aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-01 20:42:41 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-01 20:42:41 +0000
commitab90a7d8d415413f3800d32eedc815d8462c8e4e (patch)
tree394c5c07039e0c4b24bcdaaa26c8671a79c76364 /devel
parentd4de191fe9d3919f9bb9f1f9cdc1327c3f050995 (diff)
downloadports-ab90a7d8d415413f3800d32eedc815d8462c8e4e.tar.gz
ports-ab90a7d8d415413f3800d32eedc815d8462c8e4e.zip
Back in a patch which has been mistakenly removed during the 2.14 import.
Notes
Notes: svn path=/head/; revision=161131
Diffstat (limited to 'devel')
-rw-r--r--devel/libbonobo/Makefile1
-rw-r--r--devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c21
2 files changed, 22 insertions, 0 deletions
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index a2cd560e7f53..c45bc6670046 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libbonobo
PORTVERSION= 2.14.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c b/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c
new file mode 100644
index 000000000000..ced10add3d34
--- /dev/null
+++ b/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c
@@ -0,0 +1,21 @@
+--- bonobo-activation/bonobo-activation-fork-server.c.orig Fri Sep 9 17:20:15 2005
++++ bonobo-activation/bonobo-activation-fork-server.c Fri Sep 9 17:31:52 2005
+@@ -359,10 +359,18 @@
+ g_source_destroy (source);
+ g_source_unref (source);
+
++ g_io_channel_shutdown (ai.ioc, FALSE, NULL);
+ g_io_channel_unref (ai.ioc);
+
+ if (use_new_loop)
+ g_main_context_unref (context);
++
++ close (iopipes[1]);
++
++ g_strfreev(newenv);
++
++ if (fd_arg != 0)
++ g_free ((char *) cmd[fd_arg]);
+
+ return CORBA_OBJECT_NIL;
+ }