aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-24 06:15:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-24 06:15:19 +0000
commiteee499a3b564f06738d98d821b448ca78670ac98 (patch)
treed8195120c31eafd71b9fa3ac0e83214a0a646cb5 /devel
parent74e1fb092513cd16a5502cc1c2e0671eaeba12eb (diff)
downloadports-eee499a3b564f06738d98d821b448ca78670ac98.tar.gz
ports-eee499a3b564f06738d98d821b448ca78670ac98.zip
- Add LICENSE
- Remove .include <bsd.port.options.mk> - Silence patch message - Use GEM_NAME - Cosmetic change - Update pkg-descr - Update WWW - Take maintainership
Notes
Notes: svn path=/head/; revision=375409
Diffstat (limited to 'devel')
-rw-r--r--devel/rubygem-term-ansicolor/Makefile22
-rw-r--r--devel/rubygem-term-ansicolor/pkg-descr18
2 files changed, 25 insertions, 15 deletions
diff --git a/devel/rubygem-term-ansicolor/Makefile b/devel/rubygem-term-ansicolor/Makefile
index fd8909a41aca..b46a158d8990 100644
--- a/devel/rubygem-term-ansicolor/Makefile
+++ b/devel/rubygem-term-ansicolor/Makefile
@@ -6,31 +6,29 @@ PORTVERSION= 1.3.0
CATEGORIES= devel ruby
MASTER_SITES= RG
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Term::ANSIColor for Ruby
-RUN_DEPENDS= rubygem-tins>=0.8:${PORTSDIR}/devel/rubygem-tins
+LICENSE= GPLv2
+
+RUN_DEPENDS= rubygem-tins>=1.0:${PORTSDIR}/devel/rubygem-tins
+
+OPTIONS_DEFINE= EXAMPLES
USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-PLIST_FILES+= bin/colortab bin/term_display bin/term_mandel
-
+PLIST_FILES= bin/colortab bin/term_display bin/term_mandel
PORTEXAMPLES= cdiff decolor
-OPTIONS_DEFINE= EXAMPLES
-
-.include <bsd.port.options.mk>
-
post-patch:
# Chop out the cdiff and decolor binaries; these should be installed to
# EXAMPLESDIR
- ${REINPLACE_CMD} -e '/^- [cd][de][ic][fo][fl]o*r*$$/d' \
- ${WRKSRC}/term-ansicolor-${PORTVERSION}.gemspec
+ @${REINPLACE_CMD} -e '/^- [cd][de][ic][fo][fl]o*r*$$/d' ${WRKSRC}/${GEM_NAME}.gemspec
post-install:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${PORTEXAMPLES:S,^,${WRKSRC}/bin/,} ${STAGEDIR}${EXAMPLESDIR}/
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ cd ${WRKSRC}/bin/ && ${INSTALL_SCRIPT} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}/
.include <bsd.port.mk>
diff --git a/devel/rubygem-term-ansicolor/pkg-descr b/devel/rubygem-term-ansicolor/pkg-descr
index cc5e4a2e5403..ae890e9e82bc 100644
--- a/devel/rubygem-term-ansicolor/pkg-descr
+++ b/devel/rubygem-term-ansicolor/pkg-descr
@@ -1,11 +1,23 @@
Small Ruby library that colors strings using ANSI escape sequences.
It's possible to use constants:
- include Term::ANSIColor
print red, bold, "red bold", reset, "\n"
- or
+or unary functions:
print red(bold("red bold")), "\n"
-WWW: http://rubygems.org/gems/term-ansicolor/
+Blockforms do also autoreset at the block's end:
+
+ print red { bold { "red bold" } }, "\n"
+
+It's also possible to use this module as Mixin for classes of objects that
+respond to :to_str, e.g. String.
+
+ class String
+ include Term::ANSIColor
+ end
+ print "red bold".red.bold, "\n"
+
+WWW: http://flori.github.io/term-ansicolor/
+RG: https://rubygems.org/gems/term-ansicolor