aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-01 12:16:36 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-01 12:16:36 +0000
commit52636e09799fefb51ffebb46fa980502c77849b2 (patch)
tree7637aae5d88356112773991c4332637821d9fcd0 /devel
parentba04f34e7e577dd92c150780e9914c939d368ec4 (diff)
downloadports-52636e09799fefb51ffebb46fa980502c77849b2.tar.gz
ports-52636e09799fefb51ffebb46fa980502c77849b2.zip
- Replace KDE4 sharedmime with USES=shared-mime-info
- Add stage support - Use options helpers - Patch sources to install man pages to standard place and remove post-install - Add kde to CATEGORIES - Amend COMMENT
Notes
Notes: svn path=/head/; revision=342127
Diffstat (limited to 'devel')
-rw-r--r--devel/piklab/Makefile45
-rw-r--r--devel/piklab/pkg-plist3
2 files changed, 16 insertions, 32 deletions
diff --git a/devel/piklab/Makefile b/devel/piklab/Makefile
index 855506f546a2..8670b21157b9 100644
--- a/devel/piklab/Makefile
+++ b/devel/piklab/Makefile
@@ -3,54 +3,35 @@
PORTNAME= piklab
PORTVERSION= 0.16.2
-CATEGORIES= devel
+CATEGORIES= devel kde
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= KDE IDE for microcontroller development
+COMMENT= KDE/Qt IDE for microcontroller development
LICENSE= GPLv2 # (or later)
-OPTIONS_DEFINE= KDE4
-OPTIONS_DEFAULT=KDE4
-
USE_BZIP2= yes
DOS2UNIX_FILES= cmake/Piklab.cmake
USE_QT4= corelib gui qt3support qtestlib xml \
moc_build qmake_build rcc_build uic_build
USES= cmake gettext readline dos2unix
-MAN1= piklab-hex.1 piklab-prog.1
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= KDE4
+OPTIONS_DEFAULT= KDE4
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MKDE4}
-USE_KDE4= automoc4 kdehier kdelibs kdeprefix sharedmime
-INSTALLS_ICONS= yes
-MAN1+= piklab.1x
-PLIST_SUB+= KDE4=""
-.else
-CMAKE_ARGS+= -DQT_ONLY:BOOL=ON \
+KDE4_USES= shared-mime-info
+KDE4_USE= KDE4=automoc4,kdehier,kdelibs,kdeprefix
+KDE4_CMAKE_OFF= -DQT_ONLY:BOOL=ON \
-DLOCALE_INSTALL_DIR:STRING="${PREFIX}/share/locale"
-PLIST_SUB+= KDE4="@comment "
-.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
+BROKEN_sparc64= does not compile on sparc64
post-patch:
@${REINPLACE_CMD} -e \
- '/man/s|^|#| ; \
- /install/s|^|#|' ${WRKSRC}/CMakeLists.txt
-
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/man/piklab-*.1 ${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MKDE4}
- ${INSTALL_MAN} ${WRKSRC}/man/piklab.1x ${MANPREFIX}/man/man1
-.endif
+ '/install/s|^|#|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ 's,share/man,man,' ${WRKSRC}/man/CMakeLists.txt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/piklab/pkg-plist b/devel/piklab/pkg-plist
index 89a038e68da6..8c11988910aa 100644
--- a/devel/piklab/pkg-plist
+++ b/devel/piklab/pkg-plist
@@ -2,6 +2,9 @@
bin/piklab-coff
bin/piklab-hex
bin/piklab-prog
+%%KDE4%%man/man1/piklab.1x.gz
+man/man1/piklab-hex.1.gz
+man/man1/piklab-prog.1.gz
%%KDE4%%share/applications/kde4/piklab.desktop
%%KDE4%%share/apps/katepart/syntax/asm-pic.xml
%%KDE4%%share/apps/katepart/syntax/coff-c-pic.xml