aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
commit93872f18cc0a948ab9c010bbe5694579bd59f8c4 (patch)
tree918c0e1660ed837a4087b57670a1b1c181c285e0 /devel
parentd7568468f977aa272698f2ab9e7164f2a52b0ad5 (diff)
downloadports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.tar.gz
ports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Notes
Notes: svn path=/head/; revision=82300
Diffstat (limited to 'devel')
-rw-r--r--devel/arm-elf-gcc295/Makefile12
-rw-r--r--devel/asis-gpl/Makefile10
-rw-r--r--devel/asis/Makefile10
-rw-r--r--devel/asmutils/Makefile12
-rw-r--r--devel/clint/Makefile12
-rw-r--r--devel/crossgo32/Makefile12
-rw-r--r--devel/ddd/Makefile12
-rw-r--r--devel/doc++/Makefile12
-rw-r--r--devel/freescope/Makefile12
-rw-r--r--devel/ixlib/Makefile12
-rw-r--r--devel/mico/Makefile12
-rw-r--r--devel/p5-File-Lock/Makefile4
-rw-r--r--devel/sdts++/Makefile6
-rw-r--r--devel/titano/Makefile12
-rw-r--r--devel/yacl/Makefile12
15 files changed, 81 insertions, 81 deletions
diff --git a/devel/arm-elf-gcc295/Makefile b/devel/arm-elf-gcc295/Makefile
index 8cbd63bbd777..9c56e44aff63 100644
--- a/devel/arm-elf-gcc295/Makefile
+++ b/devel/arm-elf-gcc295/Makefile
@@ -24,12 +24,6 @@ BUILD_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
RUN_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
${PKGNAMEPREFIX}ld:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
GCC_REV= ${DISTNAME:S/gcc-//g}
PLIST_SUB+= GCC_REV=${GCC_REV}
USE_PERL5= yes
@@ -47,6 +41,12 @@ LIBTOOLFILES= configure etc/configure gcc/configure libiberty/configure \
texinfo/testsuite/configure
MAN1= ${PKGNAMEPREFIX}g++.1 ${PKGNAMEPREFIX}gcc.1 cccp.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
.if !defined(DEFAULT_CPU)
pre-extract:
@${ECHO}
diff --git a/devel/asis-gpl/Makefile b/devel/asis-gpl/Makefile
index 71bfdd5a3649..2fd20a7dd96d 100644
--- a/devel/asis-gpl/Makefile
+++ b/devel/asis-gpl/Makefile
@@ -19,17 +19,17 @@ COMMENT= GNAT implementation of the Ada Semantic Interface Specification
BUILD_DEPENDS= adagcc:${PORTSDIR}/lang/gnat
+USE_GMAKE= yes
+MAKEFILE= "${FILESDIR}/Makefile.bsd"
+MAKE_ARGS= GMAKE=${GMAKE} PORTVERSION=${PORTVERSION} \
+ LN=${LN}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-USE_GMAKE= yes
-MAKEFILE= "${FILESDIR}/Makefile.bsd"
-MAKE_ARGS= GMAKE=${GMAKE} PORTVERSION=${PORTVERSION} \
- LN=${LN}
-
do-install:
@${MKDIR} ${PREFIX}/lib/asis
@${INSTALL_DATA} ${WRKSRC}/asis/*.ad? ${WRKSRC}/gnat/*.ad? ${WRKSRC}/obj/*.ali ${PREFIX}/lib/asis
diff --git a/devel/asis/Makefile b/devel/asis/Makefile
index 71bfdd5a3649..2fd20a7dd96d 100644
--- a/devel/asis/Makefile
+++ b/devel/asis/Makefile
@@ -19,17 +19,17 @@ COMMENT= GNAT implementation of the Ada Semantic Interface Specification
BUILD_DEPENDS= adagcc:${PORTSDIR}/lang/gnat
+USE_GMAKE= yes
+MAKEFILE= "${FILESDIR}/Makefile.bsd"
+MAKE_ARGS= GMAKE=${GMAKE} PORTVERSION=${PORTVERSION} \
+ LN=${LN}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-USE_GMAKE= yes
-MAKEFILE= "${FILESDIR}/Makefile.bsd"
-MAKE_ARGS= GMAKE=${GMAKE} PORTVERSION=${PORTVERSION} \
- LN=${LN}
-
do-install:
@${MKDIR} ${PREFIX}/lib/asis
@${INSTALL_DATA} ${WRKSRC}/asis/*.ad? ${WRKSRC}/gnat/*.ad? ${WRKSRC}/obj/*.ali ${PREFIX}/lib/asis
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index 6894d0245938..c279c95938cd 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -15,12 +15,6 @@ COMMENT= A set of UNIX utilities written in assembly language
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
@@ -38,6 +32,12 @@ BINARIES= asmutils basename cat chmod chown chroot cp cpuinfo date \
DOCFILES= Asmutils-HOWTO acknowledgements endorsements history \
index s-contrib s-debug s-include s-layout s-optimize
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@(${SED} -e 's,%%KERNEL%%,${OSREL:S/.//g},g' ${WRKSRC}/MCONFIG > ${WRKDIR}/foo \
&& ${MV} ${WRKDIR}/foo ${WRKSRC}/MCONFIG)
diff --git a/devel/clint/Makefile b/devel/clint/Makefile
index a7306ff0e1a7..f8ebc9e43514 100644
--- a/devel/clint/Makefile
+++ b/devel/clint/Makefile
@@ -16,18 +16,18 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A static source code checker for C++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_PYTHON= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
diff --git a/devel/crossgo32/Makefile b/devel/crossgo32/Makefile
index dd9301c4c8e8..fa237a9cf1a8 100644
--- a/devel/crossgo32/Makefile
+++ b/devel/crossgo32/Makefile
@@ -19,12 +19,6 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} dosrel-1.0${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross Development Environment for 32-bit DOS
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=${TARGET}
USE_GMAKE= yes
@@ -39,6 +33,12 @@ MAN1= i386-go32-ar.1 i386-go32-nm.1 i386-go32-objdump.1\
DOCDIR= ${PREFIX}/share/doc/crossgo32
GO32DIR= ${PREFIX}/share/crossgo32
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-extract:
${MV} ${WRKDIR}/dosrel-1.0/ ${WRKSRC}
diff --git a/devel/ddd/Makefile b/devel/ddd/Makefile
index 505134b56825..1bdc8417924d 100644
--- a/devel/ddd/Makefile
+++ b/devel/ddd/Makefile
@@ -15,12 +15,6 @@ MASTER_SITE_SUBDIR= ddd
MAINTAINER= lioux@FreeBSD.org
COMMENT= Data Display Debugger -- a common graphical front-end for GDB/DBX/XDB
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-motif-libraries="${LIBXMDIR}" \
@@ -45,6 +39,12 @@ LIBXMDIR!= ${ECHO_CMD} ${MOTIFLIB} | ${SED} -e 's/-L//g' | ${AWK} '{print $$1}'
LIBXMDIR= ${X11BASE}
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
${RM} -fv ${WRKSRC}/ddd/ddd.info*
${RM} -fv ${WRKSRC}/ddd/ddd-themes.info*
diff --git a/devel/doc++/Makefile b/devel/doc++/Makefile
index 8d1dc53dac55..6b2108941f73 100644
--- a/devel/doc++/Makefile
+++ b/devel/doc++/Makefile
@@ -18,12 +18,6 @@ RUN_DEPENDS= tex:${PORTSDIR}/print/teTeX \
gs:${PORTSDIR}/print/ghostscript-gnu \
anytopnm:${PORTSDIR}/graphics/netpbm
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -61,6 +55,12 @@ ADDITIONAL_DOCS= ClassGraph.class \
supportedTeXmacros.html \
toc.html
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-install:
.if !defined(NOPORTSDOCS)
${MKDIR} ${PREFIX}/share/doc/doc++
diff --git a/devel/freescope/Makefile b/devel/freescope/Makefile
index 633c86a271a7..793a145e451b 100644
--- a/devel/freescope/Makefile
+++ b/devel/freescope/Makefile
@@ -16,12 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Source code browsing on UNIX-like operating systems
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_REINPLACE= yes
@@ -29,6 +23,12 @@ GNU_CONFIGURE= yes
MAN1= freescope.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|CFLAGS=.*$$|CFLAGS="\$$CFLAGS"|g ; \
s|CXXFLAGS=.*$$|CXXFLAGS="\$$CXXFLAGS"|g ; \
diff --git a/devel/ixlib/Makefile b/devel/ixlib/Makefile
index 0eca1515f596..e5525b40a44b 100644
--- a/devel/ixlib/Makefile
+++ b/devel/ixlib/Makefile
@@ -18,16 +18,16 @@ COMMENT= A small C++ tools library based on STL
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 98325b09208e..a26df18608c4 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -13,12 +13,6 @@ MASTER_SITES= http://www.mico.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= A CORBA 2.0 implementation which goal is freely available
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
WRKSRC= ${WRKDIR}/mico
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -32,6 +26,12 @@ MAN1= idl.1 imr.1 nsadmin.1
MAN5= micorc.5
MAN8= ird.8 micod.8 nsd.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s,so.1.0,so, ;s,-O2,${CFLAGS}," ${WRKSRC}/configure
diff --git a/devel/p5-File-Lock/Makefile b/devel/p5-File-Lock/Makefile
index b92ffdb882c5..aade9d867f6e 100644
--- a/devel/p5-File-Lock/Makefile
+++ b/devel/p5-File-Lock/Makefile
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl5 module for file locking (flock,fcntl)
+PERL_CONFIGURE= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-PERL_CONFIGURE= yes
-
.include <bsd.port.post.mk>
diff --git a/devel/sdts++/Makefile b/devel/sdts++/Makefile
index 74fd7030b8a9..091fb7680e3b 100644
--- a/devel/sdts++/Makefile
+++ b/devel/sdts++/Makefile
@@ -19,13 +19,13 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:site1 \
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library for SDTS related development
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-boost=${WRKDIR}/boost_1_27_0
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Configure fails"
.endif
-USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-boost=${WRKDIR}/boost_1_27_0
-
.include <bsd.port.post.mk>
diff --git a/devel/titano/Makefile b/devel/titano/Makefile
index cc722e18569e..5d0ac45615f2 100644
--- a/devel/titano/Makefile
+++ b/devel/titano/Makefile
@@ -17,12 +17,6 @@ COMMENT= An IDE for GNOME desktop
LIB_DEPENDS= gtkeditor.0:${PORTSDIR}/x11-toolkits/libgtkeditor
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
WRKSRC= ${WRKDIR}/${DISTNAME:S/b//}
USE_REINPLACE= yes
@@ -31,6 +25,12 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
diff --git a/devel/yacl/Makefile b/devel/yacl/Makefile
index b3aa429f628e..1efbf931df41 100644
--- a/devel/yacl/Makefile
+++ b/devel/yacl/Makefile
@@ -14,12 +14,6 @@ DISTNAME= yacl-0170-beta
MAINTAINER= ports@freebsd.org
COMMENT= Portable programming library for C++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
NO_WRKSUBDIR= yes
USE_ZIP= yes
MAKE_ENV= YACLPATH=${WRKDIR}
@@ -29,6 +23,12 @@ ALL_TARGET= yacl
USE_MOTIF= true
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-build:
@(cd ${WRKSRC}/apps/bmpview; ${MAKE} ${MAKE_ENV} -f gnuc.mak)
@(cd ${WRKSRC}/apps/dlged; ${MAKE} ${MAKE_ENV} -f gnuc.mak)