aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-08 08:17:18 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-08 08:17:18 +0000
commit81e19be8c67b635fb62a699ee7a28006df34b374 (patch)
treed6facc58aa1a9d71c2a5555d8afdb83cf7fc4d94 /devel
parent4728f4f68580c9c9e8d57c358b3b2bbc56799bc3 (diff)
downloadports-81e19be8c67b635fb62a699ee7a28006df34b374.tar.gz
ports-81e19be8c67b635fb62a699ee7a28006df34b374.zip
Update to 0.15.
Notes
Notes: svn path=/head/; revision=195210
Diffstat (limited to 'devel')
-rw-r--r--devel/devhelp/Makefile38
-rw-r--r--devel/devhelp/distinfo6
-rw-r--r--devel/devhelp/files/patch-configure41
-rw-r--r--devel/devhelp/files/patch-configure.in13
-rw-r--r--devel/devhelp/files/patch-ltmain.sh51
-rw-r--r--devel/devhelp/files/patch-src_dh-base.c23
-rw-r--r--devel/devhelp/pkg-plist36
7 files changed, 75 insertions, 133 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 17e156a5ed9c..612324e667e4 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= devhelp
-PORTVERSION= 0.10
-PORTREVISION= 6
+PORTVERSION= 0.15
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C,^([[:digit:]]+\.[[:digit:]]+).*,\1,}
@@ -19,43 +18,60 @@ COMMENT= Developer help browser for GNOME 2
BUILD_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
RUN_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZILLA= mozilla
+MOZILLA= firefox
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
-.else
-.if ${WITH_MOZILLA} == "firefox"
MOZILLA= firefox
+.else
+.if ${WITH_MOZILLA} == "xulrunner"
+MOZILLA= xulrunner
.elif ${WITH_MOZILLA} == "seamonkey"
MOZILLA= seamonkey
.endif
.endif
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_XLIB= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
USE_LDCONFIG= ${LOCALBASE}/lib/${MOZILLA}
GCONF_SCHEMAS= devhelp.schemas
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-mozilla=${MOZILLA}
+CONFIGURE_ARGS= --with-gecko=${MOZILLA}
+
+OPTIONS= GEDIT "Enable GEdit plug-in support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GEDIT)
+BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
+RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
+PLIST_SUB+= GEDIT=""
+.else
+PLIST_SUB+= GEDIT="@comment "
+.endif
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX}|${SED} -E 's,.*share/nls/.+$$,,g;s,^@dirrm share/((gnome/[^d]|pixmaps|application|locale).*|gnome$$),,;s,^@dirrm etc/gconf.*,,;s,^etc/gconf/gconf.*,,'|${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
+post-patch:
+.if defined(WITHOUT_GEDIT)
+ @${REINPLACE_CMD} -e 's|gedit-plugin||' \
+ ${WRKSRC}/misc/Makefile.in
+.endif
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " By default the port uses www/firefox for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " firefox seamonkey "
+ @${ECHO_MSG} " xulrunner seamonkey "
@${ECHO_MSG} ""
.include <bsd.port.post.mk>
diff --git a/devel/devhelp/distinfo b/devel/devhelp/distinfo
index b783f7ae2f37..34eb732e9b13 100644
--- a/devel/devhelp/distinfo
+++ b/devel/devhelp/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/devhelp-0.10.tar.bz2) = 14374f2a9bf952e58e2c4674afd2c6d6
-SHA256 (gnome2/devhelp-0.10.tar.bz2) = 4c8b96cbfcf75bc11cc2de2e071cd7593b6b4a7d9f0469f5cbdffa8f95a295a4
-SIZE (gnome2/devhelp-0.10.tar.bz2) = 403189
+MD5 (gnome2/devhelp-0.15.tar.bz2) = e5ec0eebc5313c0d11c2371b2b1a9c16
+SHA256 (gnome2/devhelp-0.15.tar.bz2) = f10cfa64f61ae0acd4ec25e9338c3e77175c43957b8ed1886f970183d7510ec6
+SIZE (gnome2/devhelp-0.15.tar.bz2) = 457445
diff --git a/devel/devhelp/files/patch-configure b/devel/devhelp/files/patch-configure
deleted file mode 100644
index d0f4d380dcfb..000000000000
--- a/devel/devhelp/files/patch-configure
+++ /dev/null
@@ -1,41 +0,0 @@
---- configure.orig Wed Dec 27 12:37:13 2006
-+++ configure Wed Dec 27 12:41:54 2006
-@@ -1047,9 +1047,9 @@
- include additional configurations [automatic]
- --with-gconf-source=sourceaddress Config database for installing schema files.
- --with-gconf-schema-file-dir=dir Directory for installing schema files.
-- --with-mozilla[=mozilla|firefox|thunderbird]
-- Whether to use mozilla, firefox or thunderbird
-- gtkmozembed (default: mozilla)
-+ --with-mozilla[=mozilla|firefox|seamonkey|thunderbird]
-+ Whether to use mozilla, firefox, seamonkey
-+ or thunderbird gtkmozembed (default: mozilla)
- --with-zlib=DIR use libz in DIR
-
- Some influential environment variables:
-@@ -20253,6 +20253,8 @@
- MOZILLA=mozilla
- elif pkg-config --exists firefox-gtkmozembed; then
- MOZILLA=firefox
-+ elif pkg-config --exists seamonkey-gtkmozembed; then
-+ MOZILLA=seamonkey
- elif pkg-config --exists thunderbird-gtkmozembed; then
- MOZILLA=thunderbird
- else
-@@ -20260,7 +20262,7 @@
- echo "$as_me: error: no mozilla installation found" >&2;}
- { (exit 1); exit 1; }; }
- fi
--elif test "x$with_mozilla" != "xmozilla" -a "x$with_mozilla" != "xfirefox" -a "x$with_mozilla" != "xthunderbird"; then
-+elif test "x$with_mozilla" != "xmozilla" -a "x$with_mozilla" != "xfirefox" -a "x$with_mozilla" != "xseamonkey" -a "x$with_mozilla" != "xthunderbird"; then
- { { echo "$as_me:$LINENO: error: unknown mozilla name ($MOZILLA)" >&5
- echo "$as_me: error: unknown mozilla name ($MOZILLA)" >&2;}
- { (exit 1); exit 1; }; }
-@@ -20274,6 +20276,7 @@
- case "$MOZILLA" in
- mozilla) min_version=1.7 flavour=mozilla ;;
- firefox) min_version=0.10 flavour=toolkit ;;
-+seamonkey) min_version=1.0 flavour=toolkit ;;
- thunderbird) min_version=0.8 flavour=toolkit ;;
- esac
-
diff --git a/devel/devhelp/files/patch-configure.in b/devel/devhelp/files/patch-configure.in
deleted file mode 100644
index 25d3d73f4c5d..000000000000
--- a/devel/devhelp/files/patch-configure.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.in.orig Wed Dec 27 12:40:09 2006
-+++ configure.in Wed Dec 27 12:42:54 2006
-@@ -44,8 +44,8 @@
-
- MOZILLA=
- AC_ARG_WITH([mozilla],
-- AC_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|thunderbird@:>@],
-- [Whether to use mozilla, firefox or thunderbird gtkmozembed (default: mozilla)]),
-+ AC_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|seamonkey|thunderbird@:>@],
-+ [Whether to use mozilla, firefox, seamonkey or thunderbird gtkmozembed (default: mozilla)]),
- [MOZILLA="$withval"])
-
- dnl try to autodetect: if mozilla exists, use it, else try firefox, then thunderbird
diff --git a/devel/devhelp/files/patch-ltmain.sh b/devel/devhelp/files/patch-ltmain.sh
deleted file mode 100644
index d2334e2a55e7..000000000000
--- a/devel/devhelp/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Sun Jun 29 11:51:47 2003
-+++ ltmain.sh Sun Jun 29 21:02:37 2003
-@@ -1280,7 +1280,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1290,8 +1290,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3000,6 +3008,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5428,10 +5439,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/devhelp/files/patch-src_dh-base.c b/devel/devhelp/files/patch-src_dh-base.c
index 8e174831a535..dc989e10989c 100644
--- a/devel/devhelp/files/patch-src_dh-base.c
+++ b/devel/devhelp/files/patch-src_dh-base.c
@@ -1,10 +1,13 @@
---- src/dh-base.c.orig Sat Jun 28 22:16:34 2003
-+++ src/dh-base.c Sun Jun 29 13:40:23 2003
-@@ -222,6 +222,7 @@
-
- /* Insert the books from default gtk-doc install path. */
- base_add_books (base, DATADIR "/gtk-doc/html");
-+ base_add_books (base, DATADIR "/../doc"); // FreeBSD default doc path
- base_add_books (base, "/usr/share/gtk-doc/html");
- base_add_books (base, DATADIR "/devhelp/books");
- dir = g_build_filename (g_get_home_dir (), ".devhelp", "books", NULL);
+--- src/dh-base.c.orig Tue May 15 13:00:24 2007
++++ src/dh-base.c Sun Jul 8 03:48:13 2007
+@@ -233,6 +233,10 @@ base_add_books_in_data_dir (DhBase *base
+ dir = g_build_filename (data_dir, "devhelp", "books", NULL);
+ base_add_books (base, dir);
+ g_free (dir);
++
++ dir = g_build_filename (data_dir, "..", "doc", NULL);
++ base_add_books (base, dir);
++ g_free (dir);
+ }
+
+ static void
diff --git a/devel/devhelp/pkg-plist b/devel/devhelp/pkg-plist
index de6f9ae76e79..5cf0427bf4bc 100644
--- a/devel/devhelp/pkg-plist
+++ b/devel/devhelp/pkg-plist
@@ -10,34 +10,49 @@ include/devhelp-1.0/devhelp/dh-preferences.h
include/devhelp-1.0/devhelp/dh-search.h
include/devhelp-1.0/devhelp/dh-util.h
include/devhelp-1.0/devhelp/dh-window.h
+include/devhelp-1.0/devhelp/eggfindbar.h
+%%GEDIT%%lib/gedit-2/plugins/devhelp.gedit-plugin
+%%GEDIT%%lib/gedit-2/plugins/devhelp/__init__.py
+%%GEDIT%%lib/gedit-2/plugins/devhelp/__init__.pyc
+%%GEDIT%%lib/gedit-2/plugins/devhelp/__init__.pyo
+%%GEDIT%%lib/gedit-2/plugins/devhelp/devhelp.py
+%%GEDIT%%lib/gedit-2/plugins/devhelp/devhelp.pyc
+%%GEDIT%%lib/gedit-2/plugins/devhelp/devhelp.pyo
lib/libdevhelp-1.a
lib/libdevhelp-1.la
lib/libdevhelp-1.so
lib/libdevhelp-1.so.0
libdata/pkgconfig/libdevhelp-1.0.pc
share/gnome/applications/devhelp.desktop
+share/gnome/devhelp/default-prefs.js
share/gnome/devhelp/devhelp.glade
share/gnome/devhelp/dtd/devhelp-1.dtd
share/gnome/devhelp/images/book_closed.png
share/gnome/devhelp/images/book_open.png
share/gnome/devhelp/images/helpdoc.png
share/gnome/devhelp/ui/window.ui
-share/gnome/mime-info/devhelp.keys
-share/gnome/mime-info/devhelp.mime
-share/gnome/pixmaps/devhelp.png
+share/icons/hicolor/48x48/apps/devhelp.png
+share/icons/hicolor/scalable/apps/devhelp.svg
share/locale/am/LC_MESSAGES/devhelp.mo
+share/locale/ar/LC_MESSAGES/devhelp.mo
share/locale/az/LC_MESSAGES/devhelp.mo
share/locale/be/LC_MESSAGES/devhelp.mo
+share/locale/be@latin/LC_MESSAGES/devhelp.mo
+share/locale/bg/LC_MESSAGES/devhelp.mo
+share/locale/bn_IN/LC_MESSAGES/devhelp.mo
share/locale/ca/LC_MESSAGES/devhelp.mo
share/locale/cs/LC_MESSAGES/devhelp.mo
share/locale/da/LC_MESSAGES/devhelp.mo
share/locale/de/LC_MESSAGES/devhelp.mo
+share/locale/dz/LC_MESSAGES/devhelp.mo
share/locale/el/LC_MESSAGES/devhelp.mo
share/locale/en_CA/LC_MESSAGES/devhelp.mo
share/locale/en_GB/LC_MESSAGES/devhelp.mo
share/locale/es/LC_MESSAGES/devhelp.mo
+share/locale/et/LC_MESSAGES/devhelp.mo
share/locale/fi/LC_MESSAGES/devhelp.mo
share/locale/fr/LC_MESSAGES/devhelp.mo
+share/locale/gl/LC_MESSAGES/devhelp.mo
share/locale/gu/LC_MESSAGES/devhelp.mo
share/locale/he/LC_MESSAGES/devhelp.mo
share/locale/hi/LC_MESSAGES/devhelp.mo
@@ -48,13 +63,15 @@ share/locale/it/LC_MESSAGES/devhelp.mo
share/locale/ja/LC_MESSAGES/devhelp.mo
share/locale/kn/LC_MESSAGES/devhelp.mo
share/locale/ko/LC_MESSAGES/devhelp.mo
+share/locale/lt/LC_MESSAGES/devhelp.mo
share/locale/lv/LC_MESSAGES/devhelp.mo
share/locale/mk/LC_MESSAGES/devhelp.mo
share/locale/ml/LC_MESSAGES/devhelp.mo
share/locale/ms/LC_MESSAGES/devhelp.mo
share/locale/nb/LC_MESSAGES/devhelp.mo
+share/locale/ne/LC_MESSAGES/devhelp.mo
share/locale/nl/LC_MESSAGES/devhelp.mo
-share/locale/no/LC_MESSAGES/devhelp.mo
+share/locale/or/LC_MESSAGES/devhelp.mo
share/locale/pa/LC_MESSAGES/devhelp.mo
share/locale/pl/LC_MESSAGES/devhelp.mo
share/locale/pt/LC_MESSAGES/devhelp.mo
@@ -62,14 +79,17 @@ share/locale/pt_BR/LC_MESSAGES/devhelp.mo
share/locale/ru/LC_MESSAGES/devhelp.mo
share/locale/rw/LC_MESSAGES/devhelp.mo
share/locale/sk/LC_MESSAGES/devhelp.mo
+share/locale/sl/LC_MESSAGES/devhelp.mo
share/locale/sq/LC_MESSAGES/devhelp.mo
share/locale/sr/LC_MESSAGES/devhelp.mo
share/locale/sr@Latn/LC_MESSAGES/devhelp.mo
share/locale/sv/LC_MESSAGES/devhelp.mo
+share/locale/th/LC_MESSAGES/devhelp.mo
share/locale/tr/LC_MESSAGES/devhelp.mo
share/locale/uk/LC_MESSAGES/devhelp.mo
share/locale/vi/LC_MESSAGES/devhelp.mo
share/locale/zh_CN/LC_MESSAGES/devhelp.mo
+share/locale/zh_HK/LC_MESSAGES/devhelp.mo
share/locale/zh_TW/LC_MESSAGES/devhelp.mo
@dirrm share/gnome/devhelp/ui
@dirrm share/gnome/devhelp/images
@@ -77,5 +97,13 @@ share/locale/zh_TW/LC_MESSAGES/devhelp.mo
@dirrm share/gnome/devhelp
@dirrm include/devhelp-1.0/devhelp
@dirrm include/devhelp-1.0
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin