aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /devel
parent090dbb7b77d15ec9d072089f51c17e73d6e22f59 (diff)
downloadports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.tar.gz
ports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Notes
Notes: svn path=/head/; revision=210636
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-ecore/Makefile8
-rw-r--r--devel/ruby-eet/Makefile6
-rw-r--r--devel/ruby-event-loop/Makefile3
-rw-r--r--devel/ruby-gems/Makefile8
-rw-r--r--devel/ruby-gems/Makefile.common53
-rw-r--r--devel/rubygem-activesupport/Makefile7
-rw-r--r--devel/rubygem-analogger/Makefile7
-rw-r--r--devel/rubygem-builder/Makefile7
-rw-r--r--devel/rubygem-daemons/Makefile7
-rw-r--r--devel/rubygem-eventmachine/Makefile7
-rw-r--r--devel/rubygem-facets/Makefile7
-rw-r--r--devel/rubygem-fastercsv/Makefile7
-rw-r--r--devel/rubygem-fastthread/Makefile7
-rw-r--r--devel/rubygem-gem_plugin/Makefile9
-rw-r--r--devel/rubygem-highline/Makefile7
-rw-r--r--devel/rubygem-hoe/Makefile11
-rw-r--r--devel/rubygem-inline/Makefile7
-rw-r--r--devel/rubygem-json/Makefile7
-rw-r--r--devel/rubygem-needle/Makefile7
-rw-r--r--devel/rubygem-open4/Makefile5
-rw-r--r--devel/rubygem-parsetree/Makefile7
-rw-r--r--devel/rubygem-ptreloaded/Makefile7
-rw-r--r--devel/rubygem-rake/Makefile8
-rw-r--r--devel/rubygem-rapt/Makefile7
-rw-r--r--devel/rubygem-rascut/Makefile11
-rw-r--r--devel/rubygem-rgl/Makefile7
-rw-r--r--devel/rubygem-rscm/Makefile7
-rw-r--r--devel/rubygem-rspec/Makefile9
-rw-r--r--devel/rubygem-rtags/Makefile7
-rw-r--r--devel/rubygem-ruby-debug-base/Makefile7
-rw-r--r--devel/rubygem-ruby-debug/Makefile7
-rw-r--r--devel/rubygem-ruby-prof/Makefile7
-rw-r--r--devel/rubygem-ruby2ruby/Makefile7
-rw-r--r--devel/rubygem-rubyforge/Makefile7
-rw-r--r--devel/rubygem-rubyinlineaccel/Makefile7
-rw-r--r--devel/rubygem-stream/Makefile7
-rw-r--r--devel/rubygem-transactionsimple/Makefile6
-rw-r--r--devel/rubygem-tzinfo/Makefile7
-rw-r--r--devel/rubygem-zentest/Makefile7
39 files changed, 157 insertions, 169 deletions
diff --git a/devel/ruby-ecore/Makefile b/devel/ruby-ecore/Makefile
index 95ed9dc5d393..ae760a269c24 100644
--- a/devel/ruby-ecore/Makefile
+++ b/devel/ruby-ecore/Makefile
@@ -16,11 +16,11 @@ DISTNAME= ruby-ecore-${PORTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Ruby bindings for Ecore library
-BUILD_DEPENDS= ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake \
- ${RUBY_SA}/evas/rb_evas.h:${PORTSDIR}/graphics/ruby-evas
+BUILD_DEPENDS= ${RUBY_SA}/evas/rb_evas.h:${PORTSDIR}/graphics/ruby-evas
USE_BZIP2= yes
USE_RUBY= yes
+USE_RAKE= yes
USE_EFL= ecore
USE_EFL_ECORE= x11 con job evas
@@ -30,10 +30,10 @@ RUBY_SA= ${RUBY_SITEARCHLIBDIR}
do-build:
@(cd ${WRKSRC}; ${SETENV} ECORE_PREFIX=${LOCALBASE} \
- ${LOCALBASE}/bin/rake)
+ ${RAKE_BIN})
do-install:
@(cd ${WRKSRC}; ${SETENV} ECORE_PREFIX=${LOCALBASE} \
- ${LOCALBASE}/bin/rake install)
+ ${RAKE_BIN} install)
.include <bsd.port.post.mk>
diff --git a/devel/ruby-eet/Makefile b/devel/ruby-eet/Makefile
index ab0fd6496bad..00d1c4abcffd 100644
--- a/devel/ruby-eet/Makefile
+++ b/devel/ruby-eet/Makefile
@@ -14,17 +14,17 @@ DISTNAME= ruby-eet-${PORTVERSION}
MAINTAINER= alexbl@FreeBSD.org
COMMENT= Ruby support for reading and writing EET files
-BUILD_DEPENDS= ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake
LIB_DEPENDS= eet.9:${PORTSDIR}/devel/eet
USE_RUBY= yes
+USE_RAKE= yes
.include <bsd.port.pre.mk>
do-build:
- @cd ${WRKSRC} && ${LOCALBASE}/bin/rake PREFIX=${PREFIX}/
+ @cd ${WRKSRC} && ${RAKE_BIN} PREFIX=${PREFIX}/
do-install:
- @cd ${WRKSRC} && ${LOCALBASE}/bin/rake PREFIX=${PREFIX}/ install
+ @cd ${WRKSRC} && ${RAKE_BIN} PREFIX=${PREFIX}/ install
.include <bsd.port.post.mk>
diff --git a/devel/ruby-event-loop/Makefile b/devel/ruby-event-loop/Makefile
index 8ae39383a56c..f4986ce4185f 100644
--- a/devel/ruby-event-loop/Makefile
+++ b/devel/ruby-event-loop/Makefile
@@ -14,9 +14,8 @@ PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
MAINTAINER= alexbl@FreeBSD.org
COMMENT= An Event loop for Ruby
-BUILD_DEPENDS= ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake
-
USE_RUBY= yes
+USE_RAKE= yes
do-configure:
@cd ${WRKSRC} && ${RUBY} setup.rb config --prefix=${PREFIX}
diff --git a/devel/ruby-gems/Makefile b/devel/ruby-gems/Makefile
index 513fd5482bde..347d07ad79c5 100644
--- a/devel/ruby-gems/Makefile
+++ b/devel/ruby-gems/Makefile
@@ -27,10 +27,16 @@ NO_BUILD= yes
PLIST_SUB+= DISTNAME="${DISTNAME}"
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 1.9
+IGNORE= already included in this ruby distribution
+.endif
+
do-install:
cd ${WRKSRC}; ${RUBY} ${RUBY_SETUP}
post-install:
@${LN} -sf ${PREFIX}/bin/gem18 ${PREFIX}/bin/gem
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-gems/Makefile.common b/devel/ruby-gems/Makefile.common
deleted file mode 100644
index a6805e0897a9..000000000000
--- a/devel/ruby-gems/Makefile.common
+++ /dev/null
@@ -1,53 +0,0 @@
-# $FreeBSD$
-# Ruby gem module common settings
-
-
-BUILD_DEPENDS+= ${RUBYGEMBIN}:${PORTSDIR}/devel/ruby-gems
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-PKGNAMEPREFIX= rubygem-
-EXTRACT_SUFX= .gem
-EXTRACT_ONLY=
-DIST_SUBDIR= rubygem
-
-NO_BUILD= yes
-
-REV= 1.8
-GEMS_BASE_DIR= lib/ruby/gems/${REV}
-GEMS_DIR= ${GEMS_BASE_DIR}/gems
-DOC_DIR= ${GEMS_BASE_DIR}/doc
-CACHE_DIR= ${GEMS_BASE_DIR}/cache
-SPEC_DIR= ${GEMS_BASE_DIR}/specifications
-GEM_NAME?= ${PORTNAME}-${PORTVERSION}
-GEM_LIB_DIR= ${GEMS_DIR}/${GEM_NAME}
-GEM_DOC_DIR= ${DOC_DIR}/${GEM_NAME}
-GEM_SPEC= ${SPEC_DIR}/${GEM_NAME}.gemspec
-GEM_CACHE= ${CACHE_DIR}/${GEM_NAME}.gem
-
-PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
- REV="${REV}" \
- GEMS_BASE_DIR="lib/ruby/gems/${REV}" \
- GEMS_DIR="${GEMS_DIR}" \
- DOC_DIR="${DOC_DIR}" \
- CACHE_DIR="${CACHE_DIR}" \
- SPEC_DIR="${SPEC_DIR}" \
- PORT="${PORTNAME}-${PORTVERSION}" \
- GEM_NAME="${GEM_NAME}" \
- GEM_LIB_DIR="${GEM_LIB_DIR}" \
- GEM_DOC_DIR="${GEM_DOC_DIR}" \
- GEM_SPEC="${GEM_SPEC}" \
- GEM_CACHE="${GEM_CACHE}" \
- EXTRACT_SUFX="${EXTRACT_SUFX}"
-
-RUBYGEMBIN= ${LOCALBASE}/bin/gem18
-
-.if defined(DISTFILES)
-GEMFILES= ${DISTFILES:C/:[^:]+$//}
-.else
-GEMFILES= ${DISTNAME}${EXTRACT_SUFX}
-.endif
-
-do-install:
-.for _D in ${GEMFILES}
- ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install --no-update-sources --no-ri --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${_D} -- --build-args ${CONFIGURE_ARGS}
-.endfor
diff --git a/devel/rubygem-activesupport/Makefile b/devel/rubygem-activesupport/Makefile
index 0cd545074eab..0cc39feb80c8 100644
--- a/devel/rubygem-activesupport/Makefile
+++ b/devel/rubygem-activesupport/Makefile
@@ -13,6 +13,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jw@innerewut.de
COMMENT= Utility classes and extension that are required by Rails MVC Framework
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -26,6 +29,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-analogger/Makefile b/devel/rubygem-analogger/Makefile
index cb654f2e7da8..9b565a8a3204 100644
--- a/devel/rubygem-analogger/Makefile
+++ b/devel/rubygem-analogger/Makefile
@@ -16,6 +16,7 @@ COMMENT= A fast, flexible, easy to use logging service for Ruby
BUILD_DEPENDS= rubygem-eventmachine>=0.7.0:${PORTSDIR}/devel/rubygem-eventmachine
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-builder/Makefile b/devel/rubygem-builder/Makefile
index 7324ea6d52b8..cf1c73d2b2da 100644
--- a/devel/rubygem-builder/Makefile
+++ b/devel/rubygem-builder/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@logvinov.com
COMMENT= Facilitate programatic generation of XML markup
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-daemons/Makefile b/devel/rubygem-daemons/Makefile
index d446ccfb7f42..2d2e55ef2c07 100644
--- a/devel/rubygem-daemons/Makefile
+++ b/devel/rubygem-daemons/Makefile
@@ -12,6 +12,9 @@ MASTER_SITES= RF
MAINTAINER= ports@logvinov.com
COMMENT= A toolkit to convert your script to a controllable daemon
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -25,6 +28,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-eventmachine/Makefile b/devel/rubygem-eventmachine/Makefile
index b04d295dc50f..d028555fcd96 100644
--- a/devel/rubygem-eventmachine/Makefile
+++ b/devel/rubygem-eventmachine/Makefile
@@ -12,6 +12,7 @@ MASTER_SITES= RF
MAINTAINER= ports@logvinov.com
COMMENT= A fast, simple event-processing library for Ruby programs
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-facets/Makefile b/devel/rubygem-facets/Makefile
index 32929c8c6771..a44a8b680c51 100644
--- a/devel/rubygem-facets/Makefile
+++ b/devel/rubygem-facets/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= yds@CoolRat.org
COMMENT= RubyGem port of the single most extensive additions and extensions
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-fastercsv/Makefile b/devel/rubygem-fastercsv/Makefile
index 48fe135211be..5a8b924ce310 100644
--- a/devel/rubygem-fastercsv/Makefile
+++ b/devel/rubygem-fastercsv/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= RF
MAINTAINER= ports@FreeBSD.org
COMMENT= A complete replacement to the CSV standard library
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-fastthread/Makefile b/devel/rubygem-fastthread/Makefile
index 10d8d49deaab..228b290f9971 100644
--- a/devel/rubygem-fastthread/Makefile
+++ b/devel/rubygem-fastthread/Makefile
@@ -13,6 +13,9 @@ MASTER_SITE_SUBDIR= mongrel
MAINTAINER= ports@logvinov.com
COMMENT= Optimized replacement for thread.rb primitives
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -26,6 +29,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-gem_plugin/Makefile b/devel/rubygem-gem_plugin/Makefile
index 237a28346070..a10cf75ed369 100644
--- a/devel/rubygem-gem_plugin/Makefile
+++ b/devel/rubygem-gem_plugin/Makefile
@@ -13,9 +13,12 @@ MASTER_SITE_SUBDIR= mongrel
MAINTAINER= ports@logvinov.com
COMMENT= Gem Based Plugin System
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -29,6 +32,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-highline/Makefile b/devel/rubygem-highline/Makefile
index a0d3463e16ce..fd32e290266b 100644
--- a/devel/rubygem-highline/Makefile
+++ b/devel/rubygem-highline/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pgollucci@p6m7g8.com
COMMENT= A high-level IO library for command-line interfaces
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-hoe/Makefile b/devel/rubygem-hoe/Makefile
index 9a917a1bb834..7bb153514743 100644
--- a/devel/rubygem-hoe/Makefile
+++ b/devel/rubygem-hoe/Makefile
@@ -13,10 +13,13 @@ MASTER_SITE_SUBDIR= seattlerb
MAINTAINER= jw@innerewut.de
COMMENT= A simple rake/rubygems helper for project Rakefiles
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
- rubyforge:${PORTSDIR}/devel/rubygem-rubyforge
+BUILD_DEPENDS= rubyforge:${PORTSDIR}/devel/rubygem-rubyforge
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+
post-install:
@${ECHO} bin/sow > ${TMPPLIST}
@${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
@@ -26,6 +29,4 @@ post-install:
@${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
@${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-inline/Makefile b/devel/rubygem-inline/Makefile
index 8da1280227db..ce6220aa16be 100644
--- a/devel/rubygem-inline/Makefile
+++ b/devel/rubygem-inline/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-json/Makefile b/devel/rubygem-json/Makefile
index c2301e7ec7b3..17e5a152bdd4 100644
--- a/devel/rubygem-json/Makefile
+++ b/devel/rubygem-json/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= RF
MAINTAINER= clsung@FreeBSD.org
COMMENT= Parse JSON texts and generate them from ruby data structures
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-needle/Makefile b/devel/rubygem-needle/Makefile
index 7b2733f8efca..ca9588f2694b 100644
--- a/devel/rubygem-needle/Makefile
+++ b/devel/rubygem-needle/Makefile
@@ -14,8 +14,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= r.s.a.vandomburg@nedforce.nl
COMMENT= Dependency-injection/inversion-of-control container
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
FETCH_CMD= /usr/bin/fetch -Rr
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-open4/Makefile b/devel/rubygem-open4/Makefile
index 58f531d79c55..cbc9ad6d6495 100644
--- a/devel/rubygem-open4/Makefile
+++ b/devel/rubygem-open4/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= arved@FreeBSD.org
COMMENT= Open4 manages child processes and their io handles
USE_RUBY= yes
+USE_RUBYGEMS= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-parsetree/Makefile b/devel/rubygem-parsetree/Makefile
index 024d8de567dc..646a944ed6d3 100644
--- a/devel/rubygem-parsetree/Makefile
+++ b/devel/rubygem-parsetree/Makefile
@@ -17,8 +17,9 @@ BUILD_DEPENDS= rubygem-inline>=3.6.0:${PORTSDIR}/devel/rubygem-inline \
rubygem-hoe>=1.4.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ptreloaded/Makefile b/devel/rubygem-ptreloaded/Makefile
index fe04fb6a7eb9..9e6a1104a926 100644
--- a/devel/rubygem-ptreloaded/Makefile
+++ b/devel/rubygem-ptreloaded/Makefile
@@ -20,6 +20,9 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
GEM_NAME= ${DISTNAME}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
x-generate-plist:
${ECHO} %%GEM_CACHE%% > pkg-plist.new
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},%%GEM_DOC_DIR%%,' >> pkg-plist.new
@@ -28,6 +31,4 @@ x-generate-plist:
${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm %%GEM_LIB_DIR%%,' >> pkg-plist.new
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm %%GEM_DOC_DIR%%,' >> pkg-plist.new
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rake/Makefile b/devel/rubygem-rake/Makefile
index f00e4e9f5db7..50f10b0c2aeb 100644
--- a/devel/rubygem-rake/Makefile
+++ b/devel/rubygem-rake/Makefile
@@ -13,6 +13,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jw@innerewut.de
COMMENT= Ruby Make
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
MANCOMPRESSED= yes
MAN1= rake.1
@@ -26,7 +29,10 @@ x-generate-plist:
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm %%GEM_DOC_DIR%%,' >> pkg-plist.new
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+
+.if ${RUBY_VER} == 1.9
+IGNORE= already included in ruby distribution
+.endif
post-install:
${MV} ${PREFIX}/${GEM_LIB_DIR}/doc/rake.1.gz \
diff --git a/devel/rubygem-rapt/Makefile b/devel/rubygem-rapt/Makefile
index dd6199351d6d..3a90a3c10992 100644
--- a/devel/rubygem-rapt/Makefile
+++ b/devel/rubygem-rapt/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= RF
MAINTAINER= ports@FreeBSD.org
COMMENT= Rails Plugin Tool
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rascut/Makefile b/devel/rubygem-rascut/Makefile
index 9954a2e7ac39..03a34ce3ad53 100644
--- a/devel/rubygem-rascut/Makefile
+++ b/devel/rubygem-rascut/Makefile
@@ -14,11 +14,12 @@ MASTER_SITE_SUBDIR= hotchpotch
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Ruby ActionSCript UTility
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
- mongrel_rails:${PORTSDIR}/www/rubygem-mongrel \
+BUILD_DEPENDS= mongrel_rails:${PORTSDIR}/www/rubygem-mongrel \
rackup:${PORTSDIR}/www/rubygem-rack \
fcsh:${PORTSDIR}/devel/flex_compiler_shell
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rgl/Makefile b/devel/rubygem-rgl/Makefile
index 57c774c87708..98ded754428d 100644
--- a/devel/rubygem-rgl/Makefile
+++ b/devel/rubygem-rgl/Makefile
@@ -17,6 +17,7 @@ COMMENT= Framework for graph datastructures and algorithms implemented in Ruby
RUN_DEPENDS= ${LOCALBASE}/lib/ruby/gems/1.8/specifications/stream-0.5.gemspec:${PORTSDIR}/devel/rubygem-stream
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rscm/Makefile b/devel/rubygem-rscm/Makefile
index 43a8aebc7902..a32c109c5020 100644
--- a/devel/rubygem-rscm/Makefile
+++ b/devel/rubygem-rscm/Makefile
@@ -13,6 +13,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= daniel@roe.ch
COMMENT= Ruby SCM, an SCM-independent API for accessing SCMs
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rspec/Makefile b/devel/rubygem-rspec/Makefile
index 6e66daaf1e84..dbc1a00244f5 100644
--- a/devel/rubygem-rspec/Makefile
+++ b/devel/rubygem-rspec/Makefile
@@ -13,9 +13,10 @@ MASTER_SITE_SUBDIR= rspec
MAINTAINER= romanbsd@yahoo.com
COMMENT= Behaviour Driven Development in Ruby
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rtags/Makefile b/devel/rubygem-rtags/Makefile
index 7133a47efcb8..50e4a39a40e5 100644
--- a/devel/rubygem-rtags/Makefile
+++ b/devel/rubygem-rtags/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Ruby replacement for ctags
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby-debug-base/Makefile b/devel/rubygem-ruby-debug-base/Makefile
index e25ce9e6a93a..300ddb45f847 100644
--- a/devel/rubygem-ruby-debug-base/Makefile
+++ b/devel/rubygem-ruby-debug-base/Makefile
@@ -13,6 +13,7 @@ MASTER_SITE_SUBDIR= ruby-debug
MAINTAINER= gogo@cs.uni-sb.de
COMMENT= Fast implementation of the standard Ruby debugger
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby-debug/Makefile b/devel/rubygem-ruby-debug/Makefile
index aa2797813d6e..68f18e34f5bb 100644
--- a/devel/rubygem-ruby-debug/Makefile
+++ b/devel/rubygem-ruby-debug/Makefile
@@ -15,6 +15,7 @@ COMMENT= A generic command line interface for ruby-debug
RUN_DEPENDS= rubygem-ruby-debug-base>=0.10.0:${PORTSDIR}/devel/rubygem-ruby-debug-base
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby-prof/Makefile b/devel/rubygem-ruby-prof/Makefile
index 77fb1fcb10e6..5e613edd667a 100644
--- a/devel/rubygem-ruby-prof/Makefile
+++ b/devel/rubygem-ruby-prof/Makefile
@@ -13,6 +13,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gogo@cs.uni-sb.de
COMMENT= A fast profiler for Ruby
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -26,6 +29,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby2ruby/Makefile b/devel/rubygem-ruby2ruby/Makefile
index ecfde08f0d6c..f4ebf20df0b7 100644
--- a/devel/rubygem-ruby2ruby/Makefile
+++ b/devel/rubygem-ruby2ruby/Makefile
@@ -18,6 +18,9 @@ BUILD_DEPENDS= rubygem-parsetree>=0.0:${PORTSDIR}/devel/rubygem-parsetree \
rubygem-hoe>=1.4.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
x-generate-plist:
${ECHO} bin/r2r_show > pkg-plist.new
${ECHO} %%GEM_CACHE%% >> pkg-plist.new
@@ -27,6 +30,4 @@ x-generate-plist:
${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm %%GEM_LIB_DIR%%,' >> pkg-plist.new
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm %%GEM_DOC_DIR%%,' >> pkg-plist.new
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rubyforge/Makefile b/devel/rubygem-rubyforge/Makefile
index 45ac113b0203..ee13f39adc91 100644
--- a/devel/rubygem-rubyforge/Makefile
+++ b/devel/rubygem-rubyforge/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= codeforpeople
MAINTAINER= jw@innerewut.de
COMMENT= Simplistic script which automates rubyforge operations
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rubyinlineaccel/Makefile b/devel/rubygem-rubyinlineaccel/Makefile
index 5afd40c22d94..8e969337ea87 100644
--- a/devel/rubygem-rubyinlineaccel/Makefile
+++ b/devel/rubygem-rubyinlineaccel/Makefile
@@ -20,6 +20,9 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
GEM_NAME= ${DISTNAME}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
x-generate-plist:
${ECHO} %%GEM_CACHE%% > pkg-plist.new
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},%%GEM_DOC_DIR%%,' >> pkg-plist.new
@@ -28,6 +31,4 @@ x-generate-plist:
${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm %%GEM_LIB_DIR%%,' >> pkg-plist.new
${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm %%GEM_DOC_DIR%%,' >> pkg-plist.new
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-stream/Makefile b/devel/rubygem-stream/Makefile
index 9498e007a2d5..f02c1f26cffc 100644
--- a/devel/rubygem-stream/Makefile
+++ b/devel/rubygem-stream/Makefile
@@ -16,6 +16,7 @@ MASTER_SITE_SUBDIR= fenner
MAINTAINER= uspoerlein@gmail.com
COMMENT= Interface for external iterators
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-transactionsimple/Makefile b/devel/rubygem-transactionsimple/Makefile
index 489a3fca5e04..b1aba32fb9a0 100644
--- a/devel/rubygem-transactionsimple/Makefile
+++ b/devel/rubygem-transactionsimple/Makefile
@@ -17,8 +17,8 @@ COMMENT= Simple object transaction support
BUILD_DEPENDS= rubygem-hoe>=1.3.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rubygem-tzinfo/Makefile b/devel/rubygem-tzinfo/Makefile
index bc4913765f25..c5921e5cdc30 100644
--- a/devel/rubygem-tzinfo/Makefile
+++ b/devel/rubygem-tzinfo/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= RF
MAINTAINER= clsung@FreeBSD.org
COMMENT= Daylight-savings aware timezone support for Ruby
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-zentest/Makefile b/devel/rubygem-zentest/Makefile
index 57a287e19b81..9df487fc2f0d 100644
--- a/devel/rubygem-zentest/Makefile
+++ b/devel/rubygem-zentest/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>