aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:34:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:34:59 +0000
commit2576caf9b1309a46c058e314ad6d880ecea26cbd (patch)
tree82cbefea0e15d06fdb4507b1063c5117b88be82d /devel
parent917a9e8892717719ca3d93dc883c9359fbb64b35 (diff)
downloadports-2576caf9b1309a46c058e314ad6d880ecea26cbd.tar.gz
ports-2576caf9b1309a46c058e314ad6d880ecea26cbd.zip
A C-coded Python extension module that wraps the GMP library to provide
to Python code fast multiprecision arithmetic (integer, rational, and float), random number generation, advanced number-theoretical functions, and more. WWW: http://code.google.com/p/gmpy/ PR: ports/125429 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=217029
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-gmpy/Makefile25
-rw-r--r--devel/py-gmpy/distinfo3
-rw-r--r--devel/py-gmpy/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 997b04045418..72e875388568 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2075,6 +2075,7 @@
SUBDIR += py-gdata
SUBDIR += py-generate
SUBDIR += py-geotypes
+ SUBDIR += py-gmpy
SUBDIR += py-gobject
SUBDIR += py-grouch
SUBDIR += py-icalendar
diff --git a/devel/py-gmpy/Makefile b/devel/py-gmpy/Makefile
new file mode 100644
index 000000000000..75e21523be61
--- /dev/null
+++ b/devel/py-gmpy/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-gmpy
+# Date created: 09 July 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpy
+PORTVERSION= 1.03
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Read Write And Modify MARC Bibliographic Data
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/gmpy.so
+
+.include <bsd.port.mk>
diff --git a/devel/py-gmpy/distinfo b/devel/py-gmpy/distinfo
new file mode 100644
index 000000000000..73a82f107117
--- /dev/null
+++ b/devel/py-gmpy/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpy-1.03.zip) = 7e723068ecd7078b32f344c747586592
+SHA256 (gmpy-1.03.zip) = dfb02ffd2356aee74c756ac8e235bcaa89e3e0e5199f9fd4b9dfda54c7ff71c7
+SIZE (gmpy-1.03.zip) = 86711
diff --git a/devel/py-gmpy/pkg-descr b/devel/py-gmpy/pkg-descr
new file mode 100644
index 000000000000..40dbbb94e7dd
--- /dev/null
+++ b/devel/py-gmpy/pkg-descr
@@ -0,0 +1,6 @@
+A C-coded Python extension module that wraps the GMP library to provide
+to Python code fast multiprecision arithmetic (integer, rational, and
+float), random number generation, advanced number-theoretical functions,
+and more.
+
+WWW: http://code.google.com/p/gmpy/