aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:38:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:38:21 +0000
commit32e8646bd707683ef9d019c9f5419e6d8a48d7bd (patch)
tree3e36e476b9c2671fbeff40ac24cd7573c8ca2598 /devel
parenta289f0dfc90070025f9c9e8663af4185b6a1e590 (diff)
downloadports-32e8646bd707683ef9d019c9f5419e6d8a48d7bd.tar.gz
ports-32e8646bd707683ef9d019c9f5419e6d8a48d7bd.zip
A reference implementation of the PythonGeoInterface and
the GeoJSON. WWW: http://pypi.python.org/pypi/geojson/ PR: ports/125208 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=217032
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-geojson/Makefile36
-rw-r--r--devel/py-geojson/distinfo3
-rw-r--r--devel/py-geojson/pkg-descr4
-rw-r--r--devel/py-geojson/pkg-plist12
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2a875feab82f..f5858856988e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2075,6 +2075,7 @@
SUBDIR += py-gamin
SUBDIR += py-gdata
SUBDIR += py-generate
+ SUBDIR += py-geojson
SUBDIR += py-geotypes
SUBDIR += py-gmpy
SUBDIR += py-gobject
diff --git a/devel/py-geojson/Makefile b/devel/py-geojson/Makefile
new file mode 100644
index 000000000000..5057f77395ce
--- /dev/null
+++ b/devel/py-geojson/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: py-geojson
+# Date created: 03 July, 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geojson
+PORTVERSION= 1.0b1
+CATEGORIES= devel geography python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/g/geojson/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python's Encoder/decoder for simple GIS features
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>1.9:${PORTSDIR}/devel/py-simplejson
+
+DOCSFILE= CHANGES.txt CREDITS.txt DEPENDENCIES.txt FAQ.txt \
+ GeoInterface.txt HISTORY.txt INSTALL.txt LICENSE.txt \
+ README.txt VERSION.txt
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_NOEGGINFO= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCSFILE}
+ @cd ${WRKSRC} && ${CP} ${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-geojson/distinfo b/devel/py-geojson/distinfo
new file mode 100644
index 000000000000..0892b8e3888b
--- /dev/null
+++ b/devel/py-geojson/distinfo
@@ -0,0 +1,3 @@
+MD5 (geojson-1.0b1.tar.gz) = 10863efb628d2ea76c8d674951ce2063
+SHA256 (geojson-1.0b1.tar.gz) = 61549b5dc447dcecb6f9f20593a13e87f993d3382409a2275108b32b65462aef
+SIZE (geojson-1.0b1.tar.gz) = 11586
diff --git a/devel/py-geojson/pkg-descr b/devel/py-geojson/pkg-descr
new file mode 100644
index 000000000000..5d40e0d86cdb
--- /dev/null
+++ b/devel/py-geojson/pkg-descr
@@ -0,0 +1,4 @@
+A reference implementation of the PythonGeoInterface and
+the GeoJSON draft.
+
+WWW: http://pypi.python.org/pypi/geojson/
diff --git a/devel/py-geojson/pkg-plist b/devel/py-geojson/pkg-plist
new file mode 100644
index 000000000000..43e33f853551
--- /dev/null
+++ b/devel/py-geojson/pkg-plist
@@ -0,0 +1,12 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt
+%%PORTDOCS%%%%DOCSDIR%%/DEPENDENCIES.txt
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/GeoInterface.txt
+%%PORTDOCS%%%%DOCSDIR%%/HISTORY.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/VERSION.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%