aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-08-08 06:36:53 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-08-08 06:36:53 +0000
commit5bef5ad747df450d40f7df44762bea11e76f59ac (patch)
tree067b328b281d9f11f1b6b7909b67594652563681 /devel
parent4a917313b0a855e034a82a2148602053862f74e8 (diff)
downloadports-5bef5ad747df450d40f7df44762bea11e76f59ac.tar.gz
ports-5bef5ad747df450d40f7df44762bea11e76f59ac.zip
An SVN::Dump object represents a Subversion dump.
This module follow the semantics used in the reference document: * A dump is a collection of records (SVN::Dump::Record objects). * A record is composed of a set of headers (a SVN::Dump::Headers object), a set of properties (a SVN::Dump::Property object) and an optional bloc of text (a SVN::Dump::Text object). * Some special records (delete records with a Node-kind header) recursively contain included records. WWW: http://search.cpan.org/dist/SVN-Dump/
Notes
Notes: svn path=/head/; revision=197324
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-Dump/Makefile26
-rw-r--r--devel/p5-SVN-Dump/distinfo3
-rw-r--r--devel/p5-SVN-Dump/pkg-descr13
-rw-r--r--devel/p5-SVN-Dump/pkg-plist8
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 554bd6e91e5a..caabdf51740f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1456,6 +1456,7 @@
SUBDIR += p5-SSN-Validate
SUBDIR += p5-SVN-ACL
SUBDIR += p5-SVN-Agent
+ SUBDIR += p5-SVN-Dump
SUBDIR += p5-SVN-Log
SUBDIR += p5-SVN-Mirror
SUBDIR += p5-SVN-Notify
diff --git a/devel/p5-SVN-Dump/Makefile b/devel/p5-SVN-Dump/Makefile
new file mode 100644
index 000000000000..5f76a16c7cb4
--- /dev/null
+++ b/devel/p5-SVN-Dump/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-SVN-Dump
+# Date created: Aug 8 2008
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Dump
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl interface to Subversion dumps
+
+PERL_MODBUILD= yes
+
+MAN3= SVN::Dump.3 \
+ SVN::Dump::Headers.3 \
+ SVN::Dump::Property.3 \
+ SVN::Dump::Reader.3 \
+ SVN::Dump::Record.3 \
+ SVN::Dump::Text.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Dump/distinfo b/devel/p5-SVN-Dump/distinfo
new file mode 100644
index 000000000000..ca49b8c8c082
--- /dev/null
+++ b/devel/p5-SVN-Dump/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-Dump-0.03.tar.gz) = 5152645af510bb332cb8118edeea3a35
+SHA256 (SVN-Dump-0.03.tar.gz) = af51ff287946fc539e537cf7962e0a3904517e7e75dff996aec3abc0bd70a992
+SIZE (SVN-Dump-0.03.tar.gz) = 17955
diff --git a/devel/p5-SVN-Dump/pkg-descr b/devel/p5-SVN-Dump/pkg-descr
new file mode 100644
index 000000000000..c9d21faccba4
--- /dev/null
+++ b/devel/p5-SVN-Dump/pkg-descr
@@ -0,0 +1,13 @@
+An SVN::Dump object represents a Subversion dump.
+
+This module follow the semantics used in the reference
+document:
+
+* A dump is a collection of records (SVN::Dump::Record objects).
+* A record is composed of a set of headers (a SVN::Dump::Headers
+ object), a set of properties (a SVN::Dump::Property object) and
+ an optional bloc of text (a SVN::Dump::Text object).
+* Some special records (delete records with a Node-kind header)
+ recursively contain included records.
+
+WWW: http://search.cpan.org/dist/SVN-Dump/
diff --git a/devel/p5-SVN-Dump/pkg-plist b/devel/p5-SVN-Dump/pkg-plist
new file mode 100644
index 000000000000..6d8415fb21b1
--- /dev/null
+++ b/devel/p5-SVN-Dump/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/SVN/Dump.pm
+%%SITE_PERL%%/SVN/Dump/Headers.pm
+%%SITE_PERL%%/SVN/Dump/Property.pm
+%%SITE_PERL%%/SVN/Dump/Reader.pm
+%%SITE_PERL%%/SVN/Dump/Record.pm
+%%SITE_PERL%%/SVN/Dump/Text.pm
+@dirrmtry %%SITE_PERL%%/SVN/Dump
+@dirrmtry %%SITE_PERL%%/SVN