aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-05-12 14:04:52 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-05-12 14:04:52 +0000
commitc474f947d2ae01e028eef3b9e7cd5a80f942bb24 (patch)
treeb0b24a58860ca54b453c7b0fc3aeb38ea2823d22 /devel
parentdacc280f40d2de53a1059189bf1d7869d08c6ec8 (diff)
downloadports-c474f947d2ae01e028eef3b9e7cd5a80f942bb24.tar.gz
ports-c474f947d2ae01e028eef3b9e7cd5a80f942bb24.zip
A free C++ GUI library.
Submitted by: Filip Bovyn <bovynf@awe.be> PR: ports/4192
Notes
Notes: svn path=/head/; revision=10957
Diffstat (limited to 'devel')
-rw-r--r--devel/amulet/Makefile94
-rw-r--r--devel/amulet/distinfo1
-rw-r--r--devel/amulet/files/Makefile.vars.gcc.FreeBSD61
-rw-r--r--devel/amulet/files/patch-aa47
-rw-r--r--devel/amulet/files/patch-ab11
-rw-r--r--devel/amulet/files/sample.Makefile32
-rw-r--r--devel/amulet/pkg-comment1
-rw-r--r--devel/amulet/pkg-descr24
-rw-r--r--devel/amulet/pkg-plist237
9 files changed, 508 insertions, 0 deletions
diff --git a/devel/amulet/Makefile b/devel/amulet/Makefile
new file mode 100644
index 000000000000..ad9fdf2fd721
--- /dev/null
+++ b/devel/amulet/Makefile
@@ -0,0 +1,94 @@
+# New ports collection makefile for: amulet
+# Version required: 3.0
+# Date created: 26 July 1997
+# Whom: Filip Bovyn (bovynf@awe.be)
+#
+# $Id$
+
+DISTNAME= amulet
+PKGNAME= amulet-3.0
+CATEGORIES= devel x11
+MASTER_SITES= http://www.cs.cmu.edu/afs/cs/project/amulet/amulet3/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= bovynf@awe.be
+
+USE_X11= yes
+WRKSRC= $(WRKDIR)/amulet
+MAKE_ENV+= AMULET_DIR=$(WRKSRC) AMULET_VARS_FILE=Makefile.vars.gcc.FreeBSD
+
+pre-build:
+ ${CP} $(FILESDIR)/Makefile.vars.gcc.FreeBSD $(WRKSRC)/bin
+
+do-build:
+ @(cd $(WRKSRC)/bin; $(MAKE_ENV) $(MAKE) libs)
+ @(cd $(WRKSRC)/bin; $(MAKE_ENV) $(MAKE) all)
+
+SAMPLES= av\
+ testdpy\
+ testgem\
+ testtrans\
+ testsubwins\
+ testloop\
+ testclip\
+ testpoints\
+ testwinsizes\
+ testinput\
+ testcopy\
+ testobject\
+ testopal\
+ testJIO\
+ testpolyweb\
+ testlines\
+ testgobs\
+ testmap\
+ hsv\
+ testloadsave\
+ testinter\
+ testaniminter\
+ testwidgets\
+ testselectionwidget\
+ testdragdrop\
+ testmaps\
+ testgest\
+ testfade\
+ testflip\
+ testanimators\
+ testrichtext\
+ testpixmap\
+ checkers\
+ circuit\
+ color\
+ hello\
+ goodbye_inter\
+ goodbye_button\
+ space\
+ space2\
+ timing\
+ tutorial\
+ tree\
+ example1\
+ example2
+
+do-install:
+ $(INSTALL_PROGRAM) $(WRKSRC)/lib/libamulet.so.3.0 $(PREFIX)/lib
+ $(INSTALL_PROGRAM) $(WRKSRC)/lib/libamulet-release.so.3.0 $(PREFIX)/lib
+ $(INSTALL_DATA) $(WRKSRC)/lib/libamulet-release.a $(PREFIX)/lib
+ $(LDCONFIG) -m $(PREFIX)/lib
+ $(INSTALL_PROGRAM) $(WRKSRC)/bin/gilt $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/bin/agate $(PREFIX)/bin
+ ${MKDIR} $(PREFIX)/include/amulet
+ $(INSTALL_DATA) $(WRKSRC)/include/*.h $(PREFIX)/include
+ $(INSTALL_DATA) $(WRKSRC)/include/amulet/* $(PREFIX)/include/amulet
+ ${MKDIR} $(PREFIX)/share/amulet/lib
+ $(INSTALL_DATA) $(WRKSRC)/lib/select.cl $(PREFIX)/share/amulet/lib/select.cl
+ ${MKDIR} $(PREFIX)/share/amulet/lib/images
+ $(INSTALL_DATA) $(WRKSRC)/lib/images/* $(PREFIX)/share/amulet/lib/images
+ ${MKDIR} $(PREFIX)/share/amulet/samples
+ $(INSTALL_DATA) $(FILESDIR)/sample.Makefile $(PREFIX)/share/amulet/samples
+ (for a in $(SAMPLES); \
+ do \
+ $(INSTALL_PROGRAM) $(WRKSRC)/bin/$$a $(PREFIX)/share/amulet/samples; \
+ done)
+
+.include <bsd.port.mk>
diff --git a/devel/amulet/distinfo b/devel/amulet/distinfo
new file mode 100644
index 000000000000..dda414acc411
--- /dev/null
+++ b/devel/amulet/distinfo
@@ -0,0 +1 @@
+MD5 (amulet.tar.Z) = 7208df5b773f03456bf55fb56c0b8c76
diff --git a/devel/amulet/files/Makefile.vars.gcc.FreeBSD b/devel/amulet/files/Makefile.vars.gcc.FreeBSD
new file mode 100644
index 000000000000..31407b989ebc
--- /dev/null
+++ b/devel/amulet/files/Makefile.vars.gcc.FreeBSD
@@ -0,0 +1,61 @@
+
+CC = g++
+LD = ld
+
+##
+## Parameters for Amulet programs
+##
+
+# X11 directories, uncomment and set if necessary
+X11_INC = -I/usr/X11R6/include
+X11_LIB = -L/usr/X11R6/lib
+
+# directory where Amulet will (eventually) be installed
+# defaults to its current location (AMULET_DIR)
+AMULET_ROOT=$(PREFIX)/share/amulet
+
+# compiler flags for Amulet programs
+AM_CFLAGS = -I$(AMULET_DIR)/include $(X11_INC) -Wall \
+ -DGCC -DMEMORY
+
+# libraries needed by Amulet (interactors needs math library)
+AM_LIBS = $(X11_LIB) -lX11 -lm
+
+
+##
+## Parameters for the Amulet library
+##
+
+# additional compiler flags for development version
+AM_DEVELOP = -O2 -DDEBUG -g -DAMULET2_CONVERSION
+
+# additional compiler flags for release version
+AM_RELEASE = -O2 -DAMULET2_CONVERSION
+
+# additional compiler flags for optimized version with inspector and debugging enabled
+AM_INHOUSE = -DDEBUG -g
+
+# additional compiler flags for optimized version with inspector but no debugging symbols
+AM_NODEBUGSYM = -O2 -DDEBUG -DAMULET2_CONVERSION
+
+# Flags used to build the sample programs
+AM_SAMPLE_FLAGS = $(AM_NODEBUGSYM)
+
+# Default set of extra compiler flags
+OP = $(AM_NODEBUGSYM)
+
+# extra link flags for library test programs
+AM_LIB_LDFLAGS =
+
+# Makefile identifying the gem files for this platform
+AM_GEM_SOURCE = Makefile.gem.X
+
+# Makefile that knows how to make the Amulet library for this platform
+AM_SHARED_LIB_MAKE = Makefile.lib.gcc.shared
+AM_STATIC_LIB_MAKE = Makefile.lib.unix.static
+
+# Set of library variants for make libs
+# Note: The develop-shared library will also be build when
+# we build the samples programs. If we add it here it would
+# be build twice.
+AM_LIBS_TO_MAKE = release-shared release-static
diff --git a/devel/amulet/files/patch-aa b/devel/amulet/files/patch-aa
new file mode 100644
index 000000000000..071d2594da0b
--- /dev/null
+++ b/devel/amulet/files/patch-aa
@@ -0,0 +1,47 @@
+--- bin/Makefile.lib.gcc.shared.orig Mon Jun 23 21:37:02 1997
++++ bin/Makefile.lib.gcc.shared Mon May 11 22:48:44 1998
+@@ -27,6 +27,7 @@
+ echo "*** or upgrade to gcc 2.7.0 or later." ; \
+ echo "" ; false ; \
+ } fi
++ @touch check_gcc_version
+
+ FULL_AMULET_DEPENDENCIES = \
+ $(OPAL_MODULE) $(INTER_MODULE) $(DEBUG_MODULE) \
+@@ -49,26 +50,22 @@
+ $(AMULET_LIB):: $(AMULET_LIB_DEPENDENCIES)
+ $(SHARED_CC) $(AM_CFLAGS) $(FULL_AMULET_DEPENDENCIES) \
+ -o $(LIB_DIR)/$(AMULET_lib).so.$(V)
+- cd $(LIB_DIR); for p in $(AMULET_lib).sl $(AMULET_lib).so ; \
+- do rm -f $$p ; ln -s $(AMULET_lib).so.$(V) $$p ; done
++ touch $(AMULET_LIB)
+
+ $(GEM_LIB): $(GEM_LIB_DEPENDENCIES)
+ $(SHARED_CC) $(AM_CFLAGS) $(FULL_GEM_DEPENDENCIES) \
+ -o $(LIB_DIR)/$(GEM_lib).so.$(V)
+- cd $(LIB_DIR); for p in $(GEM_lib).sl $(GEM_lib).so ; \
+- do rm -f $$p ; ln -s $(GEM_lib).so.$(V) $$p ; done
++ touch $(GEM_LIB)
+
+ $(ORE_LIB): $(ORE_LIB_DEPENDENCIES)
+ $(SHARED_CC) $(AM_CFLAGS) $(FULL_ORE_DEPENDENCIES) \
+ -o $(LIB_DIR)/$(ORE_lib).so.$(V)
+- cd $(LIB_DIR); for p in $(ORE_lib).sl $(ORE_lib).so ; \
+- do rm -f $$p ; ln -s $(ORE_lib).so.$(V) $$p ; done
++ touch $(ORE_LIB)
+
+ $(UTILS_LIB): $(UTILS_LIB_DEPENDENCIES)
+ $(SHARED_CC) $(AM_CFLAGS) $(FULL_UTILS_DEPENDENCIES) \
+ -o $(LIB_DIR)/$(UTILS_lib).so.$(V)
+- cd $(LIB_DIR); for p in $(UTILS_lib).sl $(UTILS_lib).so ; \
+- do rm -f $$p ; ln -s $(UTILS_lib).so.$(V) $$p ; done
++ touch $(UTILS_LIB)
+
+
+ # Use these declarations to compile tests against monolithic shared libs.
+@@ -91,4 +88,4 @@
+ # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
+
+ .cc.o:
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -fpic -c $< -o $@
diff --git a/devel/amulet/files/patch-ab b/devel/amulet/files/patch-ab
new file mode 100644
index 000000000000..7c47b0c20abc
--- /dev/null
+++ b/devel/amulet/files/patch-ab
@@ -0,0 +1,11 @@
+--- bin/Makefile.orig Thu May 8 18:40:57 1997
++++ bin/Makefile Sat Jul 26 22:01:27 1997
+@@ -160,7 +160,7 @@
+ # can also build other versions of the Amulet library: optimized/static/combo
+ #
+
+-AS_DEVELOP = OP="$(AM_DEVELOP)" LIB_MODIFIER=""
++AS_DEVELOP = OP="$(AM_NODEBUGSYM)" LIB_MODIFIER=""
+ AS_RELEASE = OP="$(AM_RELEASE)" LIB_MODIFIER=-release
+ AS_INHOUSE = OP="$(AM_INHOUSE)" LIB_MODIFIER=-inhouse
+ AS_STATIC = LIB_MAKE="$(AM_STATIC_LIB_MAKE)"
diff --git a/devel/amulet/files/sample.Makefile b/devel/amulet/files/sample.Makefile
new file mode 100644
index 000000000000..dfc6de2594e5
--- /dev/null
+++ b/devel/amulet/files/sample.Makefile
@@ -0,0 +1,32 @@
+
+AM_DEVELOP= -O2 -DDEBUG -g -DAMULET2_CONVERSION
+AM_RELEASE= -O2 -DAMULET2_CONVERSION
+AM_NODEBUGSYM= -O2 -DDEBUG -DAMULET2_CONVERSION
+
+## The default build has two parameters: OP and LIB_MODIFIER
+## used to specify the variant of the Amulet library that will be used
+## OP chooses one of the sets of compiler flags:
+## AM_DEVELOP, AM_RELEASE, AM_INHOUSE, AM_NODEBUGSYM
+OP=$(AM_DEVELOP)
+
+## LIB_MODIFIER is appended to library filename to indicate particular
+## OP choice: blank for AM_DEVELOP, -release for AM_RELEASE
+LIB_MODIFIER=
+
+## To link with the release library, invoke make as follows
+## Make OP='$(AM_RELEASE)' LIB_MODIFIER=-release
+
+CFLAGS+= -I$(X11BASE)/include -DGCC -DMEMORY
+LDFLAGS+= -lamulet$(LIB_MODIFIER) -lstdc++ -lg++ \
+ -L$(X11BASE)/lib -lX11 -lm
+
+PROG= xxxx
+SRCS= xxxx.cc
+
+xxxx: xxxx.o
+ $(CC) -o xxxx $(.ALLSRC) $(LDFLAGS)
+
+xxxx.o: xxxx.cc
+ $(CXX) -c $(CXXFLAGS) $(OP) $(.IMPSRC)
+clean:
+ -rm -f *.o xxxx
diff --git a/devel/amulet/pkg-comment b/devel/amulet/pkg-comment
new file mode 100644
index 000000000000..414aced2f12b
--- /dev/null
+++ b/devel/amulet/pkg-comment
@@ -0,0 +1 @@
+A free C++ GUI library
diff --git a/devel/amulet/pkg-descr b/devel/amulet/pkg-descr
new file mode 100644
index 000000000000..ee70c0d8180c
--- /dev/null
+++ b/devel/amulet/pkg-descr
@@ -0,0 +1,24 @@
+Amulet is a toolkit for building graphical user interfaces in C++.
+
+Get the manual from:
+ http://www.cs.cmu.edu/~amulet/amulet3-documentation.html
+
+This port builds three versions of the library:
+ libamulet.so.3.0: shared library with the inspector
+ (for development)
+ libamulet-release.so.3.0: shared library without the inspector
+ libamulet-release.a: static version of the above library
+
+In addition, the following programs are installed in /usr/X11R6/bin:
+ gilt: the interface designer
+ agate: gesture training program
+
+The sample programs are installed in /usr/X11R6/share/amulet/samples.
+
+There is also a sample Makefile (sample.Makefile) in that directory
+that you can use to build amulet programs. This is an adaption
+of the Makefiles that come with amulet, which does not require the
+AMULET_DIR and AMULET_VARS_FILE to be set.
+
+Filip Bovyn
+bovynf@awe.be
diff --git a/devel/amulet/pkg-plist b/devel/amulet/pkg-plist
new file mode 100644
index 000000000000..f2df92072adb
--- /dev/null
+++ b/devel/amulet/pkg-plist
@@ -0,0 +1,237 @@
+bin/gilt
+bin/agate
+lib/libamulet.so.3.0
+lib/libamulet-release.so.3.0
+lib/libamulet-release.a
+@exec /sbin/ldconfig -m %B
+@unexec /sbin/ldconfig -R %B
+include/am_inc.h
+include/amulet.h
+include/amulet/am_io.h
+include/amulet/am_strstream.h
+include/amulet/amulet2_conversion.h
+include/amulet/anim.h
+include/amulet/debugger.h
+include/amulet/formula.h
+include/amulet/formula_advanced.h
+include/amulet/gdefs.h
+include/amulet/gem.h
+include/amulet/gemM.h
+include/amulet/gemX.h
+include/amulet/gem_image.h
+include/amulet/gesture.h
+include/amulet/idefs.h
+include/amulet/inter.h
+include/amulet/inter_advanced.h
+include/amulet/misc.h
+include/amulet/object.h
+include/amulet/object_advanced.h
+include/amulet/opal.h
+include/amulet/opal_advanced.h
+include/amulet/priority_list.h
+include/amulet/registry.h
+include/amulet/rich_text.h
+include/amulet/standard_slots.h
+include/amulet/stdvalue.h
+include/amulet/symbol_table.h
+include/amulet/text_fns.h
+include/amulet/types.h
+include/amulet/undo_dialog.h
+include/amulet/univ_lst.h
+include/amulet/univ_lst.tpl
+include/amulet/univ_map.h
+include/amulet/univ_map.tpl
+include/amulet/value_list.h
+include/amulet/web.h
+include/amulet/widgets.h
+include/amulet/widgets_advanced.h
+@dirrm include/amulet
+share/amulet/lib/select.cl
+share/amulet/lib/images/Am_med.gif
+share/amulet/lib/images/aboutamulet.gif
+share/amulet/lib/images/alien.bmp
+share/amulet/lib/images/amside.gif
+share/amulet/lib/images/amside2.gif
+share/amulet/lib/images/amtiny.gif
+share/amulet/lib/images/amulet.gif
+share/amulet/lib/images/amuletside.xbm
+share/amulet/lib/images/amulettiny.xbm
+share/amulet/lib/images/arrow.gif
+share/amulet/lib/images/arrow.xbm
+share/amulet/lib/images/bomb.gif
+share/amulet/lib/images/borg.gif
+share/amulet/lib/images/borg.xbm
+share/amulet/lib/images/borg_m.gif
+share/amulet/lib/images/borg_mask.xbm
+share/amulet/lib/images/bug.gif
+share/amulet/lib/images/bugsmall.gif
+share/amulet/lib/images/circle.xbm
+share/amulet/lib/images/corrupt_ent.gif
+share/amulet/lib/images/corrupt_eye10.gif
+share/amulet/lib/images/crosshair.xbm
+share/amulet/lib/images/dog.gif
+share/amulet/lib/images/crosshair_mask.xbm
+share/amulet/lib/images/crsshr.gif
+share/amulet/lib/images/crsshr_m.gif
+share/amulet/lib/images/diamond.gif
+share/amulet/lib/images/diamond.xbm
+share/amulet/lib/images/ds9.gif
+share/amulet/lib/images/ds9.xbm
+share/amulet/lib/images/ds9_m.gif
+share/amulet/lib/images/ds9_mask.xbm
+share/amulet/lib/images/ent.gif
+share/amulet/lib/images/ent.xbm
+share/amulet/lib/images/ent_d.gif
+share/amulet/lib/images/ent_d.xbm
+share/amulet/lib/images/eye.gif
+share/amulet/lib/images/eye1.gif
+share/amulet/lib/images/eye10.gif
+share/amulet/lib/images/eye11.gif
+share/amulet/lib/images/eye12.gif
+share/amulet/lib/images/eye13.gif
+share/amulet/lib/images/eye14.gif
+share/amulet/lib/images/eye15.gif
+share/amulet/lib/images/eye16.gif
+share/amulet/lib/images/eye17.gif
+share/amulet/lib/images/eye18.gif
+share/amulet/lib/images/eye19.gif
+share/amulet/lib/images/fun.gif
+share/amulet/lib/images/eye2.gif
+share/amulet/lib/images/eye20.gif
+share/amulet/lib/images/eye21.gif
+share/amulet/lib/images/eye22.gif
+share/amulet/lib/images/eye23.gif
+share/amulet/lib/images/eye24.gif
+share/amulet/lib/images/eye3.gif
+share/amulet/lib/images/eye4.gif
+share/amulet/lib/images/eye5.gif
+share/amulet/lib/images/eye6.gif
+share/amulet/lib/images/eye7.gif
+share/amulet/lib/images/eye8.gif
+share/amulet/lib/images/eye9.gif
+share/amulet/lib/images/fun.xbm
+share/amulet/lib/images/girl.gif
+share/amulet/lib/images/goodship.gif
+share/amulet/lib/images/grey.gif
+share/amulet/lib/images/grey.xbm
+share/amulet/lib/images/happy.gif
+share/amulet/lib/images/happy.xbm
+share/amulet/lib/images/happy_m.gif
+share/amulet/lib/images/happy_mask.xbm
+share/amulet/lib/images/hi.gif
+share/amulet/lib/images/hi.xbm
+share/amulet/lib/images/horse.gif
+share/amulet/lib/images/rom.gif
+share/amulet/lib/images/kling.gif
+share/amulet/lib/images/kling.xbm
+share/amulet/lib/images/line.xbm
+share/amulet/lib/images/opaque_Am_med.gif
+share/amulet/lib/images/opaque_amside.gif
+share/amulet/lib/images/opaque_amside2.gif
+share/amulet/lib/images/opaque_amtiny.gif
+share/amulet/lib/images/opaque_amulet.gif
+share/amulet/lib/images/opaque_arrow.gif
+share/amulet/lib/images/opaque_bomb.gif
+share/amulet/lib/images/opaque_borg.gif
+share/amulet/lib/images/opaque_bug.gif
+share/amulet/lib/images/opaque_bugsmall.gif
+share/amulet/lib/images/opaque_crsshr.gif
+share/amulet/lib/images/opaque_diamond.gif
+share/amulet/lib/images/opaque_dog.gif
+share/amulet/lib/images/opaque_ds9.gif
+share/amulet/lib/images/opaque_ent.gif
+share/amulet/lib/images/opaque_ent_d.gif
+share/amulet/lib/images/opaque_eye.gif
+share/amulet/lib/images/opaque_eye1.gif
+share/amulet/lib/images/opaque_eye10.gif
+share/amulet/lib/images/opaque_eye11.gif
+share/amulet/lib/images/opaque_eye12.gif
+share/amulet/lib/images/opaque_eye13.gif
+share/amulet/lib/images/opaque_eye14.gif
+share/amulet/lib/images/opaque_eye15.gif
+share/amulet/lib/images/opaque_eye16.gif
+share/amulet/lib/images/opaque_eye17.gif
+share/amulet/lib/images/opaque_eye18.gif
+share/amulet/lib/images/opaque_eye19.gif
+share/amulet/lib/images/opaque_eye2.gif
+share/amulet/lib/images/opaque_eye20.gif
+share/amulet/lib/images/opaque_eye21.gif
+share/amulet/lib/images/opaque_eye22.gif
+share/amulet/lib/images/opaque_eye23.gif
+share/amulet/lib/images/opaque_eye24.gif
+share/amulet/lib/images/opaque_eye3.gif
+share/amulet/lib/images/rect.xbm
+share/amulet/lib/images/opaque_eye4.gif
+share/amulet/lib/images/opaque_eye5.gif
+share/amulet/lib/images/opaque_eye6.gif
+share/amulet/lib/images/opaque_eye7.gif
+share/amulet/lib/images/opaque_eye8.gif
+share/amulet/lib/images/opaque_eye9.gif
+share/amulet/lib/images/opaque_fun.gif
+share/amulet/lib/images/opaque_girl.gif
+share/amulet/lib/images/opaque_goodship.gif
+share/amulet/lib/images/opaque_grey.gif
+share/amulet/lib/images/opaque_happy.gif
+share/amulet/lib/images/opaque_hi.gif
+share/amulet/lib/images/opaque_horse.gif
+share/amulet/lib/images/opaque_kling.gif
+share/amulet/lib/images/opaque_rom.gif
+share/amulet/lib/images/opaque_smile.gif
+share/amulet/lib/images/opaque_spaceship.gif
+share/amulet/lib/images/rom.xbm
+share/amulet/lib/images/rom_m.gif
+share/amulet/lib/images/rom_mask.xbm
+share/amulet/lib/images/smile.gif
+share/amulet/lib/images/smile.xbm
+share/amulet/lib/images/spaceship.gif
+share/amulet/lib/images/stars.gif
+@dirrm share/amulet/lib/images
+@dirrm share/amulet/lib
+share/amulet/samples/sample.Makefile
+share/amulet/samples/av
+share/amulet/samples/testdpy
+share/amulet/samples/testgem
+share/amulet/samples/testtrans
+share/amulet/samples/testsubwins
+share/amulet/samples/testloop
+share/amulet/samples/testclip
+share/amulet/samples/testpoints
+share/amulet/samples/testwinsizes
+share/amulet/samples/testinput
+share/amulet/samples/testcopy
+share/amulet/samples/testobject
+share/amulet/samples/testopal
+share/amulet/samples/testJIO
+share/amulet/samples/testpolyweb
+share/amulet/samples/testlines
+share/amulet/samples/testgobs
+share/amulet/samples/testmap
+share/amulet/samples/hsv
+share/amulet/samples/testloadsave
+share/amulet/samples/testinter
+share/amulet/samples/testaniminter
+share/amulet/samples/testwidgets
+share/amulet/samples/testselectionwidget
+share/amulet/samples/testdragdrop
+share/amulet/samples/testmaps
+share/amulet/samples/testgest
+share/amulet/samples/testfade
+share/amulet/samples/testflip
+share/amulet/samples/testanimators
+share/amulet/samples/testrichtext
+share/amulet/samples/testpixmap
+share/amulet/samples/checkers
+share/amulet/samples/circuit
+share/amulet/samples/color
+share/amulet/samples/hello
+share/amulet/samples/goodbye_inter
+share/amulet/samples/goodbye_button
+share/amulet/samples/space
+share/amulet/samples/space2
+share/amulet/samples/timing
+share/amulet/samples/tutorial
+share/amulet/samples/tree
+share/amulet/samples/example1
+share/amulet/samples/example2
+@dirrm share/amulet/samples
+@dirrm share/amulet