aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-24 21:53:40 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-24 21:53:40 +0000
commit17e6ebb2413e22ef67887c41ea39abd21891e11d (patch)
treeffc591ff45bae4bcb13d0e74f30e0fc856fdd217 /devel
parent52a16208eaba05e0c1cb0d95be24e44e71706dd2 (diff)
downloadports-17e6ebb2413e22ef67887c41ea39abd21891e11d.tar.gz
ports-17e6ebb2413e22ef67887c41ea39abd21891e11d.zip
Ruby-FFI is a ruby extension for programmatically loading dynamic libraries,
binding functions within them, and calling those functions from Ruby code. WWW: http://wiki.github.com/ffi/ffi/ PR: ports/146728 Submitted by: Christoph Kick
Notes
Notes: svn path=/head/; revision=255000
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-ffi/Makefile26
-rw-r--r--devel/rubygem-ffi/distinfo3
-rw-r--r--devel/rubygem-ffi/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 803226d8d812..867807c60a79 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2968,6 +2968,7 @@
SUBDIR += rubygem-fastercsv
SUBDIR += rubygem-fastthread
SUBDIR += rubygem-fattr
+ SUBDIR += rubygem-ffi
SUBDIR += rubygem-file-tail
SUBDIR += rubygem-gdata
SUBDIR += rubygem-gem_plugin
diff --git a/devel/rubygem-ffi/Makefile b/devel/rubygem-ffi/Makefile
new file mode 100644
index 000000000000..d87f2a9dcf84
--- /dev/null
+++ b/devel/rubygem-ffi/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: rubygem-ffi
+# Date created: 28 April 2010
+# Whom: Christoph Kick
+#
+# $FreeBSD$
+#
+
+PORTNAME= ffi
+PORTVERSION= 0.5.3
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= kick.christoph@googlemail.com
+COMMENT= Extension for dynamic libraries & binding functions
+
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES= ${GEM_LIB_DIR}/ext/ffi_c/libffi/include/ffitarget.h \
+ ${GEM_LIB_DIR}/ext/ffi_c/libffi/.libs/libffi.so \
+ ${GEM_LIB_DIR}/ext/ffi_c/libffi/.libs/libffi.la \
+ ${GEM_LIB_DIR}/ext/ffi_c/libffi/.libs/libffi_convenience.la
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ffi/distinfo b/devel/rubygem-ffi/distinfo
new file mode 100644
index 000000000000..e06c3a2c15db
--- /dev/null
+++ b/devel/rubygem-ffi/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/ffi-0.5.3.gem) = a050278709ff23ceb2eb34d529923595
+SHA256 (rubygem/ffi-0.5.3.gem) = 8589a7cdafddc97e5dfb838fa68df20f338a9512e0cc7866f425b4b9e88c0fa4
+SIZE (rubygem/ffi-0.5.3.gem) = 785920
diff --git a/devel/rubygem-ffi/pkg-descr b/devel/rubygem-ffi/pkg-descr
new file mode 100644
index 000000000000..00798de22fb7
--- /dev/null
+++ b/devel/rubygem-ffi/pkg-descr
@@ -0,0 +1,4 @@
+Ruby-FFI is a ruby extension for programmatically loading dynamic libraries,
+binding functions within them, and calling those functions from Ruby code.
+
+WWW: http://wiki.github.com/ffi/ffi/