aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-07 14:39:47 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-07 14:39:47 +0000
commit6be33926020dcfa43ec8a1bf94700238962f3b92 (patch)
treeb915338a31558eaf368cfd16cdf2b7ec1e6e80db /devel
parent79507948280cacb290417077cbdc3e8420c3f9c1 (diff)
downloadports-6be33926020dcfa43ec8a1bf94700238962f3b92.tar.gz
ports-6be33926020dcfa43ec8a1bf94700238962f3b92.zip
Update with bsd.ruby.mk. :>
Notes
Notes: svn path=/head/; revision=32391
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-filelock/Makefile28
-rw-r--r--devel/ruby-filelock/pkg-descr2
-rw-r--r--devel/ruby-filelock/pkg-plist20
-rw-r--r--devel/ruby-intl/Makefile36
-rw-r--r--devel/ruby-intl/pkg-plist18
-rw-r--r--devel/ruby-locale/Makefile33
-rw-r--r--devel/ruby-locale/pkg-plist10
-rw-r--r--devel/ruby-property/Makefile23
-rw-r--r--devel/ruby-property/pkg-plist20
-rw-r--r--devel/ruby-slang/Makefile34
-rw-r--r--devel/ruby-slang/pkg-plist26
11 files changed, 107 insertions, 143 deletions
diff --git a/devel/ruby-filelock/Makefile b/devel/ruby-filelock/Makefile
index ffd5c7b5e3f0..5d1a1d0c2287 100644
--- a/devel/ruby-filelock/Makefile
+++ b/devel/ruby-filelock/Makefile
@@ -9,39 +9,31 @@ PORTNAME= filelock
PORTVERSION= 0.2
CATEGORIES= devel ruby
MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/contrib/
-PKGNAMEPREFIX= ruby-
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
DOCS= README
EXAMPLES= test.rb tst1.rb tst2.rb tst3.rb tst4.rb
-do-configure:
- @cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
-
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/filelock
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/filelock
.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${PREFIX}/share/examples/ruby/filelock/
+ ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${RUBY_EXAMPLESDIR}/filelock/
.endfor
- ${MKDIR} ${PREFIX}/share/doc/ruby/filelock
+ ${MKDIR} ${RUBY_DOCDIR}/filelock
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/filelock/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/filelock/
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-filelock/pkg-descr b/devel/ruby-filelock/pkg-descr
index 47d3df5877b5..b690784e8da6 100644
--- a/devel/ruby-filelock/pkg-descr
+++ b/devel/ruby-filelock/pkg-descr
@@ -9,4 +9,4 @@ To be portable, a small C extension is used to minimize the time
between existence check of a lockfile and its creation.
Author: Clemens Hintze <c.hintze@gmx.net>
-WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=filelock \ No newline at end of file
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=filelock
diff --git a/devel/ruby-filelock/pkg-plist b/devel/ruby-filelock/pkg-plist
index f49eb045ce60..b234a95c6dbf 100644
--- a/devel/ruby-filelock/pkg-plist
+++ b/devel/ruby-filelock/pkg-plist
@@ -1,10 +1,10 @@
-lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/_filelock.so
-lib/ruby/site_ruby/%%RUBY_VER%%/filelock.rb
-share/examples/ruby/filelock/test.rb
-share/examples/ruby/filelock/tst1.rb
-share/examples/ruby/filelock/tst2.rb
-share/examples/ruby/filelock/tst3.rb
-share/examples/ruby/filelock/tst4.rb
-@dirrm share/examples/ruby/filelock
-share/doc/ruby/filelock/README
-@dirrm share/doc/ruby/filelock
+%%RUBY_SITEARCHLIBDIR%%/_filelock.so
+%%RUBY_SITELIBDIR%%/filelock.rb
+%%RUBY_EXAMPLESDIR%%/filelock/test.rb
+%%RUBY_EXAMPLESDIR%%/filelock/tst1.rb
+%%RUBY_EXAMPLESDIR%%/filelock/tst2.rb
+%%RUBY_EXAMPLESDIR%%/filelock/tst3.rb
+%%RUBY_EXAMPLESDIR%%/filelock/tst4.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/filelock
+%%RUBY_DOCDIR%%/filelock/README
+@dirrm %%RUBY_DOCDIR%%/filelock
diff --git a/devel/ruby-intl/Makefile b/devel/ruby-intl/Makefile
index 61fc77133f9c..b63088f1ffa7 100644
--- a/devel/ruby-intl/Makefile
+++ b/devel/ruby-intl/Makefile
@@ -9,38 +9,30 @@ PORTNAME= intl
PORTVERSION= 0.11
CATEGORIES= devel ruby
MASTER_SITES= http://www.page.sannet.ne.jp/hirata-naoto/
-PKGNAMEPREFIX= ruby-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-INSTALL_TARGET= site-install
-CONFIGURE_ARGS= --with-opt-dir="${LOCALBASE}"
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
-do-configure:
- @cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
+INSTALL_TARGET= site-install
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/intl/po/
- ${INSTALL_DATA} ${WRKSRC}/hello.rb ${PREFIX}/share/examples/ruby/intl/
- ${INSTALL_DATA} ${WRKSRC}/ja.po ${PREFIX}/share/examples/ruby/intl/po/
- ${MKDIR} ${PREFIX}/share/doc/ruby/intl/ja
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ruby/intl/
- ${INSTALL_DATA} ${WRKSRC}/README.jp ${PREFIX}/share/doc/ruby/intl/ja/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/intl/po/
+ ${INSTALL_DATA} ${WRKSRC}/hello.rb ${RUBY_EXAMPLESDIR}/intl/
+ ${INSTALL_DATA} ${WRKSRC}/ja.po ${RUBY_EXAMPLESDIR}/intl/po/
+ ${MKDIR} ${RUBY_DOCDIR}/intl/ja
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/intl/
+ ${INSTALL_DATA} ${WRKSRC}/README.jp ${RUBY_DOCDIR}/intl/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-intl/pkg-plist b/devel/ruby-intl/pkg-plist
index f082543350dc..0cf5de5731e2 100644
--- a/devel/ruby-intl/pkg-plist
+++ b/devel/ruby-intl/pkg-plist
@@ -1,9 +1,9 @@
-lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/intl.so
-share/examples/ruby/intl/hello.rb
-share/examples/ruby/intl/po/ja.po
-@dirrm share/examples/ruby/intl/po
-@dirrm share/examples/ruby/intl
-share/doc/ruby/intl/README
-share/doc/ruby/intl/ja/README.jp
-@dirrm share/doc/ruby/intl/ja
-@dirrm share/doc/ruby/intl
+%%RUBY_SITEARCHLIBDIR%%/intl.so
+%%RUBY_EXAMPLESDIR%%/intl/hello.rb
+%%RUBY_EXAMPLESDIR%%/intl/po/ja.po
+@dirrm %%RUBY_EXAMPLESDIR%%/intl/po
+@dirrm %%RUBY_EXAMPLESDIR%%/intl
+%%RUBY_DOCDIR%%/intl/README
+%%RUBY_DOCDIR%%/intl/ja/README.jp
+@dirrm %%RUBY_DOCDIR%%/intl/ja
+@dirrm %%RUBY_DOCDIR%%/intl
diff --git a/devel/ruby-locale/Makefile b/devel/ruby-locale/Makefile
index fcb6769999ef..4690175d9795 100644
--- a/devel/ruby-locale/Makefile
+++ b/devel/ruby-locale/Makefile
@@ -9,36 +9,27 @@ PORTNAME= locale
PORTVERSION= 0.2
CATEGORIES= devel ruby
MASTER_SITES= http://kafka.salem.mass.edu/~yashi/ruby/
-PKGNAMEPREFIX= ruby-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-
#USE_BZIP2= yes # only saves 500 bytes..
-
-INSTALL_TARGET= site-install
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
-do-configure:
- @cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+INSTALL_TARGET= site-install
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/locale
- ${INSTALL_DATA} ${WRKSRC}/test.rb ${PREFIX}/share/examples/ruby/locale/
- ${MKDIR} ${PREFIX}/share/doc/ruby/locale
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ruby/locale/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/locale
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${RUBY_EXAMPLESDIR}/locale/
+ ${MKDIR} ${RUBY_DOCDIR}/locale
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/locale/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-locale/pkg-plist b/devel/ruby-locale/pkg-plist
index c401c7b0d5f6..42159b51724a 100644
--- a/devel/ruby-locale/pkg-plist
+++ b/devel/ruby-locale/pkg-plist
@@ -1,5 +1,5 @@
-lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/locale.so
-share/examples/ruby/locale/test.rb
-@dirrm share/examples/ruby/locale
-share/doc/ruby/locale/README
-@dirrm share/doc/ruby/locale
+%%RUBY_SITEARCHLIBDIR%%/locale.so
+%%RUBY_EXAMPLESDIR%%/locale/test.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/locale
+%%RUBY_DOCDIR%%/locale/README
+@dirrm %%RUBY_DOCDIR%%/locale
diff --git a/devel/ruby-property/Makefile b/devel/ruby-property/Makefile
index df59c6b52edc..3b8428f2c246 100644
--- a/devel/ruby-property/Makefile
+++ b/devel/ruby-property/Makefile
@@ -9,36 +9,33 @@ PORTNAME= property
PORTVERSION= 19990308
CATEGORIES= devel ruby
MASTER_SITES= http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/
-PKGNAMEPREFIX= ruby-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
post-patch:
${PERL} -i -pe 's|rubyapi.css|../rubyapi.css|g' ${WRKSRC}/Properties-ja.html
do-install:
- ${INSTALL_DATA} ${WRKSRC}/property.rb ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/
+ ${INSTALL_DATA} ${WRKSRC}/property.rb ${RUBY_SITELIBDIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ruby/property/ja
+ ${MKDIR} ${RUBY_DOCDIR}/property/ja
.for f in property-example.rb test.default property.README Properties.html rubyapi.css
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/property
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/property
.endfor
.for f in property.README.ja Properties-ja.html
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/property/ja
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/property/ja
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-property/pkg-plist b/devel/ruby-property/pkg-plist
index 24df63d345b1..ee8d2e8b8313 100644
--- a/devel/ruby-property/pkg-plist
+++ b/devel/ruby-property/pkg-plist
@@ -1,10 +1,10 @@
-lib/ruby/site_ruby/%%RUBY_VER%%/property.rb
-share/doc/ruby/property/property-example.rb
-share/doc/ruby/property/test.default
-share/doc/ruby/property/property.README
-share/doc/ruby/property/Properties.html
-share/doc/ruby/property/rubyapi.css
-share/doc/ruby/property/ja/property.README.ja
-share/doc/ruby/property/ja/Properties-ja.html
-@dirrm share/doc/ruby/property/ja
-@dirrm share/doc/ruby/property
+%%RUBY_SITELIBDIR%%/property.rb
+%%RUBY_DOCDIR%%/property/property-example.rb
+%%RUBY_DOCDIR%%/property/test.default
+%%RUBY_DOCDIR%%/property/property.README
+%%RUBY_DOCDIR%%/property/Properties.html
+%%RUBY_DOCDIR%%/property/rubyapi.css
+%%RUBY_DOCDIR%%/property/ja/property.README.ja
+%%RUBY_DOCDIR%%/property/ja/Properties-ja.html
+@dirrm %%RUBY_DOCDIR%%/property/ja
+@dirrm %%RUBY_DOCDIR%%/property
diff --git a/devel/ruby-slang/Makefile b/devel/ruby-slang/Makefile
index 729dfdcdd20a..19ebcc9d60cb 100644
--- a/devel/ruby-slang/Makefile
+++ b/devel/ruby-slang/Makefile
@@ -14,23 +14,18 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
.if defined(WITH_JAPANESE)
LIB_DEPENDS= slang.2:${PORTSDIR}/japanese/libslang
.else
LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
.endif
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-INSTALL_TARGET= site-install
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
CONFIGURE_ARGS= --with-slang-include="${LOCALBASE}/include/slang" \
--with-slang-lib="${LOCALBASE}/lib"
-
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+INSTALL_TARGET= site-install
EXAMPLES_EN= fm.rb smgtest.rb urlview.rb
EXAMPLES_JA= pager.rb
@@ -38,32 +33,29 @@ DOCS_EN= README changes.txt
DOCS_JA= README.euc
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
.if defined(PKGNAMEPREFIX)
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}ruby-
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
.else
-PKGNAMEPREFIX= ruby-
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
.endif
-do-configure:
- @cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
-
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/slang/ja
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/slang/ja
.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/ruby/slang/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/slang/
.endfor
.for f in ${EXAMPLES_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/ruby/slang/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/slang/ja/
.endfor
- ${MKDIR} ${PREFIX}/share/doc/ruby/slang/ja
+ ${MKDIR} ${RUBY_DOCDIR}/slang/ja
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/slang/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/slang/
.endfor
.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/slang/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/slang/ja/
.endfor
.endif
diff --git a/devel/ruby-slang/pkg-plist b/devel/ruby-slang/pkg-plist
index 717afc307ef8..ab4eee33dc45 100644
--- a/devel/ruby-slang/pkg-plist
+++ b/devel/ruby-slang/pkg-plist
@@ -1,13 +1,13 @@
-lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/slanglib.so
-lib/ruby/site_ruby/%%RUBY_VER%%/slang.rb
-share/examples/ruby/slang/fm.rb
-share/examples/ruby/slang/smgtest.rb
-share/examples/ruby/slang/urlview.rb
-share/examples/ruby/slang/ja/pager.rb
-@dirrm share/examples/ruby/slang/ja
-@dirrm share/examples/ruby/slang
-share/doc/ruby/slang/README
-share/doc/ruby/slang/changes.txt
-share/doc/ruby/slang/ja/README.euc
-@dirrm share/doc/ruby/slang/ja
-@dirrm share/doc/ruby/slang
+%%RUBY_SITEARCHLIBDIR%%/slanglib.so
+%%RUBY_SITELIBDIR%%/slang.rb
+%%RUBY_EXAMPLESDIR%%/slang/fm.rb
+%%RUBY_EXAMPLESDIR%%/slang/smgtest.rb
+%%RUBY_EXAMPLESDIR%%/slang/urlview.rb
+%%RUBY_EXAMPLESDIR%%/slang/ja/pager.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/slang/ja
+@dirrm %%RUBY_EXAMPLESDIR%%/slang
+%%RUBY_DOCDIR%%/slang/README
+%%RUBY_DOCDIR%%/slang/changes.txt
+%%RUBY_DOCDIR%%/slang/ja/README.euc
+@dirrm %%RUBY_DOCDIR%%/slang/ja
+@dirrm %%RUBY_DOCDIR%%/slang