aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-13 02:34:51 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-13 02:34:51 +0000
commitbcbbd38d1559139a85ea9ac6817e3b3ef002e934 (patch)
tree92cdd03f01c1e08def0559ec7641d48a01bee249 /devel
parent3fb04ea8552a2371428ad09cbe110ed62b3c2925 (diff)
downloadports-bcbbd38d1559139a85ea9ac6817e3b3ef002e934.tar.gz
ports-bcbbd38d1559139a85ea9ac6817e3b3ef002e934.zip
Add p5-Devel-LexAlias 0.04, a perl module which does alias lexical
variables. PR: ports/100094 Submitted by: Ying-Chieh Chen
Notes
Notes: svn path=/head/; revision=167660
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Devel-LexAlias/Makefile32
-rw-r--r--devel/p5-Devel-LexAlias/distinfo3
-rw-r--r--devel/p5-Devel-LexAlias/pkg-descr20
-rw-r--r--devel/p5-Devel-LexAlias/pkg-plist7
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7d68d3082d1a..463a6cc6456f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -959,6 +959,7 @@
SUBDIR += p5-Devel-Diagram
SUBDIR += p5-Devel-Leak
SUBDIR += p5-Devel-LeakTrace
+ SUBDIR += p5-Devel-LexAlias
SUBDIR += p5-Devel-Modlist
SUBDIR += p5-Devel-ObjectTracker
SUBDIR += p5-Devel-PPPort
diff --git a/devel/p5-Devel-LexAlias/Makefile b/devel/p5-Devel-LexAlias/Makefile
new file mode 100644
index 000000000000..bceffd4df076
--- /dev/null
+++ b/devel/p5-Devel-LexAlias/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: Devel-LexAlias
+# Date created: Jul. 12, 2006
+# Whom: Ying-Chieh Chen
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-LexAlias
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Devel
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= yinjieh@csie.nctu.edu.tw
+COMMENT= A perl module which does alias lexical variables
+
+BUILD_DEPENDS= p5-Devel-Caller>=0.03:${PORTSDIR}/devel/p5-Devel-Caller
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Devel::LexAlias.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Devel-LexAlias/distinfo b/devel/p5-Devel-LexAlias/distinfo
new file mode 100644
index 000000000000..f6e07d659a43
--- /dev/null
+++ b/devel/p5-Devel-LexAlias/distinfo
@@ -0,0 +1,3 @@
+MD5 (Devel-LexAlias-0.04.tar.gz) = 7fe986f50b467fa8575a67f0729fbb1d
+SHA256 (Devel-LexAlias-0.04.tar.gz) = f610bbabc530d3771192d9a2feb31c90dea891c1cc0bd5d3c5ccd1e324cd639c
+SIZE (Devel-LexAlias-0.04.tar.gz) = 2888
diff --git a/devel/p5-Devel-LexAlias/pkg-descr b/devel/p5-Devel-LexAlias/pkg-descr
new file mode 100644
index 000000000000..d0a234df7a56
--- /dev/null
+++ b/devel/p5-Devel-LexAlias/pkg-descr
@@ -0,0 +1,20 @@
+Description from the homepage:
+
+Devel::LexAlias provides the ability to alias a lexical variable in a
+subroutines scope to one of your choosing.
+
+If you don't know why you'd want to do this, I'd suggest that you skip
+this module. If you think you have a use for it, I'd insist on it.
+
+Still here?
+
+lexalias( $where, $name, $variable )
+
+ $where refers to the subroutine in which to alias the lexical, it
+ can be a coderef or a call level such that you'd give to caller
+
+ $name is the name of the lexical within that subroutine
+
+ $variable is a reference to the variable to install at that location
+
+WWW: http://search.cpan.org/dist/Devel-LexAlias/
diff --git a/devel/p5-Devel-LexAlias/pkg-plist b/devel/p5-Devel-LexAlias/pkg-plist
new file mode 100644
index 000000000000..6b65883d130d
--- /dev/null
+++ b/devel/p5-Devel-LexAlias/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Devel/LexAlias.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LexAlias/LexAlias.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LexAlias/LexAlias.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LexAlias/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/LexAlias
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Devel