aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJean Milanez Melo <jmelo@FreeBSD.org>2006-08-08 11:35:27 +0000
committerJean Milanez Melo <jmelo@FreeBSD.org>2006-08-08 11:35:27 +0000
commit0a9f8dd1df910df5253e31c04ae42c367e97ff2c (patch)
treed7961854bb03af94e55639e85616ef0471cad7b1 /devel
parent59769e1795a51354a19a770e5011e7273511dac4 (diff)
downloadports-0a9f8dd1df910df5253e31c04ae42c367e97ff2c.tar.gz
ports-0a9f8dd1df910df5253e31c04ae42c367e97ff2c.zip
- Change to use MASTER_SITE_RUBYFORGE macro to fix fetch problem.
Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=170091
Diffstat (limited to 'devel')
-rw-r--r--devel/freeride/Makefile4
-rw-r--r--devel/ruby-flexmock/Makefile3
-rw-r--r--devel/ruby-gems/Makefile3
-rw-r--r--devel/ruby-gettext/Makefile3
-rw-r--r--devel/ruby-zoom/Makefile3
-rw-r--r--devel/rubygem-activesupport/Makefile3
-rw-r--r--devel/rubygem-daemons/Makefile3
-rw-r--r--devel/rubygem-gem_plugin/Makefile3
-rw-r--r--devel/rubygem-gettext/Makefile3
-rw-r--r--devel/rubygem-locale/Makefile3
-rw-r--r--devel/rubygem-needle/Makefile3
-rw-r--r--devel/rubygem-rake/Makefile3
-rw-r--r--devel/rubygem-rgl/Makefile3
-rw-r--r--devel/rubygem-rscm/Makefile3
-rw-r--r--devel/rubygem-transactionsimple/Makefile3
-rw-r--r--devel/rubygem-tzinfo/Makefile6
-rw-r--r--devel/rubygem-zoom/Makefile3
17 files changed, 34 insertions, 21 deletions
diff --git a/devel/freeride/Makefile b/devel/freeride/Makefile
index 5c314bafeb24..e0bab65d2f9c 100644
--- a/devel/freeride/Makefile
+++ b/devel/freeride/Makefile
@@ -8,8 +8,8 @@
PORTNAME?= ${MASTERPORTNAME}
PORTVERSION= 0.9.6
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.rubyuser.de/${MASTERPORTNAME}/ \
- http://files.rubyforge.vm.bytemark.co.uk/${MASTERPORTNAME}/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
diff --git a/devel/ruby-flexmock/Makefile b/devel/ruby-flexmock/Makefile
index 3cdc3a356b32..96fc877e1e5d 100644
--- a/devel/ruby-flexmock/Makefile
+++ b/devel/ruby-flexmock/Makefile
@@ -8,7 +8,8 @@
PORTNAME= flexmock
PORTVERSION= 0.2.1
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/9301/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ecal
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
diff --git a/devel/ruby-gems/Makefile b/devel/ruby-gems/Makefile
index 90b5725bcfee..80a665a2ea6f 100644
--- a/devel/ruby-gems/Makefile
+++ b/devel/ruby-gems/Makefile
@@ -8,7 +8,8 @@
PORTNAME= gems
PORTVERSION= 0.8.11
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/5207/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ruby${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
diff --git a/devel/ruby-gettext/Makefile b/devel/ruby-gettext/Makefile
index 55edd03ad1ec..80a6b44a3e7a 100644
--- a/devel/ruby-gettext/Makefile
+++ b/devel/ruby-gettext/Makefile
@@ -8,7 +8,8 @@
PORTNAME= gettext
PORTVERSION= 1.5.0
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/10363/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
DIST_SUBDIR= ruby
diff --git a/devel/ruby-zoom/Makefile b/devel/ruby-zoom/Makefile
index 100cd39a5f91..6f9fae498033 100644
--- a/devel/ruby-zoom/Makefile
+++ b/devel/ruby-zoom/Makefile
@@ -8,7 +8,8 @@
PORTNAME= zoom
PORTVERSION= 0.2.0
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/5601/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ruby-${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
diff --git a/devel/rubygem-activesupport/Makefile b/devel/rubygem-activesupport/Makefile
index fbf937832b3a..1a03ec76428e 100644
--- a/devel/rubygem-activesupport/Makefile
+++ b/devel/rubygem-activesupport/Makefile
@@ -7,7 +7,8 @@
PORTNAME= activesupport
PORTVERSION= 1.3.1
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/9562/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jw@innerewut.de
COMMENT= Utility classes and extension that are required by Rails MVC Framework
diff --git a/devel/rubygem-daemons/Makefile b/devel/rubygem-daemons/Makefile
index bd056911dbd4..30424ca0b7a4 100644
--- a/devel/rubygem-daemons/Makefile
+++ b/devel/rubygem-daemons/Makefile
@@ -7,7 +7,8 @@
PORTNAME= daemons
PORTVERSION= 0.4.4
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/9598/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= rgl@ruilopes.com
COMMENT= A toolkit to convert your script to a controllable daemon
diff --git a/devel/rubygem-gem_plugin/Makefile b/devel/rubygem-gem_plugin/Makefile
index 06ca7225d98d..4186d6867626 100644
--- a/devel/rubygem-gem_plugin/Makefile
+++ b/devel/rubygem-gem_plugin/Makefile
@@ -7,7 +7,8 @@
PORTNAME= gem_plugin
PORTVERSION= 0.2.1
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/9199/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= mongrel
MAINTAINER= rgl@ruilopes.com
COMMENT= Gem Based Plugin System
diff --git a/devel/rubygem-gettext/Makefile b/devel/rubygem-gettext/Makefile
index 55edd03ad1ec..80a6b44a3e7a 100644
--- a/devel/rubygem-gettext/Makefile
+++ b/devel/rubygem-gettext/Makefile
@@ -8,7 +8,8 @@
PORTNAME= gettext
PORTVERSION= 1.5.0
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/10363/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
DIST_SUBDIR= ruby
diff --git a/devel/rubygem-locale/Makefile b/devel/rubygem-locale/Makefile
index 55edd03ad1ec..80a6b44a3e7a 100644
--- a/devel/rubygem-locale/Makefile
+++ b/devel/rubygem-locale/Makefile
@@ -8,7 +8,8 @@
PORTNAME= gettext
PORTVERSION= 1.5.0
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/10363/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
DIST_SUBDIR= ruby
diff --git a/devel/rubygem-needle/Makefile b/devel/rubygem-needle/Makefile
index 901709927292..0eeae0b5973d 100644
--- a/devel/rubygem-needle/Makefile
+++ b/devel/rubygem-needle/Makefile
@@ -8,7 +8,8 @@
PORTNAME= needle
PORTVERSION= 1.3.0
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/7842/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= r.s.a.vandomburg@student.utwente.nl
COMMENT= Dependency-injection/inversion-of-control container
diff --git a/devel/rubygem-rake/Makefile b/devel/rubygem-rake/Makefile
index 33ed81e1543e..037241c67f88 100644
--- a/devel/rubygem-rake/Makefile
+++ b/devel/rubygem-rake/Makefile
@@ -7,7 +7,8 @@
PORTNAME= rake
PORTVERSION= 0.7.1
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/9498/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jw@innerewut.de
COMMENT= Ruby Make
diff --git a/devel/rubygem-rgl/Makefile b/devel/rubygem-rgl/Makefile
index 15435d513951..57c774c87708 100644
--- a/devel/rubygem-rgl/Makefile
+++ b/devel/rubygem-rgl/Makefile
@@ -9,7 +9,8 @@ PORTNAME= rgl
PORTVERSION= 0.2.3
PORTREVISION= 1
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/3958/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= uspoerlein@gmail.com
COMMENT= Framework for graph datastructures and algorithms implemented in Ruby
diff --git a/devel/rubygem-rscm/Makefile b/devel/rubygem-rscm/Makefile
index 59ebb6f8566a..351727a81115 100644
--- a/devel/rubygem-rscm/Makefile
+++ b/devel/rubygem-rscm/Makefile
@@ -7,7 +7,8 @@
PORTNAME= rscm
PORTVERSION= 0.3.16
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/7244/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= daniel@roe.ch
COMMENT= Ruby SCM, an SCM-independent API for accessing SCMs
diff --git a/devel/rubygem-transactionsimple/Makefile b/devel/rubygem-transactionsimple/Makefile
index 008e7380c1e1..6df278011d7b 100644
--- a/devel/rubygem-transactionsimple/Makefile
+++ b/devel/rubygem-transactionsimple/Makefile
@@ -7,7 +7,8 @@
PORTNAME= transactionsimple
PORTVERSION= 1.3.0
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.org/frs/download.php/4334/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= trans-simple
DISTNAME= transaction-simple-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
diff --git a/devel/rubygem-tzinfo/Makefile b/devel/rubygem-tzinfo/Makefile
index 6b4fae3b8425..b383e3c617a6 100644
--- a/devel/rubygem-tzinfo/Makefile
+++ b/devel/rubygem-tzinfo/Makefile
@@ -8,10 +8,8 @@
PORTNAME= tzinfo
PORTVERSION= 0.3.0
CATEGORIES= devel rubygems
-MASTER_SITES= http://rubyforge.rubyuser.de/tzinfo/ \
- http://rubyforge.iasi.roedu.net/files/tzinfo/ \
- http://rubyforge.halostatue.info/tzinfo/ \
- http://files.rubyforge.vm.bytemark.co.uk/tzinfo/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= rgl@ruilopes.com
COMMENT= Daylight-savings aware timezone support for Ruby
diff --git a/devel/rubygem-zoom/Makefile b/devel/rubygem-zoom/Makefile
index 100cd39a5f91..6f9fae498033 100644
--- a/devel/rubygem-zoom/Makefile
+++ b/devel/rubygem-zoom/Makefile
@@ -8,7 +8,8 @@
PORTNAME= zoom
PORTVERSION= 0.2.0
CATEGORIES= devel ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/5601/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ruby-${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby