aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-15 12:18:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-15 12:18:40 +0000
commit99b190c92b0f5790c262f96113f5baf771a858a2 (patch)
treec5c126d6852c4cb19f40425e317d107148518359 /devel
parentb22644f6616ddd539c97a11682b8cb5233391d78 (diff)
downloadports-99b190c92b0f5790c262f96113f5baf771a858a2.tar.gz
ports-99b190c92b0f5790c262f96113f5baf771a858a2.zip
add libfs++ 0.1.7
C++ library which provides a file_iterator class
Notes
Notes: svn path=/head/; revision=66360
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libfs++/Makefile19
-rw-r--r--devel/libfs++/distinfo1
-rw-r--r--devel/libfs++/pkg-comment1
-rw-r--r--devel/libfs++/pkg-descr5
-rw-r--r--devel/libfs++/pkg-plist11
6 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c686ed206b61..16e942f57f89 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -278,6 +278,7 @@
SUBDIR += libevent
SUBDIR += libffi
SUBDIR += libformat
+ SUBDIR += libfs++
SUBDIR += libg++
SUBDIR += libgetline
SUBDIR += libghthash
diff --git a/devel/libfs++/Makefile b/devel/libfs++/Makefile
new file mode 100644
index 000000000000..dcacee228759
--- /dev/null
+++ b/devel/libfs++/Makefile
@@ -0,0 +1,19 @@
+# ex:ts=8
+# Ports collection makefile for: libfs++
+# Date created: Sep 14, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libfs++
+PORTVERSION= 0.1.7
+CATEGORIES= devel
+MASTER_SITES= http://bluebat.dnsalias.org/software/libfs++/
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libfs++/distinfo b/devel/libfs++/distinfo
new file mode 100644
index 000000000000..030e6785eee2
--- /dev/null
+++ b/devel/libfs++/distinfo
@@ -0,0 +1 @@
+MD5 (libfs++-0.1.7.tar.gz) = 7c0389137404780d70af881ad4c0f9ac
diff --git a/devel/libfs++/pkg-comment b/devel/libfs++/pkg-comment
new file mode 100644
index 000000000000..ec0a7c2c9a2e
--- /dev/null
+++ b/devel/libfs++/pkg-comment
@@ -0,0 +1 @@
+C++ library which provides a file_iterator class
diff --git a/devel/libfs++/pkg-descr b/devel/libfs++/pkg-descr
new file mode 100644
index 000000000000..b04cdc999288
--- /dev/null
+++ b/devel/libfs++/pkg-descr
@@ -0,0 +1,5 @@
+libfs++ is a small c++ library which provides a file_iterator class, which
+makes it very easy to iterate through all files in a directory and its
+subdirectories.
+
+WWW: http://bluebat.dnsalias.org/software/libfs++/
diff --git a/devel/libfs++/pkg-plist b/devel/libfs++/pkg-plist
new file mode 100644
index 000000000000..7ce413bb0476
--- /dev/null
+++ b/devel/libfs++/pkg-plist
@@ -0,0 +1,11 @@
+lib/libfs++.a
+lib/libfs++.la
+lib/libfs++.so
+lib/libfs++.so.0
+include/fs++/file_iterator-impl.h
+include/fs++/file_iterator.h
+include/fs++/file_monitor.h
+include/fs++/file_t.h
+include/fs++/general-impl.h
+include/fs++/general.h
+@dirrm include/fs++