aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-06-16 14:29:59 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-06-16 14:29:59 +0000
commit670c68d144a184bae8dd07c6d677d60c6a5d5458 (patch)
tree3c2511f1dda35058af9f000a3376ecf01a6cf624 /devel
parent55a23d6dbb94dfc1cba99447c1edeaa51b5fbc12 (diff)
downloadports-670c68d144a184bae8dd07c6d677d60c6a5d5458.tar.gz
ports-670c68d144a184bae8dd07c6d677d60c6a5d5458.zip
New port: devel/kyua-atf-compat:
Kyua (pronounced Q.A.) is a testing framework for both developers and users. Kyua is different from most other testing frameworks in that it puts the end user experience before anything else. There are multiple reasons for users to run the tests themselves, and Kyua ensures that they can do so in the most convenient way. This module, kyua-atf-compat, provides tools to ease the transition from ATF to Kyua. In particular, this includes is a tool to convert Atffile files to Kyuafile files in an automated manner, and drop-in replacement wrappers for atf-run and atf-report. WWW: https://code.google.com/p/kyua/ PR: ports/177640 Submitted by: asomers Reviewed by: Garrett Cooper <yaneurabeya@gmail.com>
Notes
Notes: svn path=/head/; revision=321053
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/kyua-atf-compat/Makefile45
-rw-r--r--devel/kyua-atf-compat/distinfo2
-rw-r--r--devel/kyua-atf-compat/pkg-descr12
-rw-r--r--devel/kyua-atf-compat/pkg-plist5
5 files changed, 65 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2b79838a1662..f67c0048aa9f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -915,6 +915,7 @@
SUBDIR += kscope
SUBDIR += kyra
SUBDIR += kyua
+ SUBDIR += kyua-atf-compat
SUBDIR += kyua-testers
SUBDIR += lasi
SUBDIR += lcov
diff --git a/devel/kyua-atf-compat/Makefile b/devel/kyua-atf-compat/Makefile
new file mode 100644
index 000000000000..b729968bcc2c
--- /dev/null
+++ b/devel/kyua-atf-compat/Makefile
@@ -0,0 +1,45 @@
+# Created by: Alan Somers <asomers@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= kyua-atf-compat
+PORTVERSION= 0.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PROJECTHOST= kyua
+
+MAINTAINER= asomers@freebsd.org
+COMMENT= Kyua (automated testing framework) - ATF compatibility tools
+
+LICENSE= BSD
+
+RUN_DEPENDS= kyua:${PORTSDIR}/devel/kyua
+
+GNU_CONFIGURE= yes
+USES= pkgconfig
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+CONFIGURE_ARGS+= --docdir=${DOCSDIR}
+# TODO: install the tests, once FreeBSD has a system for ports to install tests
+CONFIGURE_ARGS+= --without-atf
+
+.if ! ${PORT_OPTIONS:MDOCS}
+MAKE_FLAGS+= doc_DATA=
+.endif
+PLIST_SUBST+= TESTS="@comment "
+
+PORTDATA= lib.subr tests_lib.subr
+PORTDOCS= AUTHORS COPYING NEWS README
+MAN1= atf-report.1 atf-run.1 atf2kyua.1
+
+# Eliminate empty directories
+remove-docsdir: .SILENT
+ ${RMDIR} ${DOCSDIR}
+
+.if ! ${PORT_OPTIONS:MDOCS}
+post-install: remove-docsdir
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/kyua-atf-compat/distinfo b/devel/kyua-atf-compat/distinfo
new file mode 100644
index 000000000000..3fd6e94b4993
--- /dev/null
+++ b/devel/kyua-atf-compat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kyua-atf-compat-0.1.tar.gz) = dd3f647ec015b4d4595d1f16ad79673b66c44f6e19cb9176dfcf4fc9d2cfd8e8
+SIZE (kyua-atf-compat-0.1.tar.gz) = 73743
diff --git a/devel/kyua-atf-compat/pkg-descr b/devel/kyua-atf-compat/pkg-descr
new file mode 100644
index 000000000000..5ad70acb7a4c
--- /dev/null
+++ b/devel/kyua-atf-compat/pkg-descr
@@ -0,0 +1,12 @@
+Kyua (pronounced Q.A.) is a testing framework for both developers and
+users. Kyua is different from most other testing frameworks in that it
+puts the end user experience before anything else. There are multiple
+reasons for users to run the tests themselves, and Kyua ensures that
+they can do so in the most convenient way.
+
+This module, kyua-atf-compat, provides tools to ease the transition from
+ATF to Kyua. In particular, this includes is a tool to convert Atffile
+files to Kyuafile files in an automated manner, and drop-in replacement
+wrappers for atf-run and atf-report.
+
+WWW: https://code.google.com/p/kyua/
diff --git a/devel/kyua-atf-compat/pkg-plist b/devel/kyua-atf-compat/pkg-plist
new file mode 100644
index 000000000000..821ca3e70c73
--- /dev/null
+++ b/devel/kyua-atf-compat/pkg-plist
@@ -0,0 +1,5 @@
+bin/atf-report
+bin/atf-run
+bin/atf2kyua
+@dirrmtry tests/kyua-atf-compat
+@dirrmtry tests