aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-09-08 06:23:02 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-09-08 06:23:02 +0000
commit96cd8d868c574b63f84b9864a2ea51b5445f2864 (patch)
treeb2d3ffc0598bfa90dbcd5e88d378cea53f6161f4 /devel
parentb229f0670490086a98defa5f0d14d77373aa61f1 (diff)
downloadports-96cd8d868c574b63f84b9864a2ea51b5445f2864.tar.gz
ports-96cd8d868c574b63f84b9864a2ea51b5445f2864.zip
ScriptTest is a library to help you test your interactive command-line
applications. With it you can easily run the command (in a subprocess) and see the output (stdout, stderr) and any file modifications. WWW: http://pythonpaste.org/scripttest/
Notes
Notes: svn path=/head/; revision=303867
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ScriptTest/Makefile23
-rw-r--r--devel/py-ScriptTest/distinfo2
-rw-r--r--devel/py-ScriptTest/pkg-descr7
-rw-r--r--devel/py-ScriptTest/pkg-plist2
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 948f2c683960..37c13bcfb15f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3194,6 +3194,7 @@
SUBDIR += py-Products.validation
SUBDIR += py-RPyC
SUBDIR += py-Record
+ SUBDIR += py-ScriptTest
SUBDIR += py-SymbolType
SUBDIR += py-TGScheduler
SUBDIR += py-ToscaWidgets
diff --git a/devel/py-ScriptTest/Makefile b/devel/py-ScriptTest/Makefile
new file mode 100644
index 000000000000..24bd43084002
--- /dev/null
+++ b/devel/py-ScriptTest/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-ScriptTest
+# Date created: 2012-09-08
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ScriptTest
+PORTVERSION= 1.2
+#PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Helper to test command-line scripts
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/devel/py-ScriptTest/distinfo b/devel/py-ScriptTest/distinfo
new file mode 100644
index 000000000000..4ae43fcf60a5
--- /dev/null
+++ b/devel/py-ScriptTest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ScriptTest-1.2.tar.gz) = 158c34cfa736288c33177588572c2bb3372b836eb4c90b05222911b4ff976942
+SIZE (ScriptTest-1.2.tar.gz) = 7208
diff --git a/devel/py-ScriptTest/pkg-descr b/devel/py-ScriptTest/pkg-descr
new file mode 100644
index 000000000000..523efd57b5f2
--- /dev/null
+++ b/devel/py-ScriptTest/pkg-descr
@@ -0,0 +1,7 @@
+ScriptTest is a library to help you test your interactive command-line
+applications.
+
+With it you can easily run the command (in a subprocess) and see the
+output (stdout, stderr) and any file modifications.
+
+WWW: http://pythonpaste.org/scripttest/
diff --git a/devel/py-ScriptTest/pkg-plist b/devel/py-ScriptTest/pkg-plist
new file mode 100644
index 000000000000..7767d3e76aa1
--- /dev/null
+++ b/devel/py-ScriptTest/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%