aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-07-30 12:03:36 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-07-30 12:03:36 +0000
commitcdffcb1103e20ff62769e6e4829bd7b6269ed2a9 (patch)
tree0a47e5d5d73f831840c065d1837fc2d95853d8df /devel
parentc5274f9bdbbe5d1728b082e6b63a9c7ef5e2060c (diff)
downloadports-cdffcb1103e20ff62769e6e4829bd7b6269ed2a9.tar.gz
ports-cdffcb1103e20ff62769e6e4829bd7b6269ed2a9.zip
Tox as is a generic virtualenv management and test command line tool you
can use for: * checking your package installs correctly with different Python versions and interpreters * running your tests in each of the environments, configuring your test tool of choice * acting as a frontend to Continuous Integration servers, greatly reducing boilerplate and merging CI and shell-based testing. WWW: http://tox.testrun.org/ PR: ports/170022 Submitted by: Kubilay Kocak <koobs.freebsd@gmail.com>
Notes
Notes: svn path=/head/; revision=301714
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-tox/Makefile45
-rw-r--r--devel/py-tox/distinfo2
-rw-r--r--devel/py-tox/files/patch-setup.py18
-rw-r--r--devel/py-tox/pkg-descr14
-rw-r--r--devel/py-tox/pkg-plist30
6 files changed, 110 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9d5dc71255d7..c1cb5debabde 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3442,6 +3442,7 @@
SUBDIR += py-tgMochiKit
SUBDIR += py-thrift
SUBDIR += py-timelib
+ SUBDIR += py-tox
SUBDIR += py-trace2html
SUBDIR += py-traits
SUBDIR += py-transaction
diff --git a/devel/py-tox/Makefile b/devel/py-tox/Makefile
new file mode 100644
index 000000000000..05dd006f9d3e
--- /dev/null
+++ b/devel/py-tox/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: py-tox
+# Date created: 2012-07-19
+# Whom: Kubilay Kocak <koobs.freebsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tox
+PORTVERSION= 1.4.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs.freebsd@gmail.com
+COMMENT= Python virtualenv-based automation of test activities
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}virtualenv>=1.7:${PORTSDIR}/devel/py-virtualenv \
+ ${PYTHON_PKGNAMEPREFIX}pylib>=1.4.9:${PORTSDIR}/devel/py-pylib
+
+USE_ZIP= YES
+USE_PYTHON= YES
+USE_PYDISTUTILS= easy_install
+
+OPTIONS_DEFINE= PYTEST
+PYTEST_DESC= Include the Pytest test runner
+
+# Workaround ports infrastructure bug
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPYTEST}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} <= 3.2
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}argparse>0:${PORTSDIR}/devel/py-argparse
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-tox/distinfo b/devel/py-tox/distinfo
new file mode 100644
index 000000000000..8dd994971bf2
--- /dev/null
+++ b/devel/py-tox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tox-1.4.2.zip) = a8a5b3ad5ff0907c13203c5b36085f8dafbdd367e0c9211aa24797990a6f3d2f
+SIZE (tox-1.4.2.zip) = 77565
diff --git a/devel/py-tox/files/patch-setup.py b/devel/py-tox/files/patch-setup.py
new file mode 100644
index 000000000000..f6e0b063d07c
--- /dev/null
+++ b/devel/py-tox/files/patch-setup.py
@@ -0,0 +1,18 @@
+--- ./setup.py.orig 2012-07-19 20:16:27.000000000 +1000
++++ ./setup.py 2012-07-19 20:16:36.000000000 +1000
+@@ -44,7 +44,7 @@
+ packages=['tox', ],
+ entry_points={'console_scripts': 'tox=tox:cmdline'},
+ install_requires=install_requires,
+- zip_safe=True,
++ zip_safe=False,
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+@@ -60,4 +60,4 @@
+ )
+
+ if __name__ == '__main__':
+- main()
+\ No newline at end of file
++ main()
diff --git a/devel/py-tox/pkg-descr b/devel/py-tox/pkg-descr
new file mode 100644
index 000000000000..548cc34a7b8a
--- /dev/null
+++ b/devel/py-tox/pkg-descr
@@ -0,0 +1,14 @@
+Tox as is a generic virtualenv management and test command line tool you can
+use for:
+
+* checking your package installs correctly with different
+ Python versions and interpreters
+
+* running your tests in each of the
+ environments, configuring your test tool of choice
+
+* acting as a frontend to Continuous Integration
+ servers, greatly reducing boilerplate and merging
+ CI and shell-based testing.
+
+WWW: http://tox.testrun.org/
diff --git a/devel/py-tox/pkg-plist b/devel/py-tox/pkg-plist
new file mode 100644
index 000000000000..cca1666d41e4
--- /dev/null
+++ b/devel/py-tox/pkg-plist
@@ -0,0 +1,30 @@
+@comment $FreeBSD$
+bin/tox
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_cmdline.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_cmdline.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_cmdline.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_config.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_config.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_config.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_exception.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_exception.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_exception.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_venv.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_venv.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_venv.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_verlib.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_verlib.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox/_verlib.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tox
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%