aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-05 22:51:12 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-05 22:51:12 +0000
commit076b36615ac1ad95926736d3333a72aba2b9ba4e (patch)
treec8d9d9d0e0ad2f93f359ee33a4ce30b595420fce /devel
parent8a4b4ae9e46042c7404f4430377f02ee7ca479d8 (diff)
downloadports-076b36615ac1ad95926736d3333a72aba2b9ba4e.tar.gz
ports-076b36615ac1ad95926736d3333a72aba2b9ba4e.zip
Shell::EnvImporter allows various kinds of shell scripts (csh, tcsh, bash, zsh
and even perl) to be "sourced" into a Perl program. This module also allows restoration of the pre-sourced environment. WWW: http://search.cpan.org/dist/Shell-EnvImporter/ PR: ports/102587 Submitted by: Martin Jackson (mhjacks at swbell.net)
Notes
Notes: svn path=/head/; revision=174590
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Shell-EnvImporter/Makefile24
-rw-r--r--devel/p5-Shell-EnvImporter/distinfo3
-rw-r--r--devel/p5-Shell-EnvImporter/pkg-descr5
-rw-r--r--devel/p5-Shell-EnvImporter/pkg-plist18
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aed1260f4bde..e9abb4b97918 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1340,6 +1340,7 @@
SUBDIR += p5-Set-Scalar
SUBDIR += p5-Shape
SUBDIR += p5-Shell-Base
+ SUBDIR += p5-Shell-EnvImporter
SUBDIR += p5-Shell-Parser
SUBDIR += p5-Shell-Source
SUBDIR += p5-Smart-Comments
diff --git a/devel/p5-Shell-EnvImporter/Makefile b/devel/p5-Shell-EnvImporter/Makefile
new file mode 100644
index 000000000000..afc1ad7b0b7a
--- /dev/null
+++ b/devel/p5-Shell-EnvImporter/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: devel/p5-Shell-EnvImporter
+# Date created: 25 Aug 2006
+# Whom: Martin Jackson (mhjacks@swbell.net)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Shell-EnvImporter
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Shell
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mhjacks@swbell.net
+COMMENT= Inherit different shell environments, and restore previous
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+
+PERL_CONFIGURE= yes
+
+MAN3= Shell::EnvImporter.3 Shell::EnvImporter::Result.3 Shell::EnvImporter::Shell.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Shell-EnvImporter/distinfo b/devel/p5-Shell-EnvImporter/distinfo
new file mode 100644
index 000000000000..91b009186c88
--- /dev/null
+++ b/devel/p5-Shell-EnvImporter/distinfo
@@ -0,0 +1,3 @@
+MD5 (Shell-EnvImporter-1.02.tar.gz) = ef7bb7792174435db4dbe77a92d31a85
+SHA256 (Shell-EnvImporter-1.02.tar.gz) = f45d702ecaa710463dee65c0c28720ebc2cd58db9c9907551d8a0710ed4eb985
+SIZE (Shell-EnvImporter-1.02.tar.gz) = 15109
diff --git a/devel/p5-Shell-EnvImporter/pkg-descr b/devel/p5-Shell-EnvImporter/pkg-descr
new file mode 100644
index 000000000000..bcb9165c6733
--- /dev/null
+++ b/devel/p5-Shell-EnvImporter/pkg-descr
@@ -0,0 +1,5 @@
+Shell::EnvImporter allows various kinds of shell scripts (csh, tcsh, bash, zsh
+and even perl) to be "sourced" into a Perl program. This module also allows
+restoration of the pre-sourced environment.
+
+WWW: http://search.cpan.org/dist/Shell-EnvImporter/
diff --git a/devel/p5-Shell-EnvImporter/pkg-plist b/devel/p5-Shell-EnvImporter/pkg-plist
new file mode 100644
index 000000000000..be307dc01a9b
--- /dev/null
+++ b/devel/p5-Shell-EnvImporter/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shell/EnvImporter/.packlist
+%%SITE_PERL%%/Shell/EnvImporter.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell.pm
+%%SITE_PERL%%/Shell/EnvImporter/Result.pm
+%%SITE_PERL%%/Shell/EnvImporter/Change.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell/sh.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell/perl.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell/tcsh.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell/zsh.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell/ksh.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell/bash.pm
+%%SITE_PERL%%/Shell/EnvImporter/Shell/csh.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Shell/EnvImporter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Shell
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Shell/EnvImporter
+@dirrm %%SITE_PERL%%/Shell/EnvImporter/Shell
+@dirrm %%SITE_PERL%%/Shell/EnvImporter
+@dirrmtry %%SITE_PERL%%/Shell