aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-03 00:53:58 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-03 00:53:58 +0000
commit2ae996e2b4affd95d9b0119c62823bdfe426a35f (patch)
treec23f71972ca484d614ae0e776dc9e2090a57d61d /devel
parenteb52d1d0409514f0350da4e940340c33c717ed80 (diff)
downloadports-2ae996e2b4affd95d9b0119c62823bdfe426a35f.tar.gz
ports-2ae996e2b4affd95d9b0119c62823bdfe426a35f.zip
Add p5-File-Pid 1.01, pid File Manipulation.
PR: ports/102892 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=174339
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Pid/Makefile25
-rw-r--r--devel/p5-File-Pid/distinfo3
-rw-r--r--devel/p5-File-Pid/pkg-descr5
-rw-r--r--devel/p5-File-Pid/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 18951f163943..2d6dd686948c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1076,6 +1076,7 @@
SUBDIR += p5-File-NFSLock
SUBDIR += p5-File-Path-Expand
SUBDIR += p5-File-PathConvert
+ SUBDIR += p5-File-Pid
SUBDIR += p5-File-Random
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
diff --git a/devel/p5-File-Pid/Makefile b/devel/p5-File-Pid/Makefile
new file mode 100644
index 000000000000..63f1180a059c
--- /dev/null
+++ b/devel/p5-File-Pid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-File-Pid
+# Date created: 2006-09-05
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Pid
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Pid File Manipulation
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Pid.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Pid/distinfo b/devel/p5-File-Pid/distinfo
new file mode 100644
index 000000000000..7eeb45ea802e
--- /dev/null
+++ b/devel/p5-File-Pid/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Pid-1.01.tar.gz) = d927b40215cbfbff233d9feb53529532
+SHA256 (File-Pid-1.01.tar.gz) = bafeee8fdc96eb06306a0c58bbdb7209b6de45f850e75fdc6b16db576e05e422
+SIZE (File-Pid-1.01.tar.gz) = 3053
diff --git a/devel/p5-File-Pid/pkg-descr b/devel/p5-File-Pid/pkg-descr
new file mode 100644
index 000000000000..696bdfeb456a
--- /dev/null
+++ b/devel/p5-File-Pid/pkg-descr
@@ -0,0 +1,5 @@
+This software manages a pid file for you. It will create a pid file,
+query the process within to discover if it's still running, and remove
+the pid file.
+
+WWW: http://search.cpan.org/dist/File-Pid/
diff --git a/devel/p5-File-Pid/pkg-plist b/devel/p5-File-Pid/pkg-plist
new file mode 100644
index 000000000000..2364e3610d62
--- /dev/null
+++ b/devel/p5-File-Pid/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Pid/.packlist
+%%SITE_PERL%%/File/Pid.pm
+@dirrmtry %%SITE_PERL%%/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Pid
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File