aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>1998-08-25 10:32:47 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>1998-08-25 10:32:47 +0000
commit9f3ac4d8ea44ba38c9ec5bb6b4169e9e83d4d3bc (patch)
treecf3427aa244e18453a7d7ca1a61f2a386c4504ab /devel
parent60ba2bdb08bd418121d5c177057f534120ac2196 (diff)
downloadports-9f3ac4d8ea44ba38c9ec5bb6b4169e9e83d4d3bc.tar.gz
ports-9f3ac4d8ea44ba38c9ec5bb6b4169e9e83d4d3bc.zip
A port of `cvslines'; a CVS wrapper that helps with merging changes
between various cvs branches, where the branches represent different lines of development.
Notes
Notes: svn path=/head/; revision=12839
Diffstat (limited to 'devel')
-rw-r--r--devel/cvslines/Makefile23
-rw-r--r--devel/cvslines/files/patch-aa23
-rw-r--r--devel/cvslines/files/patch-ab32
-rw-r--r--devel/cvslines/pkg-comment1
-rw-r--r--devel/cvslines/pkg-descr10
-rw-r--r--devel/cvslines/pkg-plist6
6 files changed, 95 insertions, 0 deletions
diff --git a/devel/cvslines/Makefile b/devel/cvslines/Makefile
new file mode 100644
index 000000000000..5efdad4008ff
--- /dev/null
+++ b/devel/cvslines/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: cvslines
+# Version required: 1.6.7
+# Date created: 24 Aug 1998
+# Whom: jkoshy
+#
+# $Id$
+#
+
+DISTNAME= cvslines-1.6.7
+CATEGORIES= devel
+MASTER_SITES= http://www.netapp.com/technology/freeware/cvslines/
+
+MAINTAINER= jkoshy@freebsd.org
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= cvslines.1
+
+do-install:
+ PREFIX=${PREFIX} ${PERL5} ${WRKSRC}/INSTALL ${WRKSRC}/CONFIG
+
+.include <bsd.port.mk>
diff --git a/devel/cvslines/files/patch-aa b/devel/cvslines/files/patch-aa
new file mode 100644
index 000000000000..8b301d266550
--- /dev/null
+++ b/devel/cvslines/files/patch-aa
@@ -0,0 +1,23 @@
+--- CONFIG-- Thu May 22 00:09:38 1997
++++ CONFIG Tue Aug 25 14:14:24 1998
+@@ -14,17 +14,17 @@
+ # The absolute path to the perl interpreter to use.
+ # INSTALL will substitute this into the #!... line.
+ #
+-if (! defined($PERL5)) { $PERL5 = "/usr/local/bin/perl5"; } # cfg
++if (! defined($PERL5)) { $PERL5 = "$ENV{'PREFIX'}/bin/perl5"; } # cfg
+
+ # Where to install the cvslines scripts...
+ # (Absolute path)
+ #
+-if (! defined($BINDIR)) { $BINDIR = "/usr/local/bin"; } # cfg
++if (! defined($BINDIR)) { $BINDIR = "$ENV{'PREFIX'}/bin"; } # cfg
+
+ # Where to install the cvslines man page...
+ # (Absolute path)
+ #
+-if (! defined($MANDIR)) { $MAN1DIR = "/usr/local/man/man1"; } # cfg
++if (! defined($MANDIR)) { $MAN1DIR = "$ENV{'PREFIX'}/man/man1"; } # cfg
+
+ ######################################################################
+ #
diff --git a/devel/cvslines/files/patch-ab b/devel/cvslines/files/patch-ab
new file mode 100644
index 000000000000..9265dc0bbc4d
--- /dev/null
+++ b/devel/cvslines/files/patch-ab
@@ -0,0 +1,32 @@
+--- INSTALL-- Thu May 22 03:36:16 1997
++++ INSTALL Tue Aug 25 14:26:30 1998
+@@ -73,7 +73,7 @@
+ }
+
+
+-$uname = `/bin/uname -a`; chop $uname;
++$uname = `/usr/bin/uname -a`; chop $uname;
+ ($u_os, $u_host, $u_osrel) = split(/\s+/, $uname);
+
+ # Try to find things in the usual places, but failing those,
+@@ -121,7 +121,8 @@
+ {
+ if ( ! ( ($u_os eq "SunOS" && $u_osrel =~ /^5\./)
+ || ($u_os eq "SunOS" && $u_osrel =~ /^4\./)
+- || ($u_os eq "OSF1" && $u_osrel =~ /^V[34]\./)))
++ || ($u_os eq "OSF1" && $u_osrel =~ /^V[34]\./)
++ || ($u_os eq "FreeBSD")))
+ {
+ print STDERR <<MSG;
+ $Myname:
+@@ -148,9 +149,8 @@
+ cvslines has been tested with cvs 1.9. The "cvs" command found via
+ your \$PATH provided the following version information:
+ $cvs_versmsg
+- (press Return to continue with the install...)
+ MSG
+- $ans = <STDIN>;
++ # $ans = <STDIN>;
+
+ }
+ }
diff --git a/devel/cvslines/pkg-comment b/devel/cvslines/pkg-comment
new file mode 100644
index 000000000000..dd50edf1ecfe
--- /dev/null
+++ b/devel/cvslines/pkg-comment
@@ -0,0 +1 @@
+A wrapper to help with merging changes between various cvs branches.
diff --git a/devel/cvslines/pkg-descr b/devel/cvslines/pkg-descr
new file mode 100644
index 000000000000..e8a0ee235d03
--- /dev/null
+++ b/devel/cvslines/pkg-descr
@@ -0,0 +1,10 @@
+cvslines extends the capability of the cvs commit command, to provide
+extra support in managing multiple concurrent lines of development.
+
+cvslines is a "wrapper" facility that helps out with merging changes
+between various cvs branches, where the branches represent different
+lines of development.
+
+For more information about using cvslines, see cvslines(1).
+
+URL: http://www.netapp.com/technology/freeware/cvslines/index.html
diff --git a/devel/cvslines/pkg-plist b/devel/cvslines/pkg-plist
new file mode 100644
index 000000000000..cc6a215c5d26
--- /dev/null
+++ b/devel/cvslines/pkg-plist
@@ -0,0 +1,6 @@
+bin/cvslines
+bin/cvslines_check
+bin/cvslines-status
+bin/cvslines-check
+bin/cvslines-commit
+bin/cvslines-config