aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
commit6b470bae86247b8cb79b0dc6e43078df2f84c4ae (patch)
treee1545740f8801646e19c181252cb4c4e39df9ca8 /devel
parentb63d72fe5f0a821fa729c344f9b44de714603abc (diff)
downloadports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.tar.gz
ports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Notes
Notes: svn path=/head/; revision=89001
Diffstat (limited to 'devel')
-rw-r--r--devel/bugzilla/Makefile3
-rw-r--r--devel/bugzilla2/Makefile3
-rw-r--r--devel/bugzilla3/Makefile3
-rw-r--r--devel/p5-DateTime-Format-DBI/Makefile15
-rw-r--r--devel/p5-POE-Component-DBIAgent/Makefile13
5 files changed, 26 insertions, 11 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 5245b048e91d..1c0ebb4dbb9b 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Bug-tracking system developed by Mozilla Project
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-RUN_DEPENDS= ${PERL_SITEDIR}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${PERL_SITEDIR}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
+RUN_DEPENDS= ${PERL_SITEDIR}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
${PERL_SITEDIR}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${PERL_SITEDIR}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
${PERL_SITEDIR}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
diff --git a/devel/bugzilla2/Makefile b/devel/bugzilla2/Makefile
index 5245b048e91d..1c0ebb4dbb9b 100644
--- a/devel/bugzilla2/Makefile
+++ b/devel/bugzilla2/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Bug-tracking system developed by Mozilla Project
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-RUN_DEPENDS= ${PERL_SITEDIR}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${PERL_SITEDIR}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
+RUN_DEPENDS= ${PERL_SITEDIR}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
${PERL_SITEDIR}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${PERL_SITEDIR}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
${PERL_SITEDIR}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index 5245b048e91d..1c0ebb4dbb9b 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Bug-tracking system developed by Mozilla Project
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-RUN_DEPENDS= ${PERL_SITEDIR}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${PERL_SITEDIR}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
+RUN_DEPENDS= ${PERL_SITEDIR}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
${PERL_SITEDIR}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${PERL_SITEDIR}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
${PERL_SITEDIR}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
diff --git a/devel/p5-DateTime-Format-DBI/Makefile b/devel/p5-DateTime-Format-DBI/Makefile
index aa4a1fd425c7..70c08bb08569 100644
--- a/devel/p5-DateTime-Format-DBI/Makefile
+++ b/devel/p5-DateTime-Format-DBI/Makefile
@@ -17,8 +17,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAINTAINER= mat@FreeBSD.org
COMMENT= Find a parser class for a database connection
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -28,4 +27,14 @@ MAN3= DateTime::Format::DBI.3
post-patch:
@${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/lib/DateTime/Format/DBI.pm
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-POE-Component-DBIAgent/Makefile b/devel/p5-POE-Component-DBIAgent/Makefile
index 7d87457a958c..a2fd31cadd1f 100644
--- a/devel/p5-POE-Component-DBIAgent/Makefile
+++ b/devel/p5-POE-Component-DBIAgent/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= POE Component for running asynchronous DBI calls
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -27,4 +26,14 @@ MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= POE::Component::DBIAgent.3 POE::Component::DBIAgent::Helper.3 \
POE::Component::DBIAgent::Queue.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>