aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-12-23 21:45:15 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-12-23 21:45:15 +0000
commita2f26adbf2348f31cc8905d38d7680e67f075479 (patch)
tree784db0a1decd6703c6c3dc1e8f30bb6c66bbbf2d /devel
parente439d0da2371cde466dd669de8342536e8ddc16a (diff)
downloadports-a2f26adbf2348f31cc8905d38d7680e67f075479.tar.gz
ports-a2f26adbf2348f31cc8905d38d7680e67f075479.zip
Fix build problem with getopt.h on current.
remove BROKEN
Notes
Notes: svn path=/head/; revision=71821
Diffstat (limited to 'devel')
-rw-r--r--devel/gcvs/Makefile9
-rw-r--r--devel/gcvs/distinfo2
-rw-r--r--devel/gcvs/files/patch-configure.in52
-rw-r--r--devel/gcvs/files/patch-cvsunix-contrib-Makefile.in23
-rw-r--r--devel/gcvs/files/patch-cvsunix-src-Makefile.in14
-rw-r--r--devel/gcvs/files/patch-make_configure8
6 files changed, 41 insertions, 67 deletions
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index c5a64cfb0d44..cf1ae49449cf 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gcvs
-PORTVERSION= 1.0b5
-PORTREVISION= 1
+PORTVERSION= 1.0rc1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cvsgui
@@ -38,8 +37,4 @@ MAN8= cvsbug.8
#USE_AUTOMAKE_VER= 14
#USE_AUTOCONF_VER= 213
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500030
-BROKEN= conflicts with /usr/include/unistd.h
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/gcvs/distinfo b/devel/gcvs/distinfo
index a33dbb970345..2db5d75e75f5 100644
--- a/devel/gcvs/distinfo
+++ b/devel/gcvs/distinfo
@@ -1 +1 @@
-MD5 (gcvs-1.0b5.tar.gz) = 2c5e645878bee83cddf3ef1b2f141d6a
+MD5 (gcvs-1.0rc1.tar.gz) = 594e289406e1662583877d51b7b316e3
diff --git a/devel/gcvs/files/patch-configure.in b/devel/gcvs/files/patch-configure.in
deleted file mode 100644
index 940f70e32656..000000000000
--- a/devel/gcvs/files/patch-configure.in
+++ /dev/null
@@ -1,52 +0,0 @@
---- configure.in.orig Fri May 3 16:43:04 2002
-+++ configure.in Wed Dec 18 19:47:26 2002
-@@ -144,49 +144,6 @@
- CFLAGS="$CFLAGS -DqCvsDebug=1"
- fi
-
--dnl checks if getopt.h exists in system includes
--echo "checking for getopt.h" >&5
--echo $ECHO_N "checking for getopt.h... $ECHO_C" >&6
--cat >conftest.$ac_ext <<_ACEOF
--#include "confdefs.h"
--#include <getopt.h>
--_ACEOF
--if { (eval echo "\"$ac_cpp conftest.$ac_ext\"") >&5
-- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
-- ac_status=$?
-- egrep -v '^ *\+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- echo "\$? = $ac_status" >&5
-- (exit $ac_status); } >/dev/null; then
-- if test -s conftest.err; then
-- ac_cpp_err=$ac_c_preproc_warn_flag
-- else
-- ac_cpp_err=
-- fi
--else
-- ac_cpp_err=yes
--fi
--if test -z "$ac_cpp_err"; then
-- eval "$as_ac_Header=yes"
--else
-- echo "$as_me: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- eval "$as_ac_Header=no"
--fi
--rm -f conftest.err conftest.$ac_ext
--
--echo "result: `eval echo '${'$as_ac_Header'}'`" >&5
--echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
--if test `eval echo '${'$as_ac_Header'}'` = yes; then
-- cat >>confdefs.h <<EOF
--#define `echo "HAVE_GETOPT_H" | $as_tr_cpp` 1
--EOF
--
--AM_CONDITIONAL(HAVE_GETOPT_H, test x$as_ac_Header= xyes)
--
--fi
--
- dnl Set PACKAGE_DATA_DIR in config.h.
- if test "x${datadir}" = 'x${prefix}/share'; then
- if test "x${prefix}" = "xNONE"; then
diff --git a/devel/gcvs/files/patch-cvsunix-contrib-Makefile.in b/devel/gcvs/files/patch-cvsunix-contrib-Makefile.in
new file mode 100644
index 000000000000..2ba9a605ce99
--- /dev/null
+++ b/devel/gcvs/files/patch-cvsunix-contrib-Makefile.in
@@ -0,0 +1,23 @@
+--- cvsunix/contrib/Makefile.in.orig Tue Sep 26 15:18:40 2000
++++ cvsunix/contrib/Makefile.in Fri Dec 20 20:05:08 2002
+@@ -38,6 +38,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+
+ DISTFILES = \
+ ChangeLog README .cvsignore intro.doc \
+@@ -83,10 +84,10 @@
+ $(INSTALL_DATA) $(srcdir)/$$f $(libdir)/cvs/contrib/$$f; \
+ done
+ for f in $(CONTRIB_PROGS) ; do\
+- $(INSTALL_PROGRAM) $$f $(libdir)/cvs/contrib/$$f; \
++ $(INSTALL_SCRIPT) $$f $(libdir)/cvs/contrib/$$f; \
+ done
+ for f in $(PROGS) ; do\
+- $(INSTALL_PROGRAM) $$f $(bindir)/$$f; \
++ $(INSTALL_SCRIPT) $$f $(bindir)/$$f; \
+ done
+ .PHONY: install
+
diff --git a/devel/gcvs/files/patch-cvsunix-src-Makefile.in b/devel/gcvs/files/patch-cvsunix-src-Makefile.in
index af49c6dfc7d8..fe726a8488e7 100644
--- a/devel/gcvs/files/patch-cvsunix-src-Makefile.in
+++ b/devel/gcvs/files/patch-cvsunix-src-Makefile.in
@@ -1,6 +1,14 @@
---- cvsunix/src/Makefile.in.orig Tue Mar 6 17:36:21 2001
-+++ cvsunix/src/Makefile.in Thu Mar 29 00:44:20 2001
-@@ -88,7 +88,7 @@
+--- cvsunix/src/Makefile.in.orig Thu Nov 7 19:29:06 2002
++++ cvsunix/src/Makefile.in Fri Dec 20 19:56:41 2002
+@@ -34,6 +34,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+
+ LIBS = @LIBS@
+
+@@ -89,7 +90,7 @@
install: installdirs
@for prog in $(PROGS); do \
echo Installing $$prog in $(bindir); \
diff --git a/devel/gcvs/files/patch-make_configure b/devel/gcvs/files/patch-make_configure
index c8116de9e110..4d69d59cb622 100644
--- a/devel/gcvs/files/patch-make_configure
+++ b/devel/gcvs/files/patch-make_configure
@@ -1,5 +1,5 @@
---- make_configure.orig Mon Feb 4 12:03:12 2002
-+++ make_configure Tue Feb 5 18:49:58 2002
+--- make_configure.orig Thu Nov 7 19:42:00 2002
++++ make_configure Fri Dec 20 19:23:07 2002
@@ -1,14 +1,14 @@
-aclocal
-autoheader
@@ -11,8 +11,8 @@
for subdir in $list
do
echo making $subdir/Makefile.in
-- automake --gnu $subdir/Makefile
-+ automake14 --gnu $subdir/Makefile
+- automake --add-missing --gnu $subdir/Makefile
++ automake14 --add-missing --gnu $subdir/Makefile
done
-autoconf