aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-08-04 01:19:21 +0000
committerAde Lovett <ade@FreeBSD.org>2000-08-04 01:19:21 +0000
commit38ae599271006aa4aa581f0b03a8a5014fcf143d (patch)
tree1a1f5120bedb0bac581913ebf46122f0c3c9a656 /devel
parentc75a39648143baed64ef95c3314123a70205e5f6 (diff)
downloadports-38ae599271006aa4aa581f0b03a8a5014fcf143d.tar.gz
ports-38ae599271006aa4aa581f0b03a8a5014fcf143d.zip
Extensive patchfile cleanups using sobomax's wonderful
post-extract rule
Notes
Notes: svn path=/head/; revision=31287
Diffstat (limited to 'devel')
-rw-r--r--devel/bug-buddy/Makefile7
-rw-r--r--devel/bugbuddy/Makefile7
-rw-r--r--devel/bugbuddy2/Makefile7
-rw-r--r--devel/libgtop/Makefile9
-rw-r--r--devel/libgtop/files/patch-ac9
-rw-r--r--devel/libgtop2/Makefile9
-rw-r--r--devel/libgtop2/files/patch-ac9
7 files changed, 37 insertions, 20 deletions
diff --git a/devel/bug-buddy/Makefile b/devel/bug-buddy/Makefile
index 8d8212389e40..ec9a64f65f1c 100644
--- a/devel/bug-buddy/Makefile
+++ b/devel/bug-buddy/Makefile
@@ -25,4 +25,11 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/devel/bugbuddy/Makefile b/devel/bugbuddy/Makefile
index 8d8212389e40..ec9a64f65f1c 100644
--- a/devel/bugbuddy/Makefile
+++ b/devel/bugbuddy/Makefile
@@ -25,4 +25,11 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/devel/bugbuddy2/Makefile b/devel/bugbuddy2/Makefile
index 8d8212389e40..ec9a64f65f1c 100644
--- a/devel/bugbuddy2/Makefile
+++ b/devel/bugbuddy2/Makefile
@@ -25,4 +25,11 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index c7a65e1a2f1d..efd81e044497 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= stable/sources/libgtop
MAINTAINER= ade@FreeBSD.org
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
- guile.6:${PORTSDIR}/lang/guile
+ guile.9:${PORTSDIR}/lang/guile
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
@@ -27,6 +27,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
post-install:
install-info --section="Programming \& development tools" \
--entry="* libgtop: (libgtop). libgtop programming manual" \
diff --git a/devel/libgtop/files/patch-ac b/devel/libgtop/files/patch-ac
index 9db028375fb8..f2e96066aab2 100644
--- a/devel/libgtop/files/patch-ac
+++ b/devel/libgtop/files/patch-ac
@@ -13,12 +13,3 @@
LT_VERSION_INFO='-version-info ${LT_CURRENT}:${LT_REVISION}:${LT_AGE}'
-@@ -8005,7 +8005,7 @@
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- CATOBJEXT=.mo
-- DATADIRNAME=lib
-+ DATADIRNAME=share
- fi
- rm -f conftest*
- INSTOBJEXT=.mo
diff --git a/devel/libgtop2/Makefile b/devel/libgtop2/Makefile
index c7a65e1a2f1d..efd81e044497 100644
--- a/devel/libgtop2/Makefile
+++ b/devel/libgtop2/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= stable/sources/libgtop
MAINTAINER= ade@FreeBSD.org
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
- guile.6:${PORTSDIR}/lang/guile
+ guile.9:${PORTSDIR}/lang/guile
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
@@ -27,6 +27,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
post-install:
install-info --section="Programming \& development tools" \
--entry="* libgtop: (libgtop). libgtop programming manual" \
diff --git a/devel/libgtop2/files/patch-ac b/devel/libgtop2/files/patch-ac
index 9db028375fb8..f2e96066aab2 100644
--- a/devel/libgtop2/files/patch-ac
+++ b/devel/libgtop2/files/patch-ac
@@ -13,12 +13,3 @@
LT_VERSION_INFO='-version-info ${LT_CURRENT}:${LT_REVISION}:${LT_AGE}'
-@@ -8005,7 +8005,7 @@
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- CATOBJEXT=.mo
-- DATADIRNAME=lib
-+ DATADIRNAME=share
- fi
- rm -f conftest*
- INSTOBJEXT=.mo