aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2003-11-17 14:57:40 +0000
committerJames E. Housley <jeh@FreeBSD.org>2003-11-17 14:57:40 +0000
commit792036fde929d5b209d94c70a61b3bc2ac37307a (patch)
tree8c305f7bcd261ea572c64b518079098eba05566d /devel
parent4dca45b9720d59e3ff6d8c2ce6f76ffc571cd007 (diff)
downloadports-792036fde929d5b209d94c70a61b3bc2ac37307a.tar.gz
ports-792036fde929d5b209d94c70a61b3bc2ac37307a.zip
Put a comment warning about USE_AUTOHEADER and USE_AUTOCONF
Notes
Notes: svn path=/head/; revision=94180
Diffstat (limited to 'devel')
-rw-r--r--devel/i386-rtems-g77/Makefile3
-rw-r--r--devel/i386-rtems-gcc/Makefile3
-rw-r--r--devel/i386-rtems-gcj/Makefile3
-rw-r--r--devel/i386-rtems-objc/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index 012b3d7bd1b9..be6f443749ff 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -33,6 +33,9 @@ PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
+# autoheader is used by the port but autoconf is not, setting USE_AUTOCONF
+# will break the port. Since USE_AUTOHEADER sets USE_AUTOCONF, this is
+# likely to break the port also.
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
diff --git a/devel/i386-rtems-gcc/Makefile b/devel/i386-rtems-gcc/Makefile
index 3444238f50e5..636aa65c2ffc 100644
--- a/devel/i386-rtems-gcc/Makefile
+++ b/devel/i386-rtems-gcc/Makefile
@@ -34,6 +34,9 @@ PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
+# autoheader is used by the port but autoconf is not, setting USE_AUTOCONF
+# will break the port. Since USE_AUTOHEADER sets USE_AUTOCONF, this is
+# likely to break the port also.
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-as:${PORTSDIR}/devel/${LCLTARGET}-binutils \
${LCLTARGET}-ld:${PORTSDIR}/devel/${LCLTARGET}-binutils
diff --git a/devel/i386-rtems-gcj/Makefile b/devel/i386-rtems-gcj/Makefile
index 14c86902dbe4..e0a04eea3d21 100644
--- a/devel/i386-rtems-gcj/Makefile
+++ b/devel/i386-rtems-gcj/Makefile
@@ -34,6 +34,9 @@ NEWLIBNAME= newlib-1.11.0
MASTERDIR= ${.CURDIR}/../i386-rtems-gcj
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
+# autoheader is used by the port but autoconf is not, setting USE_AUTOCONF
+# will break the port. Since USE_AUTOHEADER sets USE_AUTOCONF, this is
+# likely to break the port also.
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
diff --git a/devel/i386-rtems-objc/Makefile b/devel/i386-rtems-objc/Makefile
index 15a3bab0b925..8e903541a532 100644
--- a/devel/i386-rtems-objc/Makefile
+++ b/devel/i386-rtems-objc/Makefile
@@ -33,6 +33,9 @@ PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
+# autoheader is used by the port but autoconf is not, setting USE_AUTOCONF
+# will break the port. Since USE_AUTOHEADER sets USE_AUTOCONF, this is
+# likely to break the port also.
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc