aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-05-31 21:46:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-05-31 21:46:49 +0000
commit12cadf80de54eb6232dbd6b890a99df1dfb06bda (patch)
treeffe88da15b3d147321b98724bf9898224a02d284 /devel
parent828ef3755783c9af56fd631838dc54379030c1ea (diff)
downloadports-12cadf80de54eb6232dbd6b890a99df1dfb06bda.tar.gz
ports-12cadf80de54eb6232dbd6b890a99df1dfb06bda.zip
change the libtool version to use from 1.3 to 1.5
retire automake/autoconf usage
Notes
Notes: svn path=/head/; revision=136567
Diffstat (limited to 'devel')
-rw-r--r--devel/regexx/Makefile14
-rw-r--r--devel/regexx/files/patch-Makefile.am9
-rw-r--r--devel/regexx/files/patch-configure.in10
-rw-r--r--devel/regexx/files/patch-src::Makefile.am12
4 files changed, 11 insertions, 34 deletions
diff --git a/devel/regexx/Makefile b/devel/regexx/Makefile
index 8d7919b511d6..21f80b79537b 100644
--- a/devel/regexx/Makefile
+++ b/devel/regexx/Makefile
@@ -19,9 +19,17 @@ COMMENT= A complete regular expressions C++ solution
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GMAKE= yes
-USE_AUTOMAKE_VER= 14
-USE_AUTOCONF_VER= 213
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|@LIBTOOL@|${LIBTOOL}|g ; \
+ s|\./libtool|${LIBTOOL}|g ; \
+ s|\(DEFS.*\)|\1 -I${LOCALBASE}/include|' \
+ ${WRKSRC}/src/Makefile.in ${WRKSRC}/pcre/Makefile.in
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir| ; \
+ ' ${WRKSRC}/configure
+# s|subdirs="pcre"||g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/devel/regexx/files/patch-Makefile.am b/devel/regexx/files/patch-Makefile.am
deleted file mode 100644
index c41a346d0d8e..000000000000
--- a/devel/regexx/files/patch-Makefile.am
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile.am.orig Tue Mar 13 22:42:20 2001
-+++ Makefile.am Sat Dec 29 08:24:46 2001
-@@ -4,5 +4,5 @@
- ## $Date: 2001/03/13 14:42:20 $
- ##
-
--SUBDIRS = @subdirs@ src examples
-+SUBDIRS = src examples
- EXTRA_DIST = regexx.spec.in
diff --git a/devel/regexx/files/patch-configure.in b/devel/regexx/files/patch-configure.in
deleted file mode 100644
index c8ac52a237f5..000000000000
--- a/devel/regexx/files/patch-configure.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.in.orig Fri Mar 16 21:16:17 2001
-+++ configure.in Sat Dec 29 08:24:46 2001
-@@ -23,7 +23,5 @@
-
- dnl Checks for library functions.
-
--AC_CONFIG_SUBDIRS(pcre)
--
- AC_OUTPUT([Makefile src/Makefile examples/Makefile regexx.spec])
-
diff --git a/devel/regexx/files/patch-src::Makefile.am b/devel/regexx/files/patch-src::Makefile.am
deleted file mode 100644
index ba7bb6c89866..000000000000
--- a/devel/regexx/files/patch-src::Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Makefile.am.orig Tue Mar 13 22:42:21 2001
-+++ src/Makefile.am Sat Dec 29 08:24:46 2001
-@@ -4,7 +4,8 @@
- ## $Date: 2001/03/13 14:42:21 $
- ##
-
-+INCLUDES=`pcre-config --cflags`
- lib_LTLIBRARIES = libregexx.la
- libregexx_la_SOURCES = regexx.cc regexx.hh split.cc split.hh
--libregexx_la_LDFLAGS = -version-info 2:0:1 ../pcre/maketables.lo ../pcre/get.lo ../pcre/study.lo ../pcre/pcre.lo
-+libregexx_la_LDFLAGS = -version-info 2:0:1 `pcre-config --libs`
- include_HEADERS = regexx.hh split.hh