aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-03-20 23:13:45 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-03-20 23:13:45 +0000
commit7cd341218d611966bc3af58ebea46a62b5179f15 (patch)
tree4de994b9b476b7052a879f571e7c49ca6587bd88 /devel
parentddb6aff37533e3d269b6d3eb175d40c372c1b6ed (diff)
downloadports-7cd341218d611966bc3af58ebea46a62b5179f15.tar.gz
ports-7cd341218d611966bc3af58ebea46a62b5179f15.zip
Upgrade devel/uclmmbase and mbone/vic to their latest respected
versions. Use BSD's bsd.lib.mk to build uclmmbase and avoid building (most of the) functionality, that is present in our base libraries (btree, md5, etc.) In vic stop using PERL, use Tcl/Tk-8.4, respect CC and CFLAGS and some other improvements. vic is thus unbroken on 5.x Per fenner's (much) earlier e-mail, grab maintainership for the time being. PR: ports/75066 (obsoleted) Approved by: fenner (implicitly)
Notes
Notes: svn path=/head/; revision=131801
Diffstat (limited to 'devel')
-rw-r--r--devel/uclmmbase/Makefile32
-rw-r--r--devel/uclmmbase/distinfo4
-rw-r--r--devel/uclmmbase/files/Makefile.bsd30
-rw-r--r--devel/uclmmbase/files/btree.h.bsd2
-rw-r--r--devel/uclmmbase/files/crypt_random.h.bsd4
-rw-r--r--devel/uclmmbase/files/hmac.h.bsd4
-rw-r--r--devel/uclmmbase/files/md5.h.bsd5
-rw-r--r--devel/uclmmbase/files/patch-aa10
-rw-r--r--devel/uclmmbase/files/patch-ab24
-rw-r--r--devel/uclmmbase/files/patch-ac28
-rw-r--r--devel/uclmmbase/files/patch-ad14
-rw-r--r--devel/uclmmbase/files/patch-ae15
-rw-r--r--devel/uclmmbase/files/patch-af2
-rw-r--r--devel/uclmmbase/files/patch-test9
-rw-r--r--devel/uclmmbase/pkg-plist3
15 files changed, 79 insertions, 107 deletions
diff --git a/devel/uclmmbase/Makefile b/devel/uclmmbase/Makefile
index 33d71905bff7..7c3aafb76558 100644
--- a/devel/uclmmbase/Makefile
+++ b/devel/uclmmbase/Makefile
@@ -6,16 +6,33 @@
#
PORTNAME= uclmmbase
-PORTVERSION= 1.2.8
+PORTVERSION= 1.2.16
CATEGORIES= devel ipv6
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/common/
DISTNAME= common-${PORTVERSION}
-MAINTAINER= fenner@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= Common subroutines for UCL mbone applications
WRKSRC= ${WRKDIR}/common
GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+
+post-configure:
+ @for f in ${FILESDIR}/*.bsd ; do \
+ ${LN} -sf $$f ${WRKSRC}/src/`${BASENAME} $$f .bsd` ; \
+ done
+
+# Run the test, and fail if we hit an error. Don't fail in case of
+# the networking-error, which may be due IPv6 (or IPv4) being unavailable
+# or some network (mis)configuration:
+post-build test:
+ ${WRKSRC}/tests/test-libcommon | ${AWK} ' \
+ /fail/ && $$2 != "networking" { code=1 } \
+ { print } END { exit code }'
+
+do-install:
+ cd ${WRKSRC}/src && ${MAKE_ENV} ${MAKE} install
.include <bsd.port.pre.mk>
@@ -23,15 +40,4 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-ipv6
.endif
-INSTALL_HDRS= base64.h config_win32.h config_unix.h crypt_random.h \
- debug.h hmac.h mbus.h md5.h memory.h net_udp.h qfDES.h \
- rtp.h uclconf.h util.h version.h
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/src/libuclmmbase.a ${PREFIX}/lib
- @${MKDIR} ${PREFIX}/include/uclmmbase
-.for file in ${INSTALL_HDRS}
- ${INSTALL_DATA} ${WRKSRC}/src/${file} ${PREFIX}/include/uclmmbase
-.endfor
-
.include <bsd.port.post.mk>
diff --git a/devel/uclmmbase/distinfo b/devel/uclmmbase/distinfo
index 56a266b1bfb7..d215c1a4c2ea 100644
--- a/devel/uclmmbase/distinfo
+++ b/devel/uclmmbase/distinfo
@@ -1,2 +1,2 @@
-MD5 (common-1.2.8.tar.gz) = 13198bdd2ffd12f2de34789ad243ba22
-SIZE (common-1.2.8.tar.gz) = 210433
+MD5 (common-1.2.16.tar.gz) = a2c493c7c4f8e31058da19c98ae0e6ea
+SIZE (common-1.2.16.tar.gz) = 247163
diff --git a/devel/uclmmbase/files/Makefile.bsd b/devel/uclmmbase/files/Makefile.bsd
new file mode 100644
index 000000000000..8d5ad11d7272
--- /dev/null
+++ b/devel/uclmmbase/files/Makefile.bsd
@@ -0,0 +1,30 @@
+CFLAGS+= -I${OPENSSLINC}
+LDADD = -L${OPENSSLLIB} -lssl -lcrypto
+VERSION!=cat ${.CURDIR:H}/VERSION
+LIB = uclmmbase
+NOPROFILE= yes
+SHLIB_MAJOR= ${VERSION:R:S/.//g}
+SHLIB_MINOR= ${VERSION:E}
+LIBDIR= ${PREFIX}/lib
+INCLUDEDIR= ${PREFIX}/include/${LIB}
+
+SRCS = base64.c debug.c memory.c net_udp.c qfDES.c util.c \
+ rijndael-api-fst.c rijndael-alg-fst.c \
+ ntp.c rtp.c mbus_parser.c mbus_config.c mbus_addr.c \
+ mbus.c asarray.c sdp.c sap.c qfDES.c
+
+INCS= base64.h config_win32.h config_unix.h crypt_random.h \
+ debug.h hmac.h mbus.h mbus_parser.h md5.h memory.h \
+ net_udp.h qfDES.h rtp.h uclconf.h util.h version.h
+
+all: version.h lib${LIB}.a ${SHLIB_NAME}
+
+version.h: ${.CURDIR:H}/VERSION
+ echo '#define CCL_VERSION "v${VERSION}"' > $@
+
+${INCLUDEDIR} ${LIBDIR}:
+ mkdir -p $@
+
+beforeinstall: ${INCLUDEDIR} ${LIBDIR}
+
+.include <bsd.lib.mk>
diff --git a/devel/uclmmbase/files/btree.h.bsd b/devel/uclmmbase/files/btree.h.bsd
new file mode 100644
index 000000000000..e9e067b7743d
--- /dev/null
+++ b/devel/uclmmbase/files/btree.h.bsd
@@ -0,0 +1,2 @@
+#include <sys/types.h>
+#include <db.h>
diff --git a/devel/uclmmbase/files/crypt_random.h.bsd b/devel/uclmmbase/files/crypt_random.h.bsd
new file mode 100644
index 000000000000..07214141ea53
--- /dev/null
+++ b/devel/uclmmbase/files/crypt_random.h.bsd
@@ -0,0 +1,4 @@
+#include <stdlib.h>
+
+#define lbl_random random
+#define lbl_srandom srandom
diff --git a/devel/uclmmbase/files/hmac.h.bsd b/devel/uclmmbase/files/hmac.h.bsd
new file mode 100644
index 000000000000..38a000e15dcd
--- /dev/null
+++ b/devel/uclmmbase/files/hmac.h.bsd
@@ -0,0 +1,4 @@
+#include <openssl/hmac.h>
+
+#define hmac_md5(data, datalen, key, keylen, digest) \
+ HMAC(EVP_md5(), key, keylen, data, datalen, digest, NULL)
diff --git a/devel/uclmmbase/files/md5.h.bsd b/devel/uclmmbase/files/md5.h.bsd
new file mode 100644
index 000000000000..d08ad42c7faf
--- /dev/null
+++ b/devel/uclmmbase/files/md5.h.bsd
@@ -0,0 +1,5 @@
+#include <openssl/md5.h>
+
+#define MD5Init MD5_Init
+#define MD5Update MD5_Update
+#define MD5Final MD5_Final
diff --git a/devel/uclmmbase/files/patch-aa b/devel/uclmmbase/files/patch-aa
deleted file mode 100644
index 42efe635f6ef..000000000000
--- a/devel/uclmmbase/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- examples/rtp/rtpdemo.c.orig Thu Sep 5 01:15:41 2002
-+++ examples/rtp/rtpdemo.c Thu Sep 5 01:15:23 2002
-@@ -101,6 +101,7 @@
- case RX_RTCP_FINISH:
- case RR_TIMEOUT:
- case RX_APP:
-+ break;
- }
- fflush(stdout);
- }
diff --git a/devel/uclmmbase/files/patch-ab b/devel/uclmmbase/files/patch-ab
deleted file mode 100644
index 49ec0efe232c..000000000000
--- a/devel/uclmmbase/files/patch-ab
+++ /dev/null
@@ -1,24 +0,0 @@
---- configure.in.orig Fri May 11 07:59:42 2001
-+++ configure.in Thu Jan 23 17:36:33 2003
-@@ -102,8 +102,8 @@
- # declared anywhere, use egrep header to check (ugh lame, but works)
-
- AC_CACHE_CHECK(for inet_pton in <arpa/inet.h>, ucl_cv_inet_pton_in_inet_h,
-- AC_EGREP_HEADER(uint16_t,
-- stdint.h,
-+ AC_EGREP_HEADER(inet_pton,
-+ arpa/inet.h,
- ucl_cv_inet_pton_in_inet_h=yes,
- ucl_cv_inet_pton_in_inet_h=no))
- if test $ucl_cv_inet_pton_in_inet_h = "no"
-@@ -112,8 +112,8 @@
- LIBOBJS="$LIBOBJS inet_pton.o"
- fi
- AC_CACHE_CHECK(for inet_ntop in <arpa/inet.h>, ucl_cv_inet_ntop_in_inet_h,
-- AC_EGREP_HEADER(uint16_t,
-- stdint.h,
-+ AC_EGREP_HEADER(inet_ntop,
-+ arpa/inet.h,
- ucl_cv_inet_ntop_in_inet_h=yes,
- ucl_cv_inet_ntop_in_inet_h=no))
- if test $ucl_cv_inet_ntop_in_inet_h = "no"
diff --git a/devel/uclmmbase/files/patch-ac b/devel/uclmmbase/files/patch-ac
deleted file mode 100644
index c202fcfe3753..000000000000
--- a/devel/uclmmbase/files/patch-ac
+++ /dev/null
@@ -1,28 +0,0 @@
---- configure.orig Fri May 11 07:59:42 2001
-+++ configure Thu Jan 23 17:29:08 2003
-@@ -1928,10 +1928,10 @@
- cat > conftest.$ac_ext <<EOF
- #line 1930 "configure"
- #include "confdefs.h"
--#include <stdint.h>
-+#include <arpa/inet.h>
- EOF
- if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
-- egrep "uint16_t" >/dev/null 2>&1; then
-+ egrep "inet_pton" >/dev/null 2>&1; then
- rm -rf conftest*
- ucl_cv_inet_pton_in_inet_h=yes
- else
-@@ -1959,10 +1959,10 @@
- cat > conftest.$ac_ext <<EOF
- #line 1961 "configure"
- #include "confdefs.h"
--#include <stdint.h>
-+#include <arpa/inet.h>
- EOF
- if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
-- egrep "uint16_t" >/dev/null 2>&1; then
-+ egrep "inet_ntop" >/dev/null 2>&1; then
- rm -rf conftest*
- ucl_cv_inet_ntop_in_inet_h=yes
- else
diff --git a/devel/uclmmbase/files/patch-ad b/devel/uclmmbase/files/patch-ad
deleted file mode 100644
index 795bf55bcf25..000000000000
--- a/devel/uclmmbase/files/patch-ad
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/inet_ntop.h.orig Thu Jan 23 17:35:36 2003
-+++ src/inet_ntop.h Thu Jan 23 17:35:45 2003
-@@ -1,4 +1,4 @@
--#ifndef HAVE_INET_NTOP
-+#ifdef NEED_INET_NTOP
- #if defined(__cplusplus)
- extern "C" {
- #endif
-@@ -8,4 +8,4 @@
- #if defined(__cplusplus)
- }
- #endif
--#endif /* HAVE_INET_NTOP */
-+#endif /* NEED_INET_NTOP */
diff --git a/devel/uclmmbase/files/patch-ae b/devel/uclmmbase/files/patch-ae
deleted file mode 100644
index cf7a3c5b88dd..000000000000
--- a/devel/uclmmbase/files/patch-ae
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/inet_pton.h.orig Thu Jan 23 17:35:17 2003
-+++ src/inet_pton.h Thu Jan 23 17:35:29 2003
-@@ -1,4 +1,4 @@
--#ifndef HAVE_INET_PTON
-+#ifdef NEED_INET_PTON
- #if defined(__cplusplus)
- extern "C" {
- #endif
-@@ -8,5 +8,5 @@
- #if defined(__cplusplus)
- }
- #endif
--#endif /* HAVE_INET_PTON */
-+#endif /* NEED_INET_PTON */
-
diff --git a/devel/uclmmbase/files/patch-af b/devel/uclmmbase/files/patch-af
index d380c5522694..7b92000efeda 100644
--- a/devel/uclmmbase/files/patch-af
+++ b/devel/uclmmbase/files/patch-af
@@ -1,4 +1,4 @@
---- src/mbus_parser.c.orig Thu Jan 23 17:39:55 2003
+--- src/mbus_parser.c Thu Jan 23 17:39:55 2003
+++ src/mbus_parser.c Thu Jan 23 17:41:26 2003
@@ -158,6 +158,7 @@
int mbus_parse_int(struct mbus_parser *m, int *i)
diff --git a/devel/uclmmbase/files/patch-test b/devel/uclmmbase/files/patch-test
new file mode 100644
index 000000000000..b1b3e93392a2
--- /dev/null
+++ b/devel/uclmmbase/files/patch-test
@@ -0,0 +1,9 @@
+--- tests/Makefile.in Fri Mar 9 11:39:57 2001
++++ tests/Makefile.in Thu Sep 23 16:40:19 2004
+@@ -10,5 +10,5 @@
+ DEFS = @DEFS@
+ CFLAGS = -I$(COMMONSRC) @CFLAGS@ $(DEFS)
+-LIBS = -L../src @LIBS@
++LIBS = -L../src @LIBS@ -L${OPENSSLLIB}/lib -lssl -lcrypto
+ CC = @CC@
+
diff --git a/devel/uclmmbase/pkg-plist b/devel/uclmmbase/pkg-plist
index bd9817fc515c..29a448962352 100644
--- a/devel/uclmmbase/pkg-plist
+++ b/devel/uclmmbase/pkg-plist
@@ -5,6 +5,7 @@ include/uclmmbase/crypt_random.h
include/uclmmbase/debug.h
include/uclmmbase/hmac.h
include/uclmmbase/mbus.h
+include/uclmmbase/mbus_parser.h
include/uclmmbase/md5.h
include/uclmmbase/memory.h
include/uclmmbase/net_udp.h
@@ -14,4 +15,6 @@ include/uclmmbase/uclconf.h
include/uclmmbase/util.h
include/uclmmbase/version.h
lib/libuclmmbase.a
+lib/libuclmmbase.so
+lib/libuclmmbase.so.12
@dirrm include/uclmmbase