aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-18 18:41:13 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-18 18:41:13 +0000
commitb9f5999732e7222774f10d977b14daa0de7edb33 (patch)
tree044201e303293fd0309f62c7913147adac234a3f /devel
parentd1e3ce6200d91f3614414d6fe681770741edf369 (diff)
downloadports-b9f5999732e7222774f10d977b14daa0de7edb33.tar.gz
ports-b9f5999732e7222774f10d977b14daa0de7edb33.zip
- Add OPTIONS to some freepascal ports. Now, we can install the external libs
optionally.[1] - Other tiny modifications Suggested by: Ales Catona <almindor__at__gmail.com> [1] Approved by: garga(mentor, implicit)
Notes
Notes: svn path=/head/; revision=173353
Diffstat (limited to 'devel')
-rw-r--r--devel/fpc-bfd/Makefile5
-rw-r--r--devel/fpc-fcl-base/Makefile2
-rw-r--r--devel/fpc-fcl-base/fpc-fcl/Makefile2
-rw-r--r--devel/fpc-fcl-db/Makefile2
-rw-r--r--devel/fpc-fcl-fpcunit/Makefile2
-rw-r--r--devel/fpc-fcl-image/Makefile2
-rw-r--r--devel/fpc-fcl-net/Makefile2
-rw-r--r--devel/fpc-fcl-passrc/Makefile2
-rw-r--r--devel/fpc-fcl-registry/Makefile2
-rw-r--r--devel/fpc-fcl-web/Makefile2
-rw-r--r--devel/fpc-fcl-xml/Makefile2
-rw-r--r--devel/fpc-fcl/Makefile2
-rw-r--r--devel/fpc-fv/Makefile1
-rw-r--r--devel/fpc-gconf/Makefile7
-rw-r--r--devel/fpc-gdbint/Makefile1
-rw-r--r--devel/fpc-regexpr/Makefile1
16 files changed, 6 insertions, 31 deletions
diff --git a/devel/fpc-bfd/Makefile b/devel/fpc-bfd/Makefile
index fb49bcd4e38e..cac28735d032 100644
--- a/devel/fpc-bfd/Makefile
+++ b/devel/fpc-bfd/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -bfd
@@ -14,10 +14,11 @@ COMMENT= Free Pascal interface for the GNU Binary Format description
BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
fpcmake:${PORTSDIR}/lang/fpc-utils
-RUN_DEPENDS= ${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/extra/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
+OPTIONS= LIBBFD "Install Universal BFD library from GNU binutils" on
+
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-base/Makefile b/devel/fpc-fcl-base/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-base/Makefile
+++ b/devel/fpc-fcl-base/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-base/fpc-fcl/Makefile b/devel/fpc-fcl-base/fpc-fcl/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-base/fpc-fcl/Makefile
+++ b/devel/fpc-fcl-base/fpc-fcl/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-db/Makefile b/devel/fpc-fcl-db/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-db/Makefile
+++ b/devel/fpc-fcl-db/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-fpcunit/Makefile b/devel/fpc-fcl-fpcunit/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-fpcunit/Makefile
+++ b/devel/fpc-fcl-fpcunit/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-image/Makefile b/devel/fpc-fcl-image/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-image/Makefile
+++ b/devel/fpc-fcl-image/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-net/Makefile b/devel/fpc-fcl-net/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-net/Makefile
+++ b/devel/fpc-fcl-net/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-passrc/Makefile b/devel/fpc-fcl-passrc/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-passrc/Makefile
+++ b/devel/fpc-fcl-passrc/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-registry/Makefile b/devel/fpc-fcl-registry/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-registry/Makefile
+++ b/devel/fpc-fcl-registry/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-web/Makefile b/devel/fpc-fcl-web/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-web/Makefile
+++ b/devel/fpc-fcl-web/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-xml/Makefile b/devel/fpc-fcl-xml/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl-xml/Makefile
+++ b/devel/fpc-fcl-xml/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl/Makefile b/devel/fpc-fcl/Makefile
index 55f4c0ae3474..19228eaa498c 100644
--- a/devel/fpc-fcl/Makefile
+++ b/devel/fpc-fcl/Makefile
@@ -33,7 +33,5 @@ UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR} ${FPCSRCDIR}/rtl ${FPCSRCDIR}/packages/base
-OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fv/Makefile b/devel/fpc-fv/Makefile
index 0f6386d451e3..10a351dac40e 100644
--- a/devel/fpc-fv/Makefile
+++ b/devel/fpc-fv/Makefile
@@ -18,6 +18,5 @@ BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-gconf/Makefile b/devel/fpc-gconf/Makefile
index 46fe8f159f33..f50aafdf028d 100644
--- a/devel/fpc-gconf/Makefile
+++ b/devel/fpc-gconf/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -gconf
@@ -18,12 +18,11 @@ BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
${UNITSDIR}/x11/Package.fpc:${PORTSDIR}/x11/fpc-x11 \
${UNITSDIR}/opengl/Package.fpc:${PORTSDIR}/graphics/fpc-opengl
-USE_GNOME= gconf
-
UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/extra/gnome1/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
-HAVE_EXAMPLES= true
+
+OPTIONS= GCONF "Install gconf, a configuration database system" on
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-gdbint/Makefile b/devel/fpc-gdbint/Makefile
index a0ae91dbe8a9..60c9aeac651f 100644
--- a/devel/fpc-gdbint/Makefile
+++ b/devel/fpc-gdbint/Makefile
@@ -17,6 +17,5 @@ BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/base/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-regexpr/Makefile b/devel/fpc-regexpr/Makefile
index 5ec31ef5d0c5..790d67d0e155 100644
--- a/devel/fpc-regexpr/Makefile
+++ b/devel/fpc-regexpr/Makefile
@@ -17,6 +17,5 @@ BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/base/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
-HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"