aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-03-18 17:49:42 +0000
committerChris Rees <crees@FreeBSD.org>2012-03-18 17:49:42 +0000
commitff48c28a56a7f162dfe2a904c4efd3c732662102 (patch)
tree410a55d70dbcb6693e2134abc201405d471ee706 /devel
parent82e87de646195d04663a713317ca8c7e0eef3b67 (diff)
downloadports-ff48c28a56a7f162dfe2a904c4efd3c732662102.tar.gz
ports-ff48c28a56a7f162dfe2a904c4efd3c732662102.zip
Many find Bugzilla's web-based UI inefficient. PyBugz is a command-line based
interface that was written by Alastair Tse in order to improve his interaction with Gentoo Bugzilla Features -------- * Searching bugzilla * Listing details of a bug including comments and attachments * Downloading/viewing attachments from bugzilla * Posting bugs, comments, and making changes to an existing bug. * Adding attachments to a bug. There is extensive help in `bugz --help` and `bugz <subcommand> --help` for additional options. WWW: https://github.com/williamh/pybugz Feature safe: yes
Notes
Notes: svn path=/head/; revision=293525
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pybugz/Makefile27
-rw-r--r--devel/pybugz/distinfo2
-rw-r--r--devel/pybugz/pkg-descr16
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9f9d01fe2329..985f599fafd0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3484,6 +3484,7 @@
SUBDIR += py-zope.viewlet
SUBDIR += py_static_check
SUBDIR += pybaz
+ SUBDIR += pybugz
SUBDIR += pychecker
SUBDIR += pycount
SUBDIR += pylint
diff --git a/devel/pybugz/Makefile b/devel/pybugz/Makefile
new file mode 100644
index 000000000000..bc0cdf0c47cb
--- /dev/null
+++ b/devel/pybugz/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-pybugz
+# Date created: 2012-03-18
+# Whom: Chris Rees <crees@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pybugz
+PORTVERSION= 0.9.3
+CATEGORIES= devel
+MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Command line tools for interacting with Bugzilla
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS=yes
+
+PLIST_FILES= bin/bugz
+DATADIR= ${PYTHON_SITELIBDIR}/bugz
+PORTDATA= *
+
+.include <bsd.port.mk>
diff --git a/devel/pybugz/distinfo b/devel/pybugz/distinfo
new file mode 100644
index 000000000000..41ef85bd2be3
--- /dev/null
+++ b/devel/pybugz/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pybugz-0.9.3.tar.gz) = cc572ac66f372fe222e5e6e390c295b6fde1b72debdd1d9fa23c67b1d218daa7
+SIZE (pybugz-0.9.3.tar.gz) = 232381
diff --git a/devel/pybugz/pkg-descr b/devel/pybugz/pkg-descr
new file mode 100644
index 000000000000..6755d914d45e
--- /dev/null
+++ b/devel/pybugz/pkg-descr
@@ -0,0 +1,16 @@
+Many find Bugzilla's web-based UI inefficient. PyBugz is a command-line based
+interface that was written by Alastair Tse in order to improve his interaction
+with Gentoo Bugzilla
+
+Features
+--------
+* Searching bugzilla
+* Listing details of a bug including comments and attachments
+* Downloading/viewing attachments from bugzilla
+* Posting bugs, comments, and making changes to an existing bug.
+* Adding attachments to a bug.
+
+There is extensive help in `bugz --help` and `bugz <subcommand>
+--help` for additional options.
+
+WWW: https://github.com/williamh/pybugz