aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-29 20:15:51 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-29 20:15:51 +0000
commit3d4806fc37a87d5ab8160f302e1b849b6c5665a4 (patch)
tree2944366faeeaccddf90578187625390486561795 /devel
parentcba93ee80a9c660bc483e5f574485f0b10efb3b1 (diff)
downloadports-3d4806fc37a87d5ab8160f302e1b849b6c5665a4.tar.gz
ports-3d4806fc37a87d5ab8160f302e1b849b6c5665a4.zip
libftdi - A library (using libusb) to talk to FTDI's FT2232C,
FT232BM and FT245BM type chips including the popular bitbang mode. Note: When you get a -5 error "can't claim usb device" during ftdi_usb_open(), make sure the kernel ftdi_sio driver is unloaded. WWW: http://www.intra2net.com/de/produkte/opensource/ftdi/ PR: ports/100982 Submitted by: Olexandr Davydenko <o.davydenko at gmail.com>
Notes
Notes: svn path=/head/; revision=169078
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libftdi/Makefile48
-rw-r--r--devel/libftdi/distinfo3
-rw-r--r--devel/libftdi/pkg-descr7
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 070fe963880f..01566c4ea366 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -502,6 +502,7 @@
SUBDIR += libffi
SUBDIR += libformat
SUBDIR += libfs++
+ SUBDIR += libftdi
SUBDIR += libg++
SUBDIR += libgconf-java
SUBDIR += libgetline
diff --git a/devel/libftdi/Makefile b/devel/libftdi/Makefile
new file mode 100644
index 000000000000..a6f7d637d7bd
--- /dev/null
+++ b/devel/libftdi/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: libftdi
+# Date created: 2006-07-27
+# Whom: Olexandr Davydenko <o.davydenko@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libftdi
+PORTVERSION= 0.7
+CATEGORIES= devel
+MASTER_SITES= http://www.intra2net.com/de/produkte/opensource/ftdi/TGZ/
+
+MAINTAINER= o.davydenko@gmail.com
+COMMENT= A library (using libusb) to talk to FTDI chips
+
+LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig
+
+PORTDOCS= COPYING.LIB ChangeLog README
+PLIST_FILES= bin/libftdi-config \
+ include/ftdi.h \
+ lib/libftdi.a \
+ lib/libftdi.la \
+ lib/libftdi.so \
+ lib/libftdi.so.7 \
+ libdata/pkgconfig/libftdi.pc
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= doesn't install on FreeBSD 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libftdi/distinfo b/devel/libftdi/distinfo
new file mode 100644
index 000000000000..484b7504b779
--- /dev/null
+++ b/devel/libftdi/distinfo
@@ -0,0 +1,3 @@
+MD5 (libftdi-0.7.tar.gz) = c9ba4ea7544799e81cbd881f90ee3574
+SHA256 (libftdi-0.7.tar.gz) = 1d1b93227135d50230e6b0ba4eab91df45d293352b4cba83443787eba4398229
+SIZE (libftdi-0.7.tar.gz) = 171953
diff --git a/devel/libftdi/pkg-descr b/devel/libftdi/pkg-descr
new file mode 100644
index 000000000000..47425720dc62
--- /dev/null
+++ b/devel/libftdi/pkg-descr
@@ -0,0 +1,7 @@
+libftdi - A library (using libusb) to talk to FTDI's FT2232C,
+FT232BM and FT245BM type chips including the popular bitbang mode.
+
+Note: When you get a -5 error "can't claim usb device" during
+ftdi_usb_open(), make sure the kernel ftdi_sio driver is unloaded.
+
+WWW: http://www.intra2net.com/de/produkte/opensource/ftdi/