aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-01-02 18:46:02 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-01-02 18:46:02 +0000
commit7f3a54fa49be11e3581b480c6adf4b4f36d07210 (patch)
tree962a33a1258ac5b20b6d568856861889b1d0d694 /devel
parent1daeb80ca77a2fdcb78523bc03317f4f2ba88c92 (diff)
downloadports-7f3a54fa49be11e3581b480c6adf4b4f36d07210.tar.gz
ports-7f3a54fa49be11e3581b480c6adf4b4f36d07210.zip
- Add two bugfixes I submitted to get the vdr upnp plugin working that
now are also committed upstream: http://lists.freebsd.org/pipermail/freebsd-multimedia/2011-January/011531.html - Bump PORTREVISION. Approved by: "Pawel Pekala" <c0rn@o2.pl> (maintainer, via private email)
Notes
Notes: svn path=/head/; revision=267289
Diffstat (limited to 'devel')
-rw-r--r--devel/upnp/Makefile1
-rw-r--r--devel/upnp/files/patch-upnp-src-gena-gena_device.c11
-rw-r--r--devel/upnp/files/patch-upnp-src-genlib-net-http-webserver.c11
3 files changed, 23 insertions, 0 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
index 2a1fadc661eb..6ba13f1312c4 100644
--- a/devel/upnp/Makefile
+++ b/devel/upnp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= upnp
PORTVERSION= 1.6.9
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= SF/p${PORTNAME}/p${PORTNAME}/libUPnP%20${PORTVERSION}
diff --git a/devel/upnp/files/patch-upnp-src-gena-gena_device.c b/devel/upnp/files/patch-upnp-src-gena-gena_device.c
new file mode 100644
index 000000000000..9bd298fd529e
--- /dev/null
+++ b/devel/upnp/files/patch-upnp-src-gena-gena_device.c
@@ -0,0 +1,11 @@
+--- upnp/src/gena/gena_device.c.orig
++++ upnp/src/gena/gena_device.c
+@@ -225,7 +225,7 @@ static UPNP_INLINE int notify_send_and_r
+ "bbb",
+ start_msg.buf, start_msg.length,
+ propertySet, strlen(propertySet),
+- "\r\n", 2);
++ "\r\n", sizeof "\r\n" - 1);
+ if (ret_code) {
+ membuffer_destroy(&start_msg);
+ sock_destroy(&info, SD_BOTH);
diff --git a/devel/upnp/files/patch-upnp-src-genlib-net-http-webserver.c b/devel/upnp/files/patch-upnp-src-genlib-net-http-webserver.c
new file mode 100644
index 000000000000..6c64d59dc494
--- /dev/null
+++ b/devel/upnp/files/patch-upnp-src-genlib-net-http-webserver.c
@@ -0,0 +1,11 @@
+--- upnp/src/genlib/net/http/webserver.c.orig
++++ upnp/src/genlib/net/http/webserver.c
+@@ -1262,7 +1262,7 @@ static int process_request(
+ // Content-Range: bytes 222-3333/4000 HTTP_PARTIAL_CONTENT
+ // Transfer-Encoding: chunked
+ if (http_MakeMessage(headers, resp_major, resp_minor,
+- "R" "TLD" "s" "tcS" "b" "Xc" "sCc",
++ "R" "TLD" "s" "tcS" "Xc" "sCc",
+ HTTP_OK, // status code
+ finfo.content_type, // content type
+ RespInstr, // language info