aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-03 18:17:53 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-03 18:17:53 +0000
commit85c54a34d9dbd7dd7ce53957501bb91fbb3f9a29 (patch)
treedda2caf198294a44b5712ce5e3da2dbac8f07903 /devel
parenta9a963efd1b643dbdeaefae96cda40c0aef559ed (diff)
downloadports-85c54a34d9dbd7dd7ce53957501bb91fbb3f9a29.tar.gz
ports-85c54a34d9dbd7dd7ce53957501bb91fbb3f9a29.zip
Restore the possibility to define EXTRA_COMPILERS which must reside in $PATH.
PR: 158888 Submitted by: Pan Tsu <inyaoo@gmail.com>
Notes
Notes: svn path=/head/; revision=278868
Diffstat (limited to 'devel')
-rw-r--r--devel/ccache/Makefile2
-rw-r--r--devel/ccache/files/ccache-update-links.sh.in2
2 files changed, 3 insertions, 1 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index c0af09ea0d89..f489e7aaf2cf 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ccache
PORTVERSION= 3.1.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://samba.org/ftp/ccache/ CRITICAL
@@ -35,6 +36,7 @@ CCACHE_COMPILERS+= icc icpc
GNU_COMPILERS+= 34 42 43 44 45 46
CCACHE_COMPILERS+= cc c++ gcc g++ ${GNU_COMPILERS:S|^|gcc|} ${GNU_COMPILERS:S|^|g++|}
CCACHE_COMPILERS+= clang clang++ llvm-gcc llvm-c++ llvm-g++
+CCACHE_COMPILERS+= ${EXTRA_COMPILERS}
SUB_LIST+= CCACHE_COMPILERS="${CCACHE_COMPILERS}" \
CCLINKDIR="${CCLINKDIR}" \
ICCPREFIX="${LOCALBASE}/intel_cc_80/bin" \
diff --git a/devel/ccache/files/ccache-update-links.sh.in b/devel/ccache/files/ccache-update-links.sh.in
index 66ebd2d092ff..ce49ce718907 100644
--- a/devel/ccache/files/ccache-update-links.sh.in
+++ b/devel/ccache/files/ccache-update-links.sh.in
@@ -32,7 +32,7 @@ esac
# create compiler links
for comp in ${CCACHE_COMPILERS}
do
- if [ -f "${PREFIX}/bin/${comp}" ] || [ -f "/usr/bin/${comp}" ]; then
+ if command -v "${comp}" >/dev/null; then
if [ ! -L "${PREFIX}/${CCLINKDIR}/${comp}" ]; then
[ "$1" = "-v" ] && echo "create symlink for ${comp}"
ln -sf ${PREFIX}/bin/ccache ${PREFIX}/${CCLINKDIR}/${comp}