aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-11-18 12:25:07 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-11-18 12:25:07 +0000
commita3959ef040e4e2b93f45a115c8e126b00f0853db (patch)
tree7bb2329c85cfd77224ae42f7d3b15a5bee55e059 /devel
parent3c8baec5f86e3eb18a1960e9fa3e10137629406d (diff)
downloadports-a3959ef040e4e2b93f45a115c8e126b00f0853db.tar.gz
ports-a3959ef040e4e2b93f45a115c8e126b00f0853db.zip
Update to 3.0.0
PR: 89193 Submitted by: Boris B. Samorodov <bsam@ipt.ru> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=148718
Diffstat (limited to 'devel')
-rw-r--r--devel/ice/Makefile4
-rw-r--r--devel/ice/distinfo5
-rw-r--r--devel/ice/files/patch-Makefile27
-rw-r--r--devel/ice/files/patch-include::IceUtil::Config.h11
-rw-r--r--devel/ice/files/patch-src::Ice::Network.cpp20
-rw-r--r--devel/ice/files/patch-src::icecpp::config.h17
-rw-r--r--devel/ice/pkg-plist495
7 files changed, 309 insertions, 270 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 7653d7690b78..cca41dae5ddc 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= Ice
-PORTVERSION= 2.1.2
+PORTVERSION= 3.0.0
CATEGORIES= devel
-MASTER_SITES= http://www.zeroc.com/download/Ice/2.1/
+MASTER_SITES= http://www.zeroc.com/download/Ice/3.0/
MAINTAINER= shoesoft@gmx.net
COMMENT= A modern alternative to object middleware such as CORBA/COM/DCOM/COM+
diff --git a/devel/ice/distinfo b/devel/ice/distinfo
index e17dd72eecf6..b59151700a94 100644
--- a/devel/ice/distinfo
+++ b/devel/ice/distinfo
@@ -1,2 +1,3 @@
-MD5 (Ice-2.1.2.tar.gz) = 714dfe9923f0a0683e302c1f1c51a8cb
-SIZE (Ice-2.1.2.tar.gz) = 1695626
+MD5 (Ice-3.0.0.tar.gz) = e8401842669d08baf152ea8edb595a11
+SHA256 (Ice-3.0.0.tar.gz) = 8362d732d22fe03c63f9a3e8b63abadec850ce34e99904ea75469a5789b6b190
+SIZE (Ice-3.0.0.tar.gz) = 1833278
diff --git a/devel/ice/files/patch-Makefile b/devel/ice/files/patch-Makefile
index b0099528c0cf..46f3411d4c2c 100644
--- a/devel/ice/files/patch-Makefile
+++ b/devel/ice/files/patch-Makefile
@@ -1,25 +1,14 @@
---- Makefile.orig Tue Jul 5 19:58:47 2005
-+++ Makefile Tue Jul 5 19:59:39 2005
-@@ -44,11 +44,13 @@
- $(call mkdir,$(install_slicedir)) ; \
- fi
-
-+ifndef NOPORTDOCS
- @if test ! -d $(install_docdir) ; \
- then \
- echo "Creating $(install_docdir)..." ; \
- $(call mkdir,$(install_docdir)) ; \
- fi
-+endif
-
- $(EVERYTHING)::
- @for subdir in $(SUBDIRS); \
-@@ -61,9 +63,11 @@
+--- Makefile.orig Tue Jul 26 23:32:00 2005
++++ Makefile Thu Nov 17 10:15:57 2005
+@@ -43,12 +43,14 @@
@( cd doc && $(MAKE) ) || exit 1
install::
+ifndef NOPORTDOCS
- @( cd doc && $(MAKE) install ) || exit 1
+ @if test -d doc ; \
+ then \
+ ( cd doc && $(MAKE) install ) || exit 1 ; \
+ fi
- $(call installdata,ICE_LICENSE,$(prefix))
- $(call installdata,LICENSE,$(prefix))
+ $(call installdata,ICE_LICENSE,$(install_docdir))
@@ -27,4 +16,4 @@
+endif
clean::
- @( cd doc && $(MAKE) clean ) || exit 1
+ @if test -d doc ; \
diff --git a/devel/ice/files/patch-include::IceUtil::Config.h b/devel/ice/files/patch-include::IceUtil::Config.h
deleted file mode 100644
index 235ee4e818be..000000000000
--- a/devel/ice/files/patch-include::IceUtil::Config.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/IceUtil/Config.h.orig Thu Jul 22 01:21:08 2004
-+++ include/IceUtil/Config.h Tue Jul 27 16:16:48 2004
-@@ -16,7 +16,7 @@
- // Most CPUs support only one endianness, with the notable exceptions
- // of Itanium (IA64) and MIPS.
- //
--#if defined(__i386) || defined(_M_IX86) || defined (__x86_64)
-+#if defined(__i386) || defined(_M_IX86) || defined (__x86_64) || defined(__alpha__)
- # define ICE_LITTLE_ENDIAN
- #elif defined(__sparc) || defined(__sparc__) || defined(__hppa) || defined(__ppc__) || defined(_ARCH_COM)
- # define ICE_BIG_ENDIAN
diff --git a/devel/ice/files/patch-src::Ice::Network.cpp b/devel/ice/files/patch-src::Ice::Network.cpp
new file mode 100644
index 000000000000..3189931d7844
--- /dev/null
+++ b/devel/ice/files/patch-src::Ice::Network.cpp
@@ -0,0 +1,20 @@
+--- src/Ice/Network.cpp.orig Tue Oct 18 16:18:39 2005
++++ src/Ice/Network.cpp Thu Nov 17 15:00:25 2005
+@@ -275,7 +275,7 @@
+ {
+ return;
+ }
+-#elif defined(__APPLE__)
++#elif (defined(__APPLE__) || defined(__FreeBSD__))
+ if(errno == ENOTCONN || errno == EINVAL)
+ {
+ return;
+@@ -306,7 +306,7 @@
+ {
+ return;
+ }
+-#elif defined(__APPLE__)
++#elif (defined(__APPLE__) || defined(__FreeBSD__))
+ if(errno == ENOTCONN || errno == EINVAL)
+ {
+ return;
diff --git a/devel/ice/files/patch-src::icecpp::config.h b/devel/ice/files/patch-src::icecpp::config.h
index 14c32a505917..32a5bee093a0 100644
--- a/devel/ice/files/patch-src::icecpp::config.h
+++ b/devel/ice/files/patch-src::icecpp::config.h
@@ -1,11 +1,12 @@
---- src/icecpp/config.h.orig Wed Feb 16 21:22:23 2005
-+++ src/icecpp/config.h Wed Jun 8 12:28:58 2005
-@@ -56,7 +56,7 @@
- #define LONG_TYPE_SIZE 4
+--- src/icecpp/config.h.orig Thu Sep 22 18:01:13 2005
++++ src/icecpp/config.h Thu Nov 17 10:50:07 2005
+@@ -72,7 +72,8 @@
#if defined(_WIN32)
# define WCHAR_TYPE_SIZE 2
--#elif (defined(__linux) || defined(__FreeBSD__)) && (defined(__i386) || defined(__x86_64) || defined(__sparc)) \
-+#elif (defined(__linux) || defined(__FreeBSD__)) && (defined(__i386) || defined(__x86_64) || defined(__sparc) || defined(__alpha__) || defined(__powerpc__)) \
- || defined (__sun) || defined(__hpux) || defined(__APPLE__) || defined(_AIX)
+ #elif (defined(__linux) || defined(__FreeBSD__)) && \
+- (defined(__i386) || defined(__x86_64) || defined(__sparc)) || \
++ (defined(__i386) || defined(__x86_64) || defined(__sparc) || \
++ defined(__alpha__) || defined(__powerpc__)) || \
+ defined (__sun) || defined(__hpux) || defined(__APPLE__) || \
+ defined(_AIX) || defined(__osf1__)
# define WCHAR_TYPE_SIZE 4
- #else
diff --git a/devel/ice/pkg-plist b/devel/ice/pkg-plist
index 59e7623a4954..eb2d1d029e89 100644
--- a/devel/ice/pkg-plist
+++ b/devel/ice/pkg-plist
@@ -3,9 +3,9 @@ bin/glacier2router
bin/icebox
bin/iceboxadmin
bin/icecpp
-bin/icepackadmin
-bin/icepacknode
-bin/icepackregistry
+bin/icegridadmin
+bin/icegridnode
+bin/icegridregistry
bin/icepatch2calc
bin/icepatch2client
bin/icepatch2server
@@ -57,7 +57,8 @@ include/Ice/Current.h
include/Ice/Direct.h
include/Ice/DynamicLibrary.h
include/Ice/DynamicLibraryF.h
-include/Ice/EndpointF.h
+include/Ice/Endpoint.h
+include/Ice/EndpointIF.h
include/Ice/EndpointFactory.h
include/Ice/EndpointFactoryF.h
include/Ice/Exception.h
@@ -65,6 +66,9 @@ include/Ice/FacetMap.h
include/Ice/FactoryTable.h
include/Ice/FactoryTableDef.h
include/Ice/Functional.h
+include/Ice/GC.h
+include/Ice/GCShared.h
+include/Ice/GCRecMutex.h
include/Ice/Handle.h
include/Ice/Ice.h
include/Ice/Identity.h
@@ -119,12 +123,16 @@ include/Ice/Stats.h
include/Ice/StatsF.h
include/Ice/Stream.h
include/Ice/StreamF.h
+include/Ice/UndefSysMacros.h
include/Ice/UserExceptionFactory.h
include/Ice/UserExceptionFactoryF.h
include/IceBox/IceBox.h
-include/IcePack/Admin.h
-include/IcePack/Exception.h
-include/IcePack/Query.h
+include/IceGrid/Admin.h
+include/IceGrid/Descriptor.h
+include/IceGrid/Exception.h
+include/IceGrid/Observer.h
+include/IceGrid/Perf.h
+include/IceGrid/Query.h
include/IcePatch2/ClientUtil.h
include/IcePatch2/FileInfo.h
include/IcePatch2/FileServer.h
@@ -145,6 +153,7 @@ include/IceSSL/RSAPrivateKeyF.h
include/IceSSL/RSAPublicKey.h
include/IceSSL/RSAPublicKeyF.h
include/IceStorm/IceStorm.h
+include/IceStorm/Service.h
include/IceUtil/AbstractMutex.h
include/IceUtil/Algorithm.h
include/IceUtil/Base64.h
@@ -155,9 +164,6 @@ include/IceUtil/CountDownLatch.h
include/IceUtil/CtrlCHandler.h
include/IceUtil/Exception.h
include/IceUtil/Functional.h
-include/IceUtil/GC.h
-include/IceUtil/GCRecMutex.h
-include/IceUtil/GCShared.h
include/IceUtil/Handle.h
include/IceUtil/IceUtil.h
include/IceUtil/InputUtil.h
@@ -189,41 +195,41 @@ include/Slice/Preprocessor.h
include/Slice/PythonUtil.h
include/Slice/VbUtil.h
lib/libFreeze.so
-lib/libFreeze.so.2.1.2
-lib/libFreeze.so.21
+lib/libFreeze.so.3.0.0
+lib/libFreeze.so.30
lib/libGlacier2.so
-lib/libGlacier2.so.2.1.2
-lib/libGlacier2.so.21
+lib/libGlacier2.so.3.0.0
+lib/libGlacier2.so.30
lib/libIce.so
-lib/libIce.so.2.1.2
-lib/libIce.so.21
+lib/libIce.so.3.0.0
+lib/libIce.so.30
lib/libIceBox.so
-lib/libIceBox.so.2.1.2
-lib/libIceBox.so.21
-lib/libIcePack.so
-lib/libIcePack.so.2.1.2
-lib/libIcePack.so.21
+lib/libIceBox.so.3.0.0
+lib/libIceBox.so.30
+lib/libIceGrid.so
+lib/libIceGrid.so.3.0.0
+lib/libIceGrid.so.30
lib/libIcePatch2.so
-lib/libIcePatch2.so.2.1.2
-lib/libIcePatch2.so.21
+lib/libIcePatch2.so.3.0.0
+lib/libIcePatch2.so.30
lib/libIceSSL.so
-lib/libIceSSL.so.2.1.2
-lib/libIceSSL.so.21
+lib/libIceSSL.so.3.0.0
+lib/libIceSSL.so.30
lib/libIceStorm.so
-lib/libIceStorm.so.2.1.2
-lib/libIceStorm.so.21
+lib/libIceStorm.so.3.0.0
+lib/libIceStorm.so.30
lib/libIceStormService.so
-lib/libIceStormService.so.2.1.2
-lib/libIceStormService.so.21
+lib/libIceStormService.so.3.0.0
+lib/libIceStormService.so.30
lib/libIceUtil.so
-lib/libIceUtil.so.2.1.2
-lib/libIceUtil.so.21
+lib/libIceUtil.so.3.0.0
+lib/libIceUtil.so.30
lib/libIceXML.so
-lib/libIceXML.so.2.1.2
-lib/libIceXML.so.21
+lib/libIceXML.so.3.0.0
+lib/libIceXML.so.30
lib/libSlice.so
-lib/libSlice.so.2.1.2
-lib/libSlice.so.21
+lib/libSlice.so.3.0.0
+lib/libSlice.so.30
share/Ice/Freeze/CatalogData.ice
share/Ice/Freeze/Connection.ice
share/Ice/Freeze/ConnectionF.ice
@@ -245,6 +251,7 @@ share/Ice/Ice/CommunicatorF.ice
share/Ice/Ice/Connection.ice
share/Ice/Ice/ConnectionF.ice
share/Ice/Ice/Current.ice
+share/Ice/Ice/Endpoint.ice
share/Ice/Ice/FacetMap.ice
share/Ice/Ice/Identity.ice
share/Ice/Ice/LocalException.ice
@@ -270,9 +277,11 @@ share/Ice/Ice/SliceChecksumDict.ice
share/Ice/Ice/Stats.ice
share/Ice/Ice/StatsF.ice
share/Ice/IceBox/IceBox.ice
-share/Ice/IcePack/Admin.ice
-share/Ice/IcePack/Exception.ice
-share/Ice/IcePack/Query.ice
+share/Ice/IceGrid/Admin.ice
+share/Ice/IceGrid/Descriptor.ice
+share/Ice/IceGrid/Exception.ice
+share/Ice/IceGrid/Observer.ice
+share/Ice/IceGrid/Query.ice
share/Ice/IcePatch2/FileInfo.ice
share/Ice/IcePatch2/FileServer.ice
share/Ice/IceSSL/CertificateVerifier.ice
@@ -284,10 +293,6 @@ share/Ice/IceStorm/IceStorm.ice
%%PORTDOCS%%%%DOCSDIR%%/ICE_LICENSE
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/c12905.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/c13.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/c15817.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/caution.gif
%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/home.gif
%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/important.gif
@@ -300,198 +305,232 @@ share/Ice/IceStorm/IceStorm.ice
%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/toc-plus.gif
%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/up.gif
%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/warning.gif
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1002.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10123.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1014.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10171.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1022.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1030.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10307.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10315.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10405.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10441.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10619.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10642.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10653.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10664.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1067.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10674.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10684.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10694.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10704.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10765.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10775.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10791.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10805.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10842.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10852.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10863.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x10954.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1096.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1108.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1120.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1128.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11304.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11321.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11332.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11342.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11352.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11372.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11422.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11433.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11445.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11519.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11546.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11579.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11610.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11662.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11772.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11810.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11872.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x11887.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12028.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12052.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12110.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12134.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12158.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12408.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12432.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12562.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12659.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12686.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12711.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12769.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12895.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x12947.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x13055.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x13126.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x13298.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x13328.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x13386.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x13481.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x13775.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x14066.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x14218.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x14840.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x15102.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x15462.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x15716.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x15921.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1925.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1942.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1970.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x1983.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2002.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2014.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2208.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2220.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2232.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2244.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2256.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2380.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2421.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2433.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2445.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2469.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2479.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2498.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2661.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2685.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2710.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2722.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2734.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2758.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2866.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x2972.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x3099.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x3152.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x3164.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x3176.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x3200.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x3244.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x3281.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4368.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4404.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4434.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4521.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4531.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4539.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4612.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4622.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4663.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4687.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4776.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x4840.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5208.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5265.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5289.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5301.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5369.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5449.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5642.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5650.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5672.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5756.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5792.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5813.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5841.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5877.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5894.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5906.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5918.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5930.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5945.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x5957.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6024.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6091.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6101.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6244.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6294.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6387.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6433.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x6443.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7284.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7292.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7374.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7382.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7390.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7400.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7442.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7514.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7575.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7622.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7630.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7669.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7693.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7775.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/c13.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/c16140.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/c19289.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1057.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10601.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1065.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1073.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10750.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10774.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10979.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10987.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11019.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11056.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1110.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11139.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11211.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11235.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11289.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11317.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11361.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1139.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11418.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11472.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1149.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11558.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1161.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11634.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1173.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11746.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11770.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1181.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11914.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11951.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12080.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12126.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12151.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12198.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12223.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12247.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12291.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12413.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12423.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12557.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12629.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12639.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12803.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12877.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12935.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12983.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13007.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13044.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13137.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13189.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13248.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13549.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13589.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13649.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13723.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13750.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13783.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13814.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13866.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13976.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14021.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14090.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14105.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14283.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14306.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14317.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14328.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14338.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14348.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14358.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14368.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14429.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14439.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14455.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14469.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14506.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14516.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14527.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14618.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14968.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14985.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14996.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15006.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15016.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15036.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15086.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15097.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15109.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15250.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15274.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15332.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15356.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15380.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15630.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15654.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15784.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15881.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15908.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15933.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16004.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16130.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16182.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16290.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16371.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16563.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16601.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16659.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x16766.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x17067.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x17347.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x17527.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x18209.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x18508.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x18906.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x19160.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x19393.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1982.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1999.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2027.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2046.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2058.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2252.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2264.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2276.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2288.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2300.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2424.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2465.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2477.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2489.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2523.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2547.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2557.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2581.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2609.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2628.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2809.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2833.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2858.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2870.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2882.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2906.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2914.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3022.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3191.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3318.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3371.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3383.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3395.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3419.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3463.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3500.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4654.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4690.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4720.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4807.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4817.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4825.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4898.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4908.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4949.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4973.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5062.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5126.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5496.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5547.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5571.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5583.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5651.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5731.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5924.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5932.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5954.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6038.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6077.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6098.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6126.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6162.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6179.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6191.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6203.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6215.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6230.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6242.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6309.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6376.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6386.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6529.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6579.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6672.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6718.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6728.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7569.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7577.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7659.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7667.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7675.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7685.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7727.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7799.html
%%PORTDOCS%%%%DOCSDIR%%/reference/x78.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x7827.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x8144.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x8229.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x8237.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9468.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9532.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9540.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9548.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9639.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9684.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9743.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9767.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9812.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9860.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9868.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9876.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9937.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9945.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9953.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/x9997.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7860.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7907.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7915.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7954.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7978.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x8060.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x8112.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x8924.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x8948.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9059.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9106.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9151.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9175.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9201.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference/stylesheet-images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/Ice/IceStorm
@dirrm share/Ice/IceSSL
@dirrm share/Ice/IcePatch2
-@dirrm share/Ice/IcePack
+@dirrm share/Ice/IceGrid
@dirrm share/Ice/IceBox
@dirrm share/Ice/Ice
@dirrm share/Ice/Glacier2
@@ -503,7 +542,7 @@ share/Ice/IceStorm/IceStorm.ice
@dirrm include/IceStorm
@dirrm include/IceSSL
@dirrm include/IcePatch2
-@dirrm include/IcePack
+@dirrm include/IceGrid
@dirrm include/IceBox
@dirrm include/Ice
@dirrm include/Glacier2