aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2011-08-05 18:24:04 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2011-08-05 18:24:04 +0000
commitffb8f0807f47e1d5f465cbca1a6046220cf7cd25 (patch)
treed4bf670f40bde4080ae4320fddc5f0602b33c010 /devel
parentdae08b7c51fe49332ee0c69b1c045fa23c735ea4 (diff)
downloadports-ffb8f0807f47e1d5f465cbca1a6046220cf7cd25.tar.gz
ports-ffb8f0807f47e1d5f465cbca1a6046220cf7cd25.zip
Date::Business provides the functionality to perform simple date manipulations
quickly. Support for calendar date and business date math is provided. Business dates are weekdays only. Adding 1 to a weekend returns Monday, subtracting 1 returns Friday. The difference in business days between Friday and the following Monday (using the diffb function) is one business day. The number of business days between Friday and the following Monday (using the betweenb function) is zero.
Notes
Notes: svn path=/head/; revision=278974
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Date-Business/Makefile20
-rw-r--r--devel/p5-Date-Business/distinfo2
-rw-r--r--devel/p5-Date-Business/pkg-descr10
-rw-r--r--devel/p5-Date-Business/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index db3442695b47..39e50c84d606 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1458,6 +1458,7 @@
SUBDIR += p5-Data-Validate
SUBDIR += p5-Data-Visitor
SUBDIR += p5-Data-Visitor-Encode
+ SUBDIR += p5-Date-Business
SUBDIR += p5-Date-Calc
SUBDIR += p5-Date-Calc-Iterator
SUBDIR += p5-Date-Calc-XS
diff --git a/devel/p5-Date-Business/Makefile b/devel/p5-Date-Business/Makefile
new file mode 100644
index 000000000000..f14cb9fe9112
--- /dev/null
+++ b/devel/p5-Date-Business/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: p5-Date-Business
+# Date created: Aug 05, 2011
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= Date-Business
+PORTVERSION= 1.2
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Fast calendar and business date calculations
+
+PERL_CONFIGURE= yes
+
+MAN3= Date::Business.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Date-Business/distinfo b/devel/p5-Date-Business/distinfo
new file mode 100644
index 000000000000..0a436cc0db8d
--- /dev/null
+++ b/devel/p5-Date-Business/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Date-Business-1.2.tar.gz) = 2e7b573517d5d05f3006b9398936351d5b6fcb041184a16b781218abb15ad224
+SIZE (Date-Business-1.2.tar.gz) = 8201
diff --git a/devel/p5-Date-Business/pkg-descr b/devel/p5-Date-Business/pkg-descr
new file mode 100644
index 000000000000..2c8f75146479
--- /dev/null
+++ b/devel/p5-Date-Business/pkg-descr
@@ -0,0 +1,10 @@
+Date::Business provides the functionality to perform simple date manipulations
+quickly. Support for calendar date and business date math is provided.
+
+Business dates are weekdays only. Adding 1 to a weekend returns Monday,
+subtracting 1 returns Friday.
+
+The difference in business days between Friday and the following
+Monday (using the diffb function) is one business day. The
+number of business days between Friday and the following
+Monday (using the betweenb function) is zero.
diff --git a/devel/p5-Date-Business/pkg-plist b/devel/p5-Date-Business/pkg-plist
new file mode 100644
index 000000000000..135cf1818f8a
--- /dev/null
+++ b/devel/p5-Date-Business/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Date/Business.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Date/Business/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Date/Business
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Date
+@dirrmtry %%SITE_PERL%%/Date