aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-26 18:44:26 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-26 18:44:26 +0000
commit343f60a7404aac0a2469d3bc44b8cbcedf969e40 (patch)
treeac11b98a152d471730b2a8b02e9bda2769cc570d /devel
parent3ddd61a4210ac9a49df353b3022d416b7697231c (diff)
downloadports-343f60a7404aac0a2469d3bc44b8cbcedf969e40.tar.gz
ports-343f60a7404aac0a2469d3bc44b8cbcedf969e40.zip
Add p5-Smart-Comments.
Smart comments provide an easy way to insert debugging and tracking code into a program. They can report the value of a variable, track the progress of a loop, and verify that particular assertions are true. Best of all, when you're finished debugging, you don't have to remove them. Simply commenting out the use Smart::Comments line turns them back into regular comments. Leaving smart comments in your code is smart because if you needed them once, you'll almost certainly need them again later. Author: Damian Conway <DCONWAY@cpan.org> WWW: http://search.cpan.org/dist/Smart-Comments/ PR: ports/81476 Submitted by: Aaron Dalton <aaron@daltons.ca>
Notes
Notes: svn path=/head/; revision=136194
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Smart-Comments/Makefile38
-rw-r--r--devel/p5-Smart-Comments/distinfo2
-rw-r--r--devel/p5-Smart-Comments/files/patch-lib_Smart_Comments.pm11
-rw-r--r--devel/p5-Smart-Comments/pkg-descr15
-rw-r--r--devel/p5-Smart-Comments/pkg-plist5
6 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d3f0a771080b..d0bab9a8bf62 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1054,6 +1054,7 @@
SUBDIR += p5-Shape
SUBDIR += p5-Shell-Base
SUBDIR += p5-Shell-Parser
+ SUBDIR += p5-Smart-Comments
SUBDIR += p5-Sort-ArrayOfArrays
SUBDIR += p5-Sort-Tree
SUBDIR += p5-Sort-Versions
diff --git a/devel/p5-Smart-Comments/Makefile b/devel/p5-Smart-Comments/Makefile
new file mode 100644
index 000000000000..8652f2fab8f2
--- /dev/null
+++ b/devel/p5-Smart-Comments/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-Smart-Comments
+# Date created: 24 May 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Smart-Comments
+PORTVERSION= 1.0.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DC/DCONWAY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Comments that do more than just sit there
+
+BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
+ ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Smart::Comments.3
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} -f {} \;
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Perl5.6 or greater required. Please install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Smart-Comments/distinfo b/devel/p5-Smart-Comments/distinfo
new file mode 100644
index 000000000000..70b129c856fa
--- /dev/null
+++ b/devel/p5-Smart-Comments/distinfo
@@ -0,0 +1,2 @@
+MD5 (Smart-Comments-1.0.1.tar.gz) = 387ce88a5aba1a7a9c49d0dbc343365c
+SIZE (Smart-Comments-1.0.1.tar.gz) = 12704
diff --git a/devel/p5-Smart-Comments/files/patch-lib_Smart_Comments.pm b/devel/p5-Smart-Comments/files/patch-lib_Smart_Comments.pm
new file mode 100644
index 000000000000..552c643157b5
--- /dev/null
+++ b/devel/p5-Smart-Comments/files/patch-lib_Smart_Comments.pm
@@ -0,0 +1,11 @@
+--- lib/Smart/Comments.pm Tue May 24 15:54:42 2005
++++ lib/Smart/Comments.pm.patched Tue May 24 20:32:10 2005
+@@ -1,6 +1,7 @@
+ package Smart::Comments;
+
+-use version; $VERSION = qv('1.0.1');
++#use version; $VERSION = qv('1.0.1');
++$VERSION = 1.001001;
+
+ use warnings;
+ use strict;
diff --git a/devel/p5-Smart-Comments/pkg-descr b/devel/p5-Smart-Comments/pkg-descr
new file mode 100644
index 000000000000..dcd4d47e5ef1
--- /dev/null
+++ b/devel/p5-Smart-Comments/pkg-descr
@@ -0,0 +1,15 @@
+Smart comments provide an easy way to insert debugging and tracking code into
+a program. They can report the value of a variable, track the progress of a
+loop, and verify that particular assertions are true.
+
+Best of all, when you're finished debugging, you don't have to remove them.
+Simply commenting out the use Smart::Comments line turns them back into
+regular comments. Leaving smart comments in your code is smart because if you
+needed them once, you'll almost certainly need them again later.
+
+Author: Damian Conway <DCONWAY@cpan.org>
+
+WWW: http://search.cpan.org/dist/Smart-Comments/
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Smart-Comments/pkg-plist b/devel/p5-Smart-Comments/pkg-plist
new file mode 100644
index 000000000000..91d6fb10534e
--- /dev/null
+++ b/devel/p5-Smart-Comments/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Smart/Comments.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Smart/Comments/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Smart/Comments
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Smart 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Smart 2>/dev/null || true