aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-02-10 06:05:06 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-02-10 06:05:06 +0000
commit60b3a84279e0657b047e05ed4f622cf401e2376b (patch)
tree87924704af779c872d6c2a33013016cf3fa9e056 /devel
parent774716a88ba9c4ee1166ca8ac4b5c3ec13b56a6a (diff)
downloadports-60b3a84279e0657b047e05ed4f622cf401e2376b.tar.gz
ports-60b3a84279e0657b047e05ed4f622cf401e2376b.zip
Use libtool15 port instead of included version to avoid objformat a.out botch
Notes
Notes: svn path=/head/; revision=184749
Diffstat (limited to 'devel')
-rw-r--r--devel/anjuta/Makefile1
-rw-r--r--devel/devhelp/Makefile1
-rw-r--r--devel/devhelp/pkg-plist1
-rw-r--r--devel/flatzebra/Makefile1
-rw-r--r--devel/flatzebra/pkg-plist1
-rw-r--r--devel/gconf/Makefile1
-rw-r--r--devel/gconfmm/Makefile1
-rw-r--r--devel/gtkmozedit/Makefile1
-rw-r--r--devel/gtkmozedit/pkg-plist1
-rw-r--r--devel/guichan/Makefile1
-rw-r--r--devel/libast/Makefile1
-rw-r--r--devel/log4cpp/Makefile1
-rw-r--r--devel/oaf/Makefile1
-rw-r--r--devel/oaf/pkg-plist1
-rw-r--r--devel/prepstools/Makefile1
15 files changed, 15 insertions, 0 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index e3c68300f071..a01939a2c168 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/gnu-autotools/bin/autoconf:${PORTSDIR}/devel/gnu-autoc
${LOCALBASE}/gnu-autotools/bin/automake:${PORTSDIR}/devel/gnu-automake \
libtool:${PORTSDIR}/devel/libtool15
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 08ee7cf9ac13..5c6353bc4a77 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -31,6 +31,7 @@ MOZILLA= seamonkey
.endif
.endif
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_XLIB= yes
USE_GETTEXT= yes
diff --git a/devel/devhelp/pkg-plist b/devel/devhelp/pkg-plist
index ae12a8397655..76ca3dafc80a 100644
--- a/devel/devhelp/pkg-plist
+++ b/devel/devhelp/pkg-plist
@@ -11,6 +11,7 @@ include/devhelp-1.0/devhelp/dh-search.h
include/devhelp-1.0/devhelp/dh-util.h
include/devhelp-1.0/devhelp/dh-window.h
lib/libdevhelp-1.a
+lib/libdevhelp-1.la
lib/libdevhelp-1.so
lib/libdevhelp-1.so.0
libdata/pkgconfig/libdevhelp-1.0.pc
diff --git a/devel/flatzebra/Makefile b/devel/flatzebra/Makefile
index 3f00605c0efe..2673e0808e4a 100644
--- a/devel/flatzebra/Makefile
+++ b/devel/flatzebra/Makefile
@@ -17,6 +17,7 @@ COMMENT= A generic game engine for 2D double-buffering animation
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include
+USE_AUTOTOOLS= libtool:15
USE_SDL= sdl mixer image
USE_GNOME= pkgconfig
diff --git a/devel/flatzebra/pkg-plist b/devel/flatzebra/pkg-plist
index 46eb023f12da..4963d5118b20 100644
--- a/devel/flatzebra/pkg-plist
+++ b/devel/flatzebra/pkg-plist
@@ -1,6 +1,7 @@
lib/libflatzebra-0.1.so.2
lib/libflatzebra-0.1.so
lib/libflatzebra-0.1.la
+lib/libflatzebra-0.1.a
libdata/pkgconfig/flatzebra-0.1.pc
diff --git a/devel/gconf/Makefile b/devel/gconf/Makefile
index a82ce60e0de7..40f0ddd2e6fa 100644
--- a/devel/gconf/Makefile
+++ b/devel/gconf/Makefile
@@ -20,6 +20,7 @@ COMMENT= A configuration database system for GNOME
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GMAKE= yes
USE_XLIB= yes
diff --git a/devel/gconfmm/Makefile b/devel/gconfmm/Makefile
index d83ab80a0a48..83e5e8cb5794 100644
--- a/devel/gconfmm/Makefile
+++ b/devel/gconfmm/Makefile
@@ -19,6 +19,7 @@ COMMENT= C++ wrapper for gconf2 API library
LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtkmm20
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack lthack gconf2
diff --git a/devel/gtkmozedit/Makefile b/devel/gtkmozedit/Makefile
index 091da42ff4d5..081584690600 100644
--- a/devel/gtkmozedit/Makefile
+++ b/devel/gtkmozedit/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Text editor widget based on Mozilla's editing functionality
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/gtkmozedit/pkg-plist b/devel/gtkmozedit/pkg-plist
index 1413bfe6b32c..0b8a2defa055 100644
--- a/devel/gtkmozedit/pkg-plist
+++ b/devel/gtkmozedit/pkg-plist
@@ -105,6 +105,7 @@ include/libgtkmozedit-1/gtkmozedit/gme-observer.h
include/libgtkmozedit-1/gtkmozedit/gme-supports.h
include/libgtkmozedit-1/gtkmozedit/gme-web-browser.h
include/libgtkmozedit-1/gtkmozedit/gtkmozedit.h
+lib/libgtkmozedit-1.a
lib/libgtkmozedit-1.la
lib/libgtkmozedit-1.so
lib/libgtkmozedit-1.so.0
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
index d912fc44a00c..48965f2f7059 100644
--- a/devel/guichan/Makefile
+++ b/devel/guichan/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mva@sysfault.org
COMMENT= A small, efficient C++ GUI library designed for games
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_GCC= 3.2+
GNU_CONFIGURE= yes
diff --git a/devel/libast/Makefile b/devel/libast/Makefile
index 04c109f95d1e..fdd0f61a2171 100644
--- a/devel/libast/Makefile
+++ b/devel/libast/Makefile
@@ -17,6 +17,7 @@ COMMENT= A library of assorted spiffy things
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
Imlib2.3:${PORTSDIR}/graphics/imlib2
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_GNOME= gnomehack
GNU_CONFIGURE= yes
diff --git a/devel/log4cpp/Makefile b/devel/log4cpp/Makefile
index 5461ac586083..30c5dc032fd0 100644
--- a/devel/log4cpp/Makefile
+++ b/devel/log4cpp/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A library of C++ classes for flexible logging
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index ded7de44e514..f18998f03015 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -19,6 +19,7 @@ COMMENT= Object Activation Framework for GNOME
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
diff --git a/devel/oaf/pkg-plist b/devel/oaf/pkg-plist
index 6ae0a769c48e..2861e3556ee3 100644
--- a/devel/oaf/pkg-plist
+++ b/devel/oaf/pkg-plist
@@ -22,6 +22,7 @@ include/liboaf/oaf-servreg.h
include/liboaf/oaf-util.h
include/liboaf/oaf.h
lib/liboaf.a
+lib/liboaf.la
lib/liboaf.so
lib/liboaf.so.0
share/aclocal/oaf.m4
diff --git a/devel/prepstools/Makefile b/devel/prepstools/Makefile
index 0b4b68b1e527..49d2b1e18731 100644
--- a/devel/prepstools/Makefile
+++ b/devel/prepstools/Makefile
@@ -16,6 +16,7 @@ COMMENT= Problem reporting system
RUN_DEPENDS= postgres:${PORTSDIR}/databases/postgresql${DEFAULT_PGSQL_VER}-server
+USE_AUTOTOOLS= libtool:15
USE_PGSQL= yes
USE_GMAKE= yes
USE_GNOME= gtk20 gconf2 glib20 libgnomeui