aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-04 17:38:57 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-04 17:38:57 +0000
commit7ba967779f360a3d5305fb7dbdd6ca95ff8c0e93 (patch)
treed152f30d4ba37aaebf41226980f1390f3c788ff4 /devel
parent3b247f9b414021c2e6b0f4b2aa645312a303e5b7 (diff)
downloadports-7ba967779f360a3d5305fb7dbdd6ca95ff8c0e93.tar.gz
ports-7ba967779f360a3d5305fb7dbdd6ca95ff8c0e93.zip
Add pear-VFS 0.0.4, PEAR Virtual File System API.
It is required by Horde-3 (to be released). Approved by: mat (mentor).
Notes
Notes: svn path=/head/; revision=106134
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-VFS/Makefile36
-rw-r--r--devel/pear-VFS/distinfo2
-rw-r--r--devel/pear-VFS/pkg-descr11
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 33c0660935e0..6313dab81281 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -955,6 +955,7 @@
SUBDIR += pear-OLE
SUBDIR += pear-PEAR
SUBDIR += pear-PHPUnit
+ SUBDIR += pear-VFS
SUBDIR += pear-XML_Parser
SUBDIR += pear-XML_RPC
SUBDIR += pear-XML_RSS
diff --git a/devel/pear-VFS/Makefile b/devel/pear-VFS/Makefile
new file mode 100644
index 000000000000..beb165c9fc43
--- /dev/null
+++ b/devel/pear-VFS/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-VFS
+# Date created: 04 April 2004
+# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= VFS
+PORTVERSION= 0.0.4
+CATEGORIES= devel pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR Virtual File System API
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= VFS.php
+VFS_FILES= Browser.php GC.php ListItem.php Object.php \
+ file.php ftp.php musql.php sql.php sql_file.php
+
+pre-everything::
+.for cat_file in ${VFS_FILES}
+FILES+= VFS/${cat_file}
+.endfor
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/VFS
+.for cat_file in ${VFS_FILES}
+ @${MV} ${WRKSRC}/${cat_file} ${WRKSRC}/VFS
+.endfor
+ @${MV} ${WRKDIR}/VFS.php ${WRKSRC}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-VFS/distinfo b/devel/pear-VFS/distinfo
new file mode 100644
index 000000000000..4f546ceeb06e
--- /dev/null
+++ b/devel/pear-VFS/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/VFS-0.0.4.tgz) = 90dca2a531e82b162cd8e2e2c248490c
+SIZE (PEAR/VFS-0.0.4.tgz) = 21675
diff --git a/devel/pear-VFS/pkg-descr b/devel/pear-VFS/pkg-descr
new file mode 100644
index 000000000000..6f5230fffb1c
--- /dev/null
+++ b/devel/pear-VFS/pkg-descr
@@ -0,0 +1,11 @@
+This PEAR package provides a Virtual File System API, with backends for:
+* SQL
+* FTP
+* Local filesystems
+* Hybrid SQL and filesystem
+
+... and more planned. Reading/writing/listing of files are all
+supported, and there are both object-based and array-based interfaces
+to directory listings.
+
+WWW: http://pear.php.net/package/VFS