aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJean Milanez Melo <jmelo@FreeBSD.org>2006-04-24 14:14:30 +0000
committerJean Milanez Melo <jmelo@FreeBSD.org>2006-04-24 14:14:30 +0000
commit7e800886e646b28fc684577e29c7efefd5a66641 (patch)
tree7e280f7f0238f4cf4bc5de11e5890235f9fe5047 /devel
parent157077c5ada04666069dad40fd478040b90eeb33 (diff)
downloadports-7e800886e646b28fc684577e29c7efefd5a66641.tar.gz
ports-7e800886e646b28fc684577e29c7efefd5a66641.zip
- Update to 0.26.
- Add pkg-message to notify users who are updating to new version. - portlint(1). PR: ports/95656 Submitted by: Lapo Luchini <lapo@lapo.it> (maintainer) Approved by: mnag (mentor)
Notes
Notes: svn path=/head/; revision=160326
Diffstat (limited to 'devel')
-rw-r--r--devel/monotone/Makefile24
-rw-r--r--devel/monotone/distinfo6
-rw-r--r--devel/monotone/files/patch-Makefile.in20
-rw-r--r--devel/monotone/files/pkg-message.in4
4 files changed, 31 insertions, 23 deletions
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index ef837f283caa..964fd84e954c 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -6,18 +6,18 @@
#
PORTNAME= monotone
-PORTVERSION= 0.25
+PORTVERSION= 0.26
CATEGORIES= devel
-MASTER_SITES= http://www.venge.net/monotone/downloads/ \
- http://norton.kettering.edu/freebsd/
+MASTER_SITES= http://www.venge.net/monotone/downloads/
MAINTAINER= lapo@lapo.it
COMMENT= A distributed version control system with digital signatures
LIB_DEPENDS= boost_regex.3:${PORTSDIR}/devel/boost
+SUB_FILES= pkg-message
USE_GCC= 3.4+
-USE_REINPLACE= yes
+USE_PERL5_BUILD=yes
USE_ICONV= yes
USE_GMAKE= yes
@@ -26,24 +26,27 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
-PLIST_FILES= bin/monotone
+PLIST_FILES= bin/mtn
INFO= monotone
-MAN1= monotone.1
-PORTDOCS= NEWS UPGRADE
+MAN1= mtn.1
+PORTDOCS= NEWS UPGRADE monotone.html
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "wcswidth() not present in libc on FreeBSD < 5.0"
+BROKEN= wcswidth() not present in libc on FreeBSD < 5.0
.endif
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
.else
USE_GETTEXT= yes
-PLIST_FILES+= share/locale/fr/LC_MESSAGES/monotone.mo \
+PLIST_FILES+= share/locale/de/LC_MESSAGES/monotone.mo \
+ share/locale/fr/LC_MESSAGES/monotone.mo \
+ share/locale/it/LC_MESSAGES/monotone.mo \
share/locale/ja/LC_MESSAGES/monotone.mo \
- share/locale/pt_BR/LC_MESSAGES/monotone.mo
+ share/locale/pt_BR/LC_MESSAGES/monotone.mo \
+ share/locale/sv/LC_MESSAGES/monotone.mo
.endif
post-extract:
@@ -58,5 +61,6 @@ post-install:
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/devel/monotone/distinfo b/devel/monotone/distinfo
index 9ddd03f837b0..f367a2dcb03b 100644
--- a/devel/monotone/distinfo
+++ b/devel/monotone/distinfo
@@ -1,3 +1,3 @@
-MD5 (monotone-0.25.tar.gz) = fb0ad449cd0093854c55dbd5c6fc07e2
-SHA256 (monotone-0.25.tar.gz) = 6d579179d6b7a2d97291c8d60f3cfd001c93281495716209db34dc854d2f48e3
-SIZE (monotone-0.25.tar.gz) = 5415426
+MD5 (monotone-0.26.tar.gz) = 21b902d1b48ffb868536d04c4ad38155
+SHA256 (monotone-0.26.tar.gz) = 4ced85ad82f7f74bc75f08d93009fa2f25b7516f11e78ece1f775a3db433054a
+SIZE (monotone-0.26.tar.gz) = 5630955
diff --git a/devel/monotone/files/patch-Makefile.in b/devel/monotone/files/patch-Makefile.in
index 3c1b76ec62c4..4a99f0008fb6 100644
--- a/devel/monotone/files/patch-Makefile.in
+++ b/devel/monotone/files/patch-Makefile.in
@@ -1,15 +1,15 @@
---- Makefile.in.orig Fri Dec 31 03:17:42 2004
-+++ Makefile.in Wed Jan 26 22:20:17 2005
-@@ -1153,10 +1153,10 @@
+--- Makefile.in.orig Sun Apr 9 04:46:33 2006
++++ Makefile.in Tue Apr 11 15:12:05 2006
+@@ -1824,10 +1824,10 @@
-test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
- monotone$(EXEEXT): $(monotone_OBJECTS) $(monotone_DEPENDENCIES)
- @rm -f monotone$(EXEEXT)
-- $(CXXLINK) $(monotone_LDFLAGS) $(monotone_OBJECTS) $(monotone_LDADD) $(LIBS)
-+ $(CXXLINK) $(monotone_LDFLAGS) $(monotone_OBJECTS) $(monotone_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
+ mtn$(EXEEXT): $(mtn_OBJECTS) $(mtn_DEPENDENCIES)
+ @rm -f mtn$(EXEEXT)
+- $(CXXLINK) $(mtn_LDFLAGS) $(mtn_OBJECTS) $(mtn_LDADD) $(LIBS)
++ $(CXXLINK) $(mtn_LDFLAGS) $(mtn_OBJECTS) $(mtn_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
unit_tests$(EXEEXT): $(unit_tests_OBJECTS) $(unit_tests_DEPENDENCIES)
@rm -f unit_tests$(EXEEXT)
- $(CXXLINK) $(unit_tests_LDFLAGS) $(unit_tests_OBJECTS) $(unit_tests_LDADD) $(LIBS)
+ $(CXXLINK) $(unit_tests_LDFLAGS) $(unit_tests_OBJECTS) $(unit_tests_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
-
- mostlyclean-compile:
- -rm -f *.$(OBJEXT)
+ contrib/$(am__dirstamp):
+ @$(mkdir_p) contrib
+ @: > contrib/$(am__dirstamp)
diff --git a/devel/monotone/files/pkg-message.in b/devel/monotone/files/pkg-message.in
new file mode 100644
index 000000000000..9de90e2a8e0c
--- /dev/null
+++ b/devel/monotone/files/pkg-message.in
@@ -0,0 +1,4 @@
+*****************************************************************************
+You have installed the monotone package. For users who are upgrating monotone,
+please read %%DOCSDIR%%/UPGRADE for upgrade instructions.
+*****************************************************************************