aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-05 21:13:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-05 21:13:31 +0000
commit94d0728d0346b4778dbc920bdb370ffef0cfe093 (patch)
tree63dc1d35e817539c26ffc65071bfc4e33243ba24 /devel
parent8caf43c2d8e94a18cd72b733603426e95c4f26c7 (diff)
downloadports-94d0728d0346b4778dbc920bdb370ffef0cfe093.tar.gz
ports-94d0728d0346b4778dbc920bdb370ffef0cfe093.zip
OpenTop contains framework classes that provide the features
you need to write network-centric, web-enabled and internationalized applications in C++. It enables you to: * create network clients and servers using either raw socket facilities or higher-level protocols such as HTTP and FTP. * create multi-threaded applications and manage synchronization between threads using simple but effective threading abstractions which are common to all platforms. * use the full Unicode character range, using built-in character types and standard string classes. * use byte and character streams and manipulate files using an API inspired by the excellent java.io package. * take advantage of its open architecture by registering your own (or third-party) classes to perform custom processing. * write portable applications and extension libraries. OpenTop is an ideal base on which to deliver cross-platform solutions, benefitting independent software vendors and corporate IT departments. * integrate XML into your C++ applications with the C++ XML Toolkit extension library. PR: 59887 Submitted by: Sergey Matveychuk <sem@ciam.ru>
Notes
Notes: svn path=/head/; revision=95160
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/opentop/Makefile64
-rw-r--r--devel/opentop/distinfo2
-rw-r--r--devel/opentop/pkg-descr22
-rw-r--r--devel/opentop/pkg-plist564
5 files changed, 653 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b79e5782a5ff..399cbd672118 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -486,6 +486,7 @@
SUBDIR += omniORB
SUBDIR += oniguruma
SUBDIR += openthreads
+ SUBDIR += opentop
SUBDIR += openzz
SUBDIR += orbitcpp
SUBDIR += ossp-al
diff --git a/devel/opentop/Makefile b/devel/opentop/Makefile
new file mode 100644
index 000000000000..4cc55581c782
--- /dev/null
+++ b/devel/opentop/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: opentop
+# Date created: 17 November 2003
+# Whom: Sergey Matveychuk <sem@ciam.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opentop
+PORTVERSION= 1.3.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= open-top
+DISTNAME= ${PORTNAME}-${PORTVERSION:C|\.|-|g}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DOCDIST}${EXTRACT_SUFX}
+
+MAINTAINER= sem@ciam.ru
+COMMENT= A cross-platform C++ framework library
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+DOCDIST= ${PORTNAME}-api-${PORTVERSION:C|\.[0-9]$||:C|\.|-|g}
+
+WCHAR= "@comment "
+STATIC= "@comment "
+DEBUG= "@comment "
+
+ALL_TARGET= release_multi_char_shared
+
+.if defined(WITH_WCHAR)
+ALL_TARGET+= release_multi_wchar_shared
+WCHAR= ""
+.endif
+.if defined(WITH_DEBUG)
+ALL_TARGET+= debug_multi_char_shared
+.if defined(WITH_WCHAR)
+ALL_TARGET+= debug_multi_wchar_shared
+.endif
+DEBUG= ""
+.endif
+
+PLIST_SUB+= WCHAR=${WCHAR} DEBUG=${DEBUG}
+
+post-patch:
+ @${REINPLACE_CMD} "s/-O3/${CFLAGS}/" \
+ ${WRKSRC}/buildtools/cxx_compiler_options \
+ ${WRKSRC}/buildtools/gcc_compiler_options
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/${PORTNAME}
+ cd ${WRKSRC}; ${FIND} ot -name *.h -print | ${TAR} cTf - - | \
+ ${TAR} xUCf ${PREFIX}/include/${PORTNAME} -
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/*.so ${PREFIX}/lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKDIR}/${DOCDIST}/html; ${TAR} cf - . | ${TAR} xUCf ${DOCSDIR} -
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/opentop/distinfo b/devel/opentop/distinfo
new file mode 100644
index 000000000000..66830add6eb2
--- /dev/null
+++ b/devel/opentop/distinfo
@@ -0,0 +1,2 @@
+MD5 (opentop-1-3-0.tar.gz) = b1aa1e140f5eb912e832ac453e6acc21
+MD5 (opentop-api-1-3.tar.gz) = 059b4300f193ac6d4e21f74cc9d894d2
diff --git a/devel/opentop/pkg-descr b/devel/opentop/pkg-descr
new file mode 100644
index 000000000000..4ada185bf566
--- /dev/null
+++ b/devel/opentop/pkg-descr
@@ -0,0 +1,22 @@
+OpenTop contains framework classes that provide the features you need
+to write network-centric, web-enabled and internationalized applications
+in C++. It enables you to:
+
+* create network clients and servers using either raw socket facilities
+ or higher-level protocols such as HTTP and FTP.
+* create multi-threaded applications and manage synchronization between
+ threads using simple but effective threading abstractions which are
+ common to all platforms.
+* use the full Unicode character range, using built-in character types
+ and standard string classes.
+* use byte and character streams and manipulate files using an API
+ inspired by the excellent java.io package.
+* take advantage of its open architecture by registering your own
+ (or third-party) classes to perform custom processing.
+* write portable applications and extension libraries. OpenTop is
+ an ideal base on which to deliver cross-platform solutions, benefitting
+ independent software vendors and corporate IT departments.
+* integrate XML into your C++ applications with the C++ XML Toolkit
+ extension library.
+
+WWW: http://www.elcel.com/products/opentop/
diff --git a/devel/opentop/pkg-plist b/devel/opentop/pkg-plist
new file mode 100644
index 000000000000..915c698bb64c
--- /dev/null
+++ b/devel/opentop/pkg-plist
@@ -0,0 +1,564 @@
+include/opentop/ot/auxil/BasicOption.h
+include/opentop/ot/auxil/BooleanOption.h
+include/opentop/ot/auxil/CommandLineException.h
+include/opentop/ot/auxil/CommandLineOption.h
+include/opentop/ot/auxil/CommandLineParser.h
+include/opentop/ot/auxil/FileMessageFactory.h
+include/opentop/ot/auxil/MemCheckSystemMonitor.h
+include/opentop/ot/auxil/MessageFactoryImpl.h
+include/opentop/ot/auxil/MessageSet.h
+include/opentop/ot/auxil/NetAccessHelper.h
+include/opentop/ot/auxil/TraceHelper.h
+include/opentop/ot/auxil/defs.h
+include/opentop/ot/auxil/messages.h
+include/opentop/ot/base/ArrayAutoPtr.h
+include/opentop/ot/base/AtomicCounter.h
+include/opentop/ot/base/AutoBuffer.h
+include/opentop/ot/base/AutoLock.h
+include/opentop/ot/base/AutoUnlock.h
+include/opentop/ot/base/Character.h
+include/opentop/ot/base/CodeConverterBase.h
+include/opentop/ot/base/ConditionVariable.h
+include/opentop/ot/base/Exception.h
+include/opentop/ot/base/FastMutex.h
+include/opentop/ot/base/IllegalArgumentException.h
+include/opentop/ot/base/IllegalCharacterException.h
+include/opentop/ot/base/IllegalMonitorStateException.h
+include/opentop/ot/base/IllegalStateException.h
+include/opentop/ot/base/IllegalThreadStateException.h
+include/opentop/ot/base/InterruptedException.h
+include/opentop/ot/base/ManagedObject.h
+include/opentop/ot/base/MessageFactory.h
+include/opentop/ot/base/Monitor.h
+include/opentop/ot/base/Mutex.h
+include/opentop/ot/base/NullPointerException.h
+include/opentop/ot/base/NumUtils.h
+include/opentop/ot/base/OSException.h
+include/opentop/ot/base/ObjectManager.h
+include/opentop/ot/base/RecursiveMutex.h
+include/opentop/ot/base/RefPtr.h
+include/opentop/ot/base/RefPtrMember.h
+include/opentop/ot/base/Runnable.h
+include/opentop/ot/base/RuntimeException.h
+include/opentop/ot/base/String.h
+include/opentop/ot/base/StringIterator.h
+include/opentop/ot/base/StringUtils.h
+include/opentop/ot/base/SynchronizedObject.h
+include/opentop/ot/base/System.h
+include/opentop/ot/base/SystemCodeConverter.h
+include/opentop/ot/base/SystemMonitor.h
+include/opentop/ot/base/SystemUtils.h
+include/opentop/ot/base/Thread.h
+include/opentop/ot/base/ThreadId.h
+include/opentop/ot/base/ThreadLocal.h
+include/opentop/ot/base/Tracer.h
+include/opentop/ot/base/UnicodeCharacterType.h
+include/opentop/ot/base/UnsupportedOperationException.h
+include/opentop/ot/base/Win32Exception.h
+include/opentop/ot/base/compdefs.h
+include/opentop/ot/base/config.h
+include/opentop/ot/base/debug.h
+include/opentop/ot/base/defs.h
+include/opentop/ot/base/gendefs.h
+include/opentop/ot/base/libname.h
+include/opentop/ot/base/stringfunc.h
+include/opentop/ot/base/threaddefs.h
+include/opentop/ot/base/version.h
+include/opentop/ot/base/winconfig.h
+include/opentop/ot/base/winincl.h
+include/opentop/ot/cvt/ASCII8BitConverter.h
+include/opentop/ot/cvt/ASCIIConverter.h
+include/opentop/ot/cvt/CodeConverter.h
+include/opentop/ot/cvt/CodeConverterFactory.h
+include/opentop/ot/cvt/ISO88591Converter.h
+include/opentop/ot/cvt/Simple8BitConverter.h
+include/opentop/ot/cvt/UTF16Converter.h
+include/opentop/ot/cvt/UTF8Converter.h
+include/opentop/ot/cvt/UTF8codecvt.h
+include/opentop/ot/cvt/defs.h
+include/opentop/ot/io/AtomicReadException.h
+include/opentop/ot/io/BufferedInputStream.h
+include/opentop/ot/io/BufferedOutputStream.h
+include/opentop/ot/io/BufferedReader.h
+include/opentop/ot/io/BufferedWriter.h
+include/opentop/ot/io/ByteArrayInputStream.h
+include/opentop/ot/io/ByteArrayOutputStream.h
+include/opentop/ot/io/CharacterCodingException.h
+include/opentop/ot/io/Console.h
+include/opentop/ot/io/ExistingFileException.h
+include/opentop/ot/io/File.h
+include/opentop/ot/io/FileDescriptor.h
+include/opentop/ot/io/FileInputStream.h
+include/opentop/ot/io/FileNotFoundException.h
+include/opentop/ot/io/FileOutputStream.h
+include/opentop/ot/io/FileSystem.h
+include/opentop/ot/io/FilterInputStream.h
+include/opentop/ot/io/FilterOutputStream.h
+include/opentop/ot/io/FilterReader.h
+include/opentop/ot/io/FilterWriter.h
+include/opentop/ot/io/IOException.h
+include/opentop/ot/io/InputStream.h
+include/opentop/ot/io/InputStreamReader.h
+include/opentop/ot/io/InterruptedIOException.h
+include/opentop/ot/io/MalformedInputException.h
+include/opentop/ot/io/OutputStream.h
+include/opentop/ot/io/OutputStreamWriter.h
+include/opentop/ot/io/PosixFileDescriptor.h
+include/opentop/ot/io/PosixFileSystem.h
+include/opentop/ot/io/PrintWriter.h
+include/opentop/ot/io/Reader.h
+include/opentop/ot/io/ResourceDescriptor.h
+include/opentop/ot/io/StringReader.h
+include/opentop/ot/io/StringWriter.h
+include/opentop/ot/io/UnmappableCharacterException.h
+include/opentop/ot/io/UnsupportedEncodingException.h
+include/opentop/ot/io/Win32FileDescriptor.h
+include/opentop/ot/io/Win32FileSystem.h
+include/opentop/ot/io/Writer.h
+include/opentop/ot/io/defs.h
+include/opentop/ot/io/messages.h
+include/opentop/ot/net/Authenticator.h
+include/opentop/ot/net/BasicHttpURLConnection.h
+include/opentop/ot/net/BasicURLConnection.h
+include/opentop/ot/net/BindException.h
+include/opentop/ot/net/ConnectException.h
+include/opentop/ot/net/DatagramPacket.h
+include/opentop/ot/net/DatagramSocket.h
+include/opentop/ot/net/DatagramSocketImpl.h
+include/opentop/ot/net/DatagramSocketImplFactory.h
+include/opentop/ot/net/FileURLConnection.h
+include/opentop/ot/net/FileURLStreamHandler.h
+include/opentop/ot/net/FtpClient.h
+include/opentop/ot/net/FtpURLConnection.h
+include/opentop/ot/net/FtpURLStreamHandler.h
+include/opentop/ot/net/HttpChunkedInputStream.h
+include/opentop/ot/net/HttpClient.h
+include/opentop/ot/net/HttpURLConnection.h
+include/opentop/ot/net/HttpURLStreamHandler.h
+include/opentop/ot/net/InetAddress.h
+include/opentop/ot/net/MalformedURLException.h
+include/opentop/ot/net/MimeHeaderParser.h
+include/opentop/ot/net/MimeHeaderSequence.h
+include/opentop/ot/net/MulticastSocket.h
+include/opentop/ot/net/NetUtils.h
+include/opentop/ot/net/NoRouteToHostException.h
+include/opentop/ot/net/NvtAsciiInputStream.h
+include/opentop/ot/net/NvtAsciiOutputStream.h
+include/opentop/ot/net/PlainDatagramSocketImpl.h
+include/opentop/ot/net/PlainSocketImpl.h
+include/opentop/ot/net/ProtocolException.h
+include/opentop/ot/net/ServerSocket.h
+include/opentop/ot/net/Socket.h
+include/opentop/ot/net/SocketDescriptor.h
+include/opentop/ot/net/SocketException.h
+include/opentop/ot/net/SocketImpl.h
+include/opentop/ot/net/SocketImplFactory.h
+include/opentop/ot/net/SocketInputStream.h
+include/opentop/ot/net/SocketOutputStream.h
+include/opentop/ot/net/SocketTimeoutException.h
+include/opentop/ot/net/TcpNetworkClient.h
+include/opentop/ot/net/URL.h
+include/opentop/ot/net/URLConnection.h
+include/opentop/ot/net/URLDecoder.h
+include/opentop/ot/net/URLEncoder.h
+include/opentop/ot/net/URLStreamHandler.h
+include/opentop/ot/net/URLStreamHandlerFactory.h
+include/opentop/ot/net/UnknownHostException.h
+include/opentop/ot/net/defs.h
+include/opentop/ot/net/messages.h
+include/opentop/ot/sax/AttributeSetAdapter.h
+include/opentop/ot/sax/Attributes.h
+include/opentop/ot/sax/AttributesImpl.h
+include/opentop/ot/sax/ContentHandler.h
+include/opentop/ot/sax/DTDHandler.h
+include/opentop/ot/sax/DeclHandler.h
+include/opentop/ot/sax/DefaultHandler.h
+include/opentop/ot/sax/EntityResolver.h
+include/opentop/ot/sax/ErrorHandler.h
+include/opentop/ot/sax/InputSource.h
+include/opentop/ot/sax/LexicalHandler.h
+include/opentop/ot/sax/Locator.h
+include/opentop/ot/sax/LocatorAdaptor.h
+include/opentop/ot/sax/LocatorImpl.h
+include/opentop/ot/sax/NamespaceSupport.h
+include/opentop/ot/sax/SAXException.h
+include/opentop/ot/sax/SAXFeatures.h
+include/opentop/ot/sax/SAXNotRecognizedException.h
+include/opentop/ot/sax/SAXNotSupportedException.h
+include/opentop/ot/sax/SAXParseException.h
+include/opentop/ot/sax/SAXParser.h
+include/opentop/ot/sax/XMLReader.h
+include/opentop/ot/sax/XMLReaderFactory.h
+include/opentop/ot/sax/defs.h
+include/opentop/ot/util/AttributeListParser.h
+include/opentop/ot/util/Base64.h
+include/opentop/ot/util/DateTime.h
+include/opentop/ot/util/InvalidDateException.h
+include/opentop/ot/util/MIMEType.h
+include/opentop/ot/util/MessageFormatter.h
+include/opentop/ot/util/RefCountedPtr.h
+include/opentop/ot/util/StringTokenizer.h
+include/opentop/ot/util/ValueRestorer.h
+include/opentop/ot/util/Win32Utils.h
+include/opentop/ot/util/defs.h
+include/opentop/ot/util/stlutils.h
+include/opentop/ot/xml/Attribute.h
+include/opentop/ot/xml/AttributeSet.h
+include/opentop/ot/xml/AttributeSetImpl.h
+include/opentop/ot/xml/AttributeType.h
+include/opentop/ot/xml/Buffer.h
+include/opentop/ot/xml/BufferRange.h
+include/opentop/ot/xml/CharTypeFacet.h
+include/opentop/ot/xml/ContentEventHandler.h
+include/opentop/ot/xml/ContextString.h
+include/opentop/ot/xml/DTDEventHandler.h
+include/opentop/ot/xml/DTDObject.h
+include/opentop/ot/xml/ElementContentSpec.h
+include/opentop/ot/xml/ElementType.h
+include/opentop/ot/xml/Entity.h
+include/opentop/ot/xml/EntityEventHandler.h
+include/opentop/ot/xml/EntityResolutionHandler.h
+include/opentop/ot/xml/EntityType.h
+include/opentop/ot/xml/ErrorEventHandler.h
+include/opentop/ot/xml/EventHandler.h
+include/opentop/ot/xml/ExternalEntity.h
+include/opentop/ot/xml/InternalEntity.h
+include/opentop/ot/xml/Parser.h
+include/opentop/ot/xml/ParserFactory.h
+include/opentop/ot/xml/ParserFeatureState.h
+include/opentop/ot/xml/ParserImpl.h
+include/opentop/ot/xml/Position.h
+include/opentop/ot/xml/QName.h
+include/opentop/ot/xml/Scanner.h
+include/opentop/ot/xml/ScannerPosition.h
+include/opentop/ot/xml/StreamPosition.h
+include/opentop/ot/xml/UnsupportedFeatureException.h
+include/opentop/ot/xml/XMLFeatures.h
+include/opentop/ot/xml/XMLFilterReader.h
+include/opentop/ot/xml/XMLInputSource.h
+include/opentop/ot/xml/XMLMessages.h
+include/opentop/ot/xml/XMLNames.h
+include/opentop/ot/xml/XMLParsingException.h
+include/opentop/ot/xml/defs.h
+include/opentop/ot/xml/version.h
+include/opentop/ot/xmlcat/CatalogDelegatorEntry.h
+include/opentop/ot/xmlcat/CatalogEntry.h
+include/opentop/ot/xmlcat/CatalogEventHandler.h
+include/opentop/ot/xmlcat/CatalogFile.h
+include/opentop/ot/xmlcat/CatalogLeafEntry.h
+include/opentop/ot/xmlcat/CatalogParserHandler.h
+include/opentop/ot/xmlcat/CatalogResolver.h
+include/opentop/ot/xmlcat/CatalogSerialisationContext.h
+include/opentop/ot/xmlcat/CatalogSet.h
+include/opentop/ot/xmlcat/defs.h
+lib/libopentop-gccmt.so
+lib/libotxml-gccmt.so
+%%WCHAR%%lib/libopentop-gccwmt.so
+%%WCHAR%%lib/libotxml-gccwmt.so
+%%DEBUG%%lib/libopentop-gccmtd.so
+%%DEBUG%%lib/libotxml-gccmtd.so
+%%DEBUG%%%%WCHAR%%lib/libopentop-gccwmtd.so
+%%DEBUG%%%%WCHAR%%lib/libotxml-gccwmtd.so
+%%PORTDOCS%%%%DOCSDIR%%/allclasses-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/ArrayAutoPtr.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/AtomicCounter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/AutoBuffer.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/AutoLock.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/AutoUnlock.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/Character.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/CodeConverterBase.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/CodeConverterBase.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/ConditionVariable.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/Exception.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/Exception.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/FastMutex.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalArgumentException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalArgumentException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalCharacterException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalCharacterException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalMonitorStateException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalMonitorStateException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalStateException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalStateException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalThreadStateException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/IllegalThreadStateException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/InterruptedException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/InterruptedException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/ManagedObject.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/MessageFactory.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/MessageFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/Monitor.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/Monitor.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/Mutex.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/NullPointerException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/NullPointerException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/NumUtils.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/OSException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/OSException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/ObjectManager.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/RecursiveMutex.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/RefPtr.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/RefPtrMember.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/Runnable.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/Runnable.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/RuntimeException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/RuntimeException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/StringIterator.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/StringUtils.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/SynchronizedObject.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/SynchronizedObject.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/System.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/SystemCodeConverter.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/SystemCodeConverter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/SystemMonitor.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/SystemMonitor.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/Thread.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/Thread.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/ThreadId.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/ThreadLocal.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/Tracer.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/Tracer.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/UnicodeCharacterType.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/UnsupportedOperationException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/UnsupportedOperationException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/BasicOption.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/BasicOption.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/BooleanOption.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/BooleanOption.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/CommandLineException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/CommandLineException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/CommandLineOption.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/CommandLineOption.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/CommandLineParser.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/FileMessageFactory.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/FileMessageFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/MemCheckSystemMonitor.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/MemCheckSystemMonitor.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/MessageFactoryImpl.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/MessageFactoryImpl.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/MessageSet.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/MessageSet.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/NetAccessHelper.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/NetAccessHelper.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/TraceHelper.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/TraceHelper.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/auxil/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/cvt/CodeConverter.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/cvt/CodeConverter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/cvt/CodeConverterFactory.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/cvt/CodeConverterFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/cvt/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/cvt/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/AtomicReadException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/AtomicReadException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedInputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedInputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedOutputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedOutputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedReader.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedReader.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedWriter.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/BufferedWriter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ByteArrayInputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ByteArrayInputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ByteArrayOutputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ByteArrayOutputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/CharacterCodingException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/CharacterCodingException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/Console.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ExistingFileException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ExistingFileException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/File.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileDescriptor.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileDescriptor.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileInputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileInputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileNotFoundException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileNotFoundException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileOutputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileOutputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileSystem.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FileSystem.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterInputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterInputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterOutputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterOutputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterReader.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterReader.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterWriter.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/FilterWriter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/IOException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/IOException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/InputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/InputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/InputStreamReader.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/InputStreamReader.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/InterruptedIOException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/InterruptedIOException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/MalformedInputException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/MalformedInputException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/OutputStream.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/OutputStream.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/OutputStreamWriter.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/OutputStreamWriter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/PrintWriter.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/PrintWriter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/Reader.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/Reader.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ResourceDescriptor.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/ResourceDescriptor.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/StringReader.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/StringReader.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/StringWriter.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/StringWriter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/UnmappableCharacterException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/UnmappableCharacterException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/UnsupportedEncodingException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/UnsupportedEncodingException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/Writer.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/Writer.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/io/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/Authenticator.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/Authenticator.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/BindException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/BindException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/ConnectException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/ConnectException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramPacket.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramPacket.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramSocket.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramSocket.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramSocketImpl.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramSocketImpl.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramSocketImplFactory.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/DatagramSocketImplFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/FtpClient.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/FtpClient.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/HttpURLConnection.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/HttpURLConnection.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/InetAddress.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/InetAddress.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/MalformedURLException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/MalformedURLException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/MulticastSocket.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/MulticastSocket.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/NoRouteToHostException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/NoRouteToHostException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/ProtocolException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/ProtocolException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/ServerSocket.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/ServerSocket.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/Socket.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/Socket.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketDescriptor.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketDescriptor.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketImpl.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketImpl.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketImplFactory.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketImplFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketTimeoutException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/SocketTimeoutException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/TcpNetworkClient.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/TcpNetworkClient.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URL.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLConnection.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLConnection.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLDecoder.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLEncoder.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLStreamHandler.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLStreamHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLStreamHandlerFactory.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/URLStreamHandlerFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/UnknownHostException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/UnknownHostException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/net/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/Attributes.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/Attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/AttributesImpl.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/AttributesImpl.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/ContentHandler.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/ContentHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/DTDHandler.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/DTDHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/DeclHandler.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/DeclHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/DefaultHandler.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/DefaultHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/EntityResolver.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/EntityResolver.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/ErrorHandler.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/ErrorHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/InputSource.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/InputSource.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/LexicalHandler.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/LexicalHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/Locator.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/Locator.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/LocatorImpl.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/LocatorImpl.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/NamespaceSupport.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/NamespaceSupport.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXFeatures.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXNotRecognizedException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXNotRecognizedException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXNotSupportedException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXNotSupportedException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXParseException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/SAXParseException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/XMLReader.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/XMLReader.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/XMLReaderFactory.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/XMLReaderFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/sax/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/Base64.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/DateTime.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/InvalidDateException.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/InvalidDateException.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/MIMEType.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/MessageFormatter.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/StringTokenizer.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/util/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/xml/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/xml/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/xmlcat/CatalogEventHandler.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/xmlcat/CatalogResolver.gif
+%%PORTDOCS%%%%DOCSDIR%%/ot/xmlcat/CatalogResolver.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/xmlcat/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ot/xmlcat/namespace-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/overview-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet.css
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/xmlcat
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/xml
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/util
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/sax
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/net
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/io
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/cvt
+%%PORTDOCS%%@dirrm share/doc/opentop/ot/auxil
+%%PORTDOCS%%@dirrm share/doc/opentop/ot
+%%PORTDOCS%%@dirrm share/doc/opentop
+@dirrm include/opentop/ot/xmlcat
+@dirrm include/opentop/ot/xml
+@dirrm include/opentop/ot/util
+@dirrm include/opentop/ot/sax
+@dirrm include/opentop/ot/net
+@dirrm include/opentop/ot/io
+@dirrm include/opentop/ot/cvt
+@dirrm include/opentop/ot/base
+@dirrm include/opentop/ot/auxil
+@dirrm include/opentop/ot
+@dirrm include/opentop