aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsdist/Makefile
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-03-22 02:14:01 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-03-22 02:14:01 +0000
commitf94e4f56ca1969f46fd043f1f7140173f05c44af (patch)
treec484a3ba0d0aab41dfca158fdb7ac7d9cccaa983 /dns/dnsdist/Makefile
parent6efd1f55fb10bcf6e28e1974dd667f3c063c6e7b (diff)
downloadports-f94e4f56ca1969f46fd043f1f7140173f05c44af.tar.gz
ports-f94e4f56ca1969f46fd043f1f7140173f05c44af.zip
- Update to 1.0.0-alpha2
- Replace USES=readline with USES=libedit - Remove ragel dependency because it's only required to compile from git. - Fix MASTER_SITES - Add incbin License (The Unlicense) - Enable dnscrypt support - Fix comparison signedness in dnsname.cc Changelog: http://dnsdist.org/changelog/#dnsdist-100-alpha2 PR: 208126 Approved by: junovitch (mentor)
Notes
Notes: svn path=/head/; revision=411633
Diffstat (limited to 'dns/dnsdist/Makefile')
-rw-r--r--dns/dnsdist/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/dns/dnsdist/Makefile b/dns/dnsdist/Makefile
index 2f83bda2d6fa..538d9f669405 100644
--- a/dns/dnsdist/Makefile
+++ b/dns/dnsdist/Makefile
@@ -2,18 +2,21 @@
# $FreeBSD$
PORTNAME= dnsdist
-DISTVERSION= 0.0.791gfbb356b
+DISTVERSION= 1.0.0-alpha2
CATEGORIES= dns net
-MASTER_SITES= http://builder.powerdns.com/files/dnsdist/dist/ \
+MASTER_SITES= https://downloads.powerdns.com/releases/ \
LOCAL/cpm
MAINTAINER= cpm@FreeBSD.org
COMMENT= Highly DNS-, DoS- and abuse-aware loadbalancer
-LICENSE= GPLv2
+LICENSE= GPLv2 UNLICENSE
+LICENSE_COMB= multi
+LICENSE_NAME_UNLICENSE= The Unlicense
+LICENSE_FILE_UNLICENSE= ${WRKSRC}/ext/incbin/UNLICENSE
+LICENSE_PERMS_UNLICENSE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= ${LOCALBASE}/lib/libatomic_ops.a:${PORTSDIR}/devel/libatomic_ops \
- ragel>0:${PORTSDIR}/devel/ragel
+BUILD_DEPENDS= ${LOCALBASE}/lib/libatomic_ops.a:${PORTSDIR}/devel/libatomic_ops
LIB_DEPENDS= libboost_serialization.so:${PORTSDIR}/devel/boost-libs \
libsodium.so:${PORTSDIR}/security/libsodium
@@ -21,8 +24,8 @@ CXXFLAGS+= -D_GLIBCXX_USE_C99
LDFLAGS+= -L${LOCALBASE}/lib -latomic
GNU_CONFIGURE= yes
USE_GCC= yes
-USES= bison cpe gmake libtool lua:52 pkgconfig readline tar:bz2
-CONFIGURE_ARGS= --enable-libsodium
+USES= bison cpe gmake libedit libtool lua:52 pkgconfig tar:bz2
+CONFIGURE_ARGS= --enable-dnscrypt --enable-libsodium
INSTALL_TARGET= install-strip
USE_RC_SUBR= dnsdist