aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsflood
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-17 20:18:11 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-17 20:18:11 +0000
commit5791c1c68a4d5b0ebe2e1235a66d96cbe22a3c50 (patch)
tree1f99e7e90e04f270a42ca582b7d86535d4bd65f8 /dns/dnsflood
parentd4107afed20259ebc2a1260e02e81a60583b5b18 (diff)
downloadports-5791c1c68a4d5b0ebe2e1235a66d96cbe22a3c50.tar.gz
ports-5791c1c68a4d5b0ebe2e1235a66d96cbe22a3c50.zip
Add dnsflood 1.08
DNS Flood Detector was developed to detect abusive usage levels on high traffic nameservers and to enable quick response in halting the use of one's nameserver to facilitate spam.
Notes
Notes: svn path=/head/; revision=91529
Diffstat (limited to 'dns/dnsflood')
-rw-r--r--dns/dnsflood/Makefile40
-rw-r--r--dns/dnsflood/distinfo1
-rw-r--r--dns/dnsflood/pkg-descr5
-rw-r--r--dns/dnsflood/pkg-plist3
4 files changed, 49 insertions, 0 deletions
diff --git a/dns/dnsflood/Makefile b/dns/dnsflood/Makefile
new file mode 100644
index 000000000000..e641221b0044
--- /dev/null
+++ b/dns/dnsflood/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: dnsflood
+# Date created: 17.10.2003
+# Whom: krion
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnsflood
+PORTVERSION= 1.08
+CATEGORIES= dns
+MASTER_SITES= http://www.adotout.com/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= DNS flood detector
+
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/dns_flood_detector
+
+pre-patch:
+ ${CP} ${WRKSRC}/makefiles/Makefile-FreeBSD ${WRKSRC}/Makefile
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dns_flood_detector ${PREFIX}/sbin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/dnsflood/distinfo b/dns/dnsflood/distinfo
new file mode 100644
index 000000000000..02377dd8e4b0
--- /dev/null
+++ b/dns/dnsflood/distinfo
@@ -0,0 +1 @@
+MD5 (dnsflood-1.08.tgz) = a7f80312839508eec1dbbbc0767d0001
diff --git a/dns/dnsflood/pkg-descr b/dns/dnsflood/pkg-descr
new file mode 100644
index 000000000000..e9af90a2d2c6
--- /dev/null
+++ b/dns/dnsflood/pkg-descr
@@ -0,0 +1,5 @@
+DNS Flood Detector was developed to detect abusive usage levels
+on high traffic nameservers and to enable quick response in
+halting the use of one's nameserver to facilitate spam.
+
+WWW: http://www.adotout.com/
diff --git a/dns/dnsflood/pkg-plist b/dns/dnsflood/pkg-plist
new file mode 100644
index 000000000000..4c871ae04fcb
--- /dev/null
+++ b/dns/dnsflood/pkg-plist
@@ -0,0 +1,3 @@
+sbin/dns_flood_detector
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%