aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsmasq
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-21 21:56:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-21 21:56:54 +0000
commitfcc4bbdec11e57d5879b8ffe07b0e2a37d7a9e65 (patch)
treea81ea99f5e6df4fb555bdd2974bc9ce05e8da58a /dns/dnsmasq
parentdfeaf523bb5d51da8a7c4625fe81628d1cb53140 (diff)
downloadports-fcc4bbdec11e57d5879b8ffe07b0e2a37d7a9e65.tar.gz
ports-fcc4bbdec11e57d5879b8ffe07b0e2a37d7a9e65.zip
Switch to use lua 5.2
Notes
Notes: svn path=/head/; revision=351724
Diffstat (limited to 'dns/dnsmasq')
-rw-r--r--dns/dnsmasq/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 46988a70c3cb..a9e896718981 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -72,8 +72,8 @@ LDFLAGS+= `pkg-config --libs dbus-1`
.if ${PORT_OPTIONS:MLUA}
CPPFLAGS+= -I${LUA_INCDIR}
CFLAGS+= -DHAVE_LUASCRIPT
-LDFLAGS+= -L${LUA_LIBDIR} -llua
-USE_LUA= 5.1
+LDFLAGS+= -L${LUA_LIBDIR} -llua-${LUA_VER}
+USES+= lua
.endif
.if ${PORT_OPTIONS:MDNSSEC}
@@ -89,7 +89,7 @@ USE_RC_SUBR= dnsmasq
LDFLAGS+= -L${LOCALBASE}/lib ${_intllibs} ${ICONV_LIB}
post-patch:
- ${REINPLACE_CMD} -e "s/lua5\.1/lua-5.1/" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s/lua5\.1/lua-${LUA_VER}/" ${WRKSRC}/Makefile
pre-configure: pretty-print-config
@${PRINTF} "dns/libidn config: " ; ${MAKE} -C ${PORTSDIR}/dns/libidn pretty-print-config