aboutsummaryrefslogtreecommitdiff
path: root/dns/maradns
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 06:04:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 06:04:01 +0000
commite28630ead26369af9ef1d199ae48177e0e2486ae (patch)
treec38809fe289a3882c872d743e8cfe274cca486f2 /dns/maradns
parentb53889dd48ab786160430cf4dc54b1562318d476 (diff)
downloadports-e28630ead26369af9ef1d199ae48177e0e2486ae.tar.gz
ports-e28630ead26369af9ef1d199ae48177e0e2486ae.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39668 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Notes
Notes: svn path=/head/; revision=61772
Diffstat (limited to 'dns/maradns')
-rw-r--r--dns/maradns/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/dns/maradns/Makefile b/dns/maradns/Makefile
index 7ca726bca563..20c2ef5a0796 100644
--- a/dns/maradns/Makefile
+++ b/dns/maradns/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://www.maradns.org/download/ \
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
USE_BZIP2= yes
MAKE_ENV= FLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
@@ -22,9 +24,9 @@ MAN5= mararc.5
MAN8= maradns.8 zoneserver.8
post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
's|/etc/mara|${PREFIX}/etc/mara|g'
- @${FIND} ${WRKSRC} -name '*Makefile*' | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name '*Makefile*' | ${XARGS} ${REINPLACE_CMD} -e \
's|make|\$$\{MAKE\}|g ; \
s|^FLAGS =|#FLAGS =|g ; \
s|-lpthread|${PTHREAD_LIBS}|g'