aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns-ng
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-04-07 15:50:42 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-04-07 15:50:42 +0000
commita14c4892781fae06aa8299e5e12005a7e140f4b0 (patch)
treebdecd1ccaaf59ffd053eeb76ffd5adb5b3ec374c /dns/mydns-ng
parent545ca687ad3dc17c32e3909a8cf03c4deb33b2a4 (diff)
downloadports-a14c4892781fae06aa8299e5e12005a7e140f4b0.tar.gz
ports-a14c4892781fae06aa8299e5e12005a7e140f4b0.zip
Update net/mydns to 0.9.9
PR: 50668 and 50676 Submitted by: Alex Dupre <sysadmin@alexdupre.com> Simon Dick <simond@irrelevant.org>
Notes
Notes: svn path=/head/; revision=78523
Diffstat (limited to 'dns/mydns-ng')
-rw-r--r--dns/mydns-ng/Makefile39
-rw-r--r--dns/mydns-ng/distinfo2
-rw-r--r--dns/mydns-ng/pkg-message1
-rw-r--r--dns/mydns-ng/pkg-plist46
4 files changed, 24 insertions, 64 deletions
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index b806a61af125..8b801d3b4630 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -6,56 +6,53 @@
#
PORTNAME= mydns
-PORTVERSION= 0.9.7
+PORTVERSION= 0.9.9
CATEGORIES= net databases
MASTER_SITES= http://mydns.bboy.net/download/
MAINTAINER= simond@irrelevant.org
COMMENT= DNS server designed to utilize the MySQL database
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/iconv
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-confdir=${PREFIX}/etc --without-libiconv-prefix
+CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
+USE_LIBTOOL= yes
USE_BZIP2= yes
USE_REINPLACE= yes
MAN5= mydns.conf.5
MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8
-DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART README TODO
+DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART README TODO
.include <bsd.port.pre.mk>
.if defined (WITH_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
-CONFIGURE_ARGS+= --without-mysql
-PKGNAMESUFFIX= -pg
+LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql7
+CONFIGURE_ARGS+=--without-mysql
+PKGNAMESUFFIX= -pg
.else
+#LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--without-pgsql
+PKGNAMESUFFIX= -mysql
+.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.10)
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+= --without-pgsql
-PKGNAMESUFFIX= -mysql
-.endif
-
-.if !defined(NOPORTDOCS)
-USE_PERL5= yes
.else
-pre-configure:
- @${REINPLACE_CMD} -E -e "s|^(all: vars manpages info) html-doc|\1|" \
- ${WRKSRC}/doc/Makefile.in
+LIB_DEPENDS= mysqlclient.12:${PORTSDIR}/databases/mysql40-client
+.endif
.endif
-
-post-build:
- cd ${WRKSRC}/doc && ${MAKE} html
post-install:
@${SED} 's|%%%PREFIX%%%|${PREFIX}|g' < ${FILESDIR}/mydns.sh > ${WRKSRC}/mydns.sh
@${INSTALL_SCRIPT} ${WRKSRC}/mydns.sh ${PREFIX}/etc/rc.d/mydns.sh.sample
@install-info ${PREFIX}/info/mydns.info ${PREFIX}/info/dir
.if !defined(NOPORTDOCS)
- @${INSTALL} -d -m 0755 ${DOCSDIR}/html ${DOCSDIR}/contrib
+ @${MKDIR} ${DOCSDIR}/contrib
.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
.endfor
- @${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}/html/
@${INSTALL_DATA} ${WRKSRC}/contrib/admin.php ${DOCSDIR}/contrib/
@${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/contrib/
.endif
diff --git a/dns/mydns-ng/distinfo b/dns/mydns-ng/distinfo
index 1c79f23ae94c..d07933adab16 100644
--- a/dns/mydns-ng/distinfo
+++ b/dns/mydns-ng/distinfo
@@ -1 +1 @@
-MD5 (mydns-0.9.7.tar.bz2) = aa41668f642b059eba7588200a38f1ee
+MD5 (mydns-0.9.9.tar.bz2) = 3eae2e08ddf0434a5bb969945ffe00c6
diff --git a/dns/mydns-ng/pkg-message b/dns/mydns-ng/pkg-message
index 48717a98c046..4f3257e1e60c 100644
--- a/dns/mydns-ng/pkg-message
+++ b/dns/mydns-ng/pkg-message
@@ -5,4 +5,3 @@ installed sample file. Following that you will need to setup your
database tables, you can use the output of
%%%PREFIX%%%/sbin/mydns --create-tables
as a template.
-
diff --git a/dns/mydns-ng/pkg-plist b/dns/mydns-ng/pkg-plist
index cb071b949cdc..93de748a7fba 100644
--- a/dns/mydns-ng/pkg-plist
+++ b/dns/mydns-ng/pkg-plist
@@ -1,15 +1,15 @@
+bin/mydnscheck
+bin/mydnsexport
+bin/mydnsimport
etc/mydns.conf.sample
etc/rc.d/mydns.sh.sample
@unexec install-info --delete %D/info/mydns.info %D/info/dir
info/mydns.info
@exec install-info %D/info/mydns.info %D/info/dir
-bin/mydnscheck
-bin/mydnsexport
-bin/mydnsimport
+sbin/mydns
share/locale/es/LC_MESSAGES/mydns.mo
-share/locale/pt_BR/LC_MESSAGES/mydns.mo
share/locale/fr/LC_MESSAGES/mydns.mo
-sbin/mydns
+share/locale/pt_BR/LC_MESSAGES/mydns.mo
%%PORTDOCS%%share/doc/mydns/AUTHORS
%%PORTDOCS%%share/doc/mydns/COPYING
%%PORTDOCS%%share/doc/mydns/ChangeLog
@@ -19,41 +19,5 @@ sbin/mydns
%%PORTDOCS%%share/doc/mydns/TODO
%%PORTDOCS%%share/doc/mydns/contrib/README
%%PORTDOCS%%share/doc/mydns/contrib/admin.php
-%%PORTDOCS%%share/doc/mydns/html/Building-the-source.html
-%%PORTDOCS%%share/doc/mydns/html/Cache-options.html
-%%PORTDOCS%%share/doc/mydns/html/Caching.html
-%%PORTDOCS%%share/doc/mydns/html/Configuration.html
-%%PORTDOCS%%share/doc/mydns/html/Creating-mydns.conf.html
-%%PORTDOCS%%share/doc/mydns/html/Database-options.html
-%%PORTDOCS%%share/doc/mydns/html/Database.html
-%%PORTDOCS%%share/doc/mydns/html/GNU-Free-Documentation-License.html
-%%PORTDOCS%%share/doc/mydns/html/General-options.html
-%%PORTDOCS%%share/doc/mydns/html/Index.html
-%%PORTDOCS%%share/doc/mydns/html/Installation.html
-%%PORTDOCS%%share/doc/mydns/html/Introduction.html
-%%PORTDOCS%%share/doc/mydns/html/Load-balancing.html
-%%PORTDOCS%%share/doc/mydns/html/Misc-options.html
-%%PORTDOCS%%share/doc/mydns/html/Optional-columns.html
-%%PORTDOCS%%share/doc/mydns/html/Preparing-the-database.html
-%%PORTDOCS%%share/doc/mydns/html/RFC-1034.html
-%%PORTDOCS%%share/doc/mydns/html/References.html
-%%PORTDOCS%%share/doc/mydns/html/Round-robin.html
-%%PORTDOCS%%share/doc/mydns/html/Server.html
-%%PORTDOCS%%share/doc/mydns/html/Signals.html
-%%PORTDOCS%%share/doc/mydns/html/TCP-support.html
-%%PORTDOCS%%share/doc/mydns/html/Troubleshooting.html
-%%PORTDOCS%%share/doc/mydns/html/Utilities.html
-%%PORTDOCS%%share/doc/mydns/html/Zone-transfers.html
-%%PORTDOCS%%share/doc/mydns/html/any.active.html
-%%PORTDOCS%%share/doc/mydns/html/in-addr.arpa.html
-%%PORTDOCS%%share/doc/mydns/html/index.html
-%%PORTDOCS%%share/doc/mydns/html/mydnscheck.html
-%%PORTDOCS%%share/doc/mydns/html/mydnsexport.html
-%%PORTDOCS%%share/doc/mydns/html/mydnsimport.html
-%%PORTDOCS%%share/doc/mydns/html/ptr-table.html
-%%PORTDOCS%%share/doc/mydns/html/rr-table.html
-%%PORTDOCS%%share/doc/mydns/html/soa-table.html
-%%PORTDOCS%%share/doc/mydns/html/soa.xfer.html
-%%PORTDOCS%%@dirrm share/doc/mydns/html
%%PORTDOCS%%@dirrm share/doc/mydns/contrib
%%PORTDOCS%%@dirrm share/doc/mydns