aboutsummaryrefslogtreecommitdiff
path: root/dns/noip
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-31 14:55:54 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-31 14:55:54 +0000
commit912d761183d8a4bb59af2311b8bd8d92e2303281 (patch)
treebce18a8fb811e6568bbdc023f1773aac10fe2a1c /dns/noip
parent34d680e05b597a7e67b4dda6744af79b1b6c0ad6 (diff)
downloadports-912d761183d8a4bb59af2311b8bd8d92e2303281.tar.gz
ports-912d761183d8a4bb59af2311b8bd8d92e2303281.zip
- update to 2.1.3
- grab maintainership PR: ports/104528 Submitted by: maintainer (Kay Abendroth)
Notes
Notes: svn path=/head/; revision=175838
Diffstat (limited to 'dns/noip')
-rw-r--r--dns/noip/Makefile5
-rw-r--r--dns/noip/distinfo6
-rw-r--r--dns/noip/files/patch-Makefile6
-rw-r--r--dns/noip/files/patch-noip2.c16
4 files changed, 16 insertions, 17 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index 34dc966d2138..96df420fc122 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= noip
-PORTVERSION= 2.1.1
-PORTREVISION= 2
+PORTVERSION= 2.1.3
CATEGORIES= dns
MASTER_SITES= http://www.no-ip.com/client/linux/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kay.abendroth@raxion.net
COMMENT= No-IP.com's dynamic DNS update client
ALL_TARGET= noip2
diff --git a/dns/noip/distinfo b/dns/noip/distinfo
index acb4dc63b33b..41d6f7a109ff 100644
--- a/dns/noip/distinfo
+++ b/dns/noip/distinfo
@@ -1,3 +1,3 @@
-MD5 (noip-2.1.1.tar.gz) = 8eb89e31dd2c1fbbf91862efe67c99fd
-SHA256 (noip-2.1.1.tar.gz) = 7750b91d1201807a9bce6602209167ad6a1c57d8b6befe4c41a24bdb7d5dcbb0
-SIZE (noip-2.1.1.tar.gz) = 71210
+MD5 (noip-2.1.3.tar.gz) = 550601f1891c8900439e2404b7d27418
+SHA256 (noip-2.1.3.tar.gz) = 1b72ab33cd9b84b19eb08ca7c4358ce192789255e656d105cb8b508f6c5c1395
+SIZE (noip-2.1.3.tar.gz) = 101286
diff --git a/dns/noip/files/patch-Makefile b/dns/noip/files/patch-Makefile
index 685fc7cd614b..db28f5529f7d 100644
--- a/dns/noip/files/patch-Makefile
+++ b/dns/noip/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Aug 2 05:56:55 2003
-+++ Makefile Wed Nov 30 01:35:17 2005
+--- Makefile.orig Wed Oct 18 11:13:47 2006
++++ Makefile Wed Oct 18 11:16:45 2006
@@ -1,13 +1,13 @@
TGT=noip2
-CC=gcc
@@ -18,7 +18,7 @@
+#LIBS=
+#ARCH=linux
- # for BSD systems that have getifaddr(), uncomment the next line
+ # for Mac OS X and BSD systems that have getifaddr(), uncomment the next line
#ARCH=bsd_with_getifaddrs
@@ -21,7 +21,7 @@
# ARCH=sun
diff --git a/dns/noip/files/patch-noip2.c b/dns/noip/files/patch-noip2.c
index fa545bab814d..ebdc8f1e7270 100644
--- a/dns/noip/files/patch-noip2.c
+++ b/dns/noip/files/patch-noip2.c
@@ -1,15 +1,15 @@
---- noip2.c.orig Fri Jan 9 06:18:39 2004
-+++ noip2.c Thu Jan 29 12:45:11 2004
-@@ -156,7 +156,7 @@
+--- noip2.c.orig Fri Feb 24 16:45:23 2006
++++ noip2.c Wed Oct 18 11:12:03 2006
+@@ -170,7 +170,7 @@
#define CLIENT_IP_PORT 8245
- #define VERSION "2.1.1"
+ #define VERSION "2.1.3"
-#define USER_AGENT "User-Agent: Linux-DUC/"VERSION
+#define USER_AGENT "User-Agent: FreeBSD-DUC/"VERSION
#define SETTING_SCRIPT "settings.php?"
#define USTRNG "username="
#define PWDSTRNG "&pass="
-@@ -264,7 +264,7 @@
+@@ -278,7 +278,7 @@
#define CMSG21 "Please select the Internet interface from this list.\n"
#define CMSG22 "By typing the number associated with it."
#define CMSG23 "Too many network devices. Limit is %d"
@@ -18,7 +18,7 @@
#define CMSG25 "Can't create config file (%s)"
#define CMSG25a "Re-run noip, adding '-c configfilename' as a parameter."
#define CMSG26 "Can't rename config file (%s)"
-@@ -466,7 +466,7 @@
+@@ -484,7 +484,7 @@
fprintf(stderr, "[ -d][ -D pid]");
#endif
fprintf(stderr, "[ -i addr][ -S][ -M][ -h]");
@@ -27,8 +27,8 @@
fprintf(stderr, "Options: -C create configuration data\n");
fprintf(stderr, " -F force NAT off\n");
fprintf(stderr, " -Y select all hosts/groups\n");
-@@ -1984,17 +1984,12 @@
- dq = devs; // point at name list
+@@ -2040,17 +2040,12 @@
+ dq = (unsigned char *)devs; // point at name list
for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
if (ifa->ifa_addr->sa_family == AF_LINK) {
-// FreeBSD doesn't define some of these!