aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-Net-Domain-ExpireDate
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-03-04 02:07:30 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-03-04 02:07:30 +0000
commit82f5ebe210903ab2c769dd1aec21adca16c796bb (patch)
tree447f500961cd35ed0f206e15c19785928acf963d /dns/p5-Net-Domain-ExpireDate
parent4cf0b5fc8fb52cdf989e290c7fb45fba6ee97f09 (diff)
downloadports-82f5ebe210903ab2c769dd1aec21adca16c796bb.tar.gz
ports-82f5ebe210903ab2c769dd1aec21adca16c796bb.zip
- obtain expiration date of domain names
e.g. use Net::Domain::ExpireDate; $expiration_obj = expire_date( 'microsoft.com' );
Notes
Notes: svn path=/head/; revision=130306
Diffstat (limited to 'dns/p5-Net-Domain-ExpireDate')
-rw-r--r--dns/p5-Net-Domain-ExpireDate/Makefile26
-rw-r--r--dns/p5-Net-Domain-ExpireDate/distinfo2
-rw-r--r--dns/p5-Net-Domain-ExpireDate/pkg-descr12
-rw-r--r--dns/p5-Net-Domain-ExpireDate/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/dns/p5-Net-Domain-ExpireDate/Makefile b/dns/p5-Net-Domain-ExpireDate/Makefile
new file mode 100644
index 000000000000..fc3ce220ab59
--- /dev/null
+++ b/dns/p5-Net-Domain-ExpireDate/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-Domain-ExpireDate
+# Date created: Mar 4 2005
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Domain-ExpireDate
+PORTVERSION= 0.33
+CATEGORIES= dns net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl module obtain expiration date of domain names
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece \
+ ${SITE_PERL}/Net/Whois/Raw.pm:${PORTSDIR}/net/p5-Net-Whois-Raw
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Domain::ExpireDate.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-Domain-ExpireDate/distinfo b/dns/p5-Net-Domain-ExpireDate/distinfo
new file mode 100644
index 000000000000..0dc621dabd57
--- /dev/null
+++ b/dns/p5-Net-Domain-ExpireDate/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-Domain-ExpireDate-0.33.tar.gz) = d80fd23066f05d96718342acebda0ce9
+SIZE (Net-Domain-ExpireDate-0.33.tar.gz) = 7615
diff --git a/dns/p5-Net-Domain-ExpireDate/pkg-descr b/dns/p5-Net-Domain-ExpireDate/pkg-descr
new file mode 100644
index 000000000000..553d04fde36e
--- /dev/null
+++ b/dns/p5-Net-Domain-ExpireDate/pkg-descr
@@ -0,0 +1,12 @@
+Net::Domain::ExpireDate gets WHOIS information of given domain
+using Net::Whois::Raw and tries to obtain expiration date of
+domain. Unfortunately there are too many different whois servers
+which provides whois info in very different formats.
+
+Net::Domain::ExpireDate knows more than 40 different formats of
+expiration date representation provided by different servers (almost
+all gTLD registrars and some ccTLD registrars are covered).
+Now obtaining of domain creation date is also supported.
+
+WWW: http://search.cpan.org/dist/Net-Domain-ExpireDate
+Author: Walery Studennikov
diff --git a/dns/p5-Net-Domain-ExpireDate/pkg-plist b/dns/p5-Net-Domain-ExpireDate/pkg-plist
new file mode 100644
index 000000000000..0c0cdc58d456
--- /dev/null
+++ b/dns/p5-Net-Domain-ExpireDate/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/Domain/ExpireDate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Domain/ExpireDate/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Domain/ExpireDate
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Domain 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net/Domain 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true