aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-Net-LibIDN2/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-26 15:55:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-26 15:55:36 +0000
commit09c19fca41006e8fbac5aa383b9068612c6c8138 (patch)
treebd3c757511d64c1e2c882381d502d60d9308f017 /dns/p5-Net-LibIDN2/Makefile
parentf4094478db6caf77e241d2c2c1ecaa7de6add36a (diff)
downloadports-09c19fca41006e8fbac5aa383b9068612c6c8138.tar.gz
ports-09c19fca41006e8fbac5aa383b9068612c6c8138.zip
Add p5-Net-LibIDN2 1.00
Net::LibIDN2 provides bindings for GNU Libidn2, a C library for handling internationalized domain names based on IDNA 2008, Punycode and TR46. WWW: http://search.cpan.org/dist/Net-LibIDN2/
Notes
Notes: svn path=/head/; revision=450672
Diffstat (limited to 'dns/p5-Net-LibIDN2/Makefile')
-rw-r--r--dns/p5-Net-LibIDN2/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/dns/p5-Net-LibIDN2/Makefile b/dns/p5-Net-LibIDN2/Makefile
new file mode 100644
index 000000000000..b2e18aa54467
--- /dev/null
+++ b/dns/p5-Net-LibIDN2/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Net-LibIDN2
+PORTVERSION= 1.00
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Perl bindings for GNU Libidn2
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libidn2.so:dns/libidn2
+
+USE_PERL5= modbuild
+USES= perl5
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/LibIDN2/LibIDN2.so
+
+.include <bsd.port.mk>