aboutsummaryrefslogtreecommitdiff
path: root/dns/pear-Net_DNS
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-12-22 22:33:52 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-12-22 22:33:52 +0000
commit6690332baad37dac9aec927e52874a0b73eceb88 (patch)
tree1e57f7f67dd6f051272d3da967eba910451b0131 /dns/pear-Net_DNS
parentea9cd6bae8f215939f04731d9c1735a52f95ffa2 (diff)
downloadports-6690332baad37dac9aec927e52874a0b73eceb88.tar.gz
ports-6690332baad37dac9aec927e52874a0b73eceb88.zip
Add pear-Net_DNS 1.0.0, resolver library used to communicate with a DNS
server. PR: ports/107028 Submitted by: chinsan
Notes
Notes: svn path=/head/; revision=180533
Diffstat (limited to 'dns/pear-Net_DNS')
-rw-r--r--dns/pear-Net_DNS/Makefile28
-rw-r--r--dns/pear-Net_DNS/distinfo3
-rw-r--r--dns/pear-Net_DNS/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/dns/pear-Net_DNS/Makefile b/dns/pear-Net_DNS/Makefile
new file mode 100644
index 000000000000..b0058513194c
--- /dev/null
+++ b/dns/pear-Net_DNS/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pear-Net_DNS
+# Date created: 2006/12/22
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_DNS
+PORTVERSION= 1.0.0
+CATEGORIES= dns net pear
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Resolver library used to communicate with a DNS server
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= mhash
+CATEGORY= Net
+FILES= DNS/RR/A.php DNS/RR/AAAA.php DNS/RR/CNAME.php DNS/RR/HINFO.php \
+ DNS/RR/MX.php DNS/RR/NAPTR.php DNS/RR/NS.php DNS/RR/PTR.php \
+ DNS/RR/SOA.php DNS/RR/SRV.php DNS/RR/TSIG.php DNS/RR/TXT.php \
+ DNS/Header.php DNS/Packet.php DNS/Question.php DNS/Resolver.php \
+ DNS/RR.php DNS.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/dns/pear-Net_DNS/distinfo b/dns/pear-Net_DNS/distinfo
new file mode 100644
index 000000000000..3b64d631d863
--- /dev/null
+++ b/dns/pear-Net_DNS/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Net_DNS-1.0.0.tgz) = 1cc082bec28189847083e2c42c2d9b2d
+SHA256 (PEAR/Net_DNS-1.0.0.tgz) = efd9aafa60e2e2e5825fa66d7c2820fc142ddfcaf3286d7b66584f7c75ad10a9
+SIZE (PEAR/Net_DNS-1.0.0.tgz) = 27260
diff --git a/dns/pear-Net_DNS/pkg-descr b/dns/pear-Net_DNS/pkg-descr
new file mode 100644
index 000000000000..a0ce956849de
--- /dev/null
+++ b/dns/pear-Net_DNS/pkg-descr
@@ -0,0 +1,7 @@
+A resolver library used to communicate with a name server to perform DNS
+queries, zone transfers, dynamic DNS updates, etc.
+Creates an object hierarchy from a DNS server response, which allows you to
+view all of the information given by the DNS server. It bypasses the system
+resolver library and communicates directly with the server.
+
+WWW: http://pear.php.net/package/Net_DNS/