aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 10:06:36 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 10:06:36 +0000
commit893b96b99ec5a70a6fd0e7adb4f809b849432801 (patch)
tree5d93ab2d078e7302de40454054a5de149642d98d /dns/powerdns/Makefile
parentd262133db912a40d1e9e274f325fc2dd31640008 (diff)
downloadports-893b96b99ec5a70a6fd0e7adb4f809b849432801.tar.gz
ports-893b96b99ec5a70a6fd0e7adb4f809b849432801.zip
Unbreak powerdns
Change the Makefile so compiling against the LDAP library works again PR: ports/89477 Submitted by: Ralf van der Enden <tremere@cainites.net>
Notes
Notes: svn path=/head/; revision=149403
Diffstat (limited to 'dns/powerdns/Makefile')
-rw-r--r--dns/powerdns/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 14aa741862d4..d7bcf28e2882 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -21,7 +21,7 @@ USE_SUBMAKE= YES
USE_REINPLACE= YES
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
-CXXFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
@@ -86,6 +86,7 @@ PLIST_SUB+= WITHMYSQL="@comment "
USE_OPENLDAP?= YES
CONFIGURE_MODULES+= "ldap"
PLIST_SUB+= WITHLDAP=""
+CXXFLAGS+= -L${LOCALBASE}/lib
.else
PLIST_SUB+= WITHLDAP="@comment "
.endif