aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-24 02:43:51 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-24 02:43:51 +0000
commite3e7faeda310222ae0f96df3ae6b0f113457b84b (patch)
treeba5166e2c135d3e49c6a45a9ee892a2b20fd7f6d /dns
parentf00c79b3aa4b62ad61bb9fcef06e2c03b1b3f088 (diff)
downloadports-e3e7faeda310222ae0f96df3ae6b0f113457b84b.tar.gz
ports-e3e7faeda310222ae0f96df3ae6b0f113457b84b.zip
Fix the adns library version so it matches the internal soname. This sets
the lib version back to 1, but since the dependencies still linked to libadns.so.1 even when the installed file was libadns.so.12, a new PORTREVISION bump is not needed.
Notes
Notes: svn path=/head/; revision=160272
Diffstat (limited to 'dns')
-rw-r--r--dns/adns/Makefile3
-rw-r--r--dns/adns/files/patch-configure2
-rw-r--r--dns/adns/files/patch-configure.in2
-rw-r--r--dns/fastresolve/Makefile2
-rw-r--r--dns/py-adns/Makefile2
5 files changed, 6 insertions, 5 deletions
diff --git a/dns/adns/Makefile b/dns/adns/Makefile
index da428dae8563..a7fab6bd8982 100644
--- a/dns/adns/Makefile
+++ b/dns/adns/Makefile
@@ -7,6 +7,7 @@
PORTNAME= adns
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= ftp://ftp.chiark.greenend.org.uk/users/ian/adns/ \
http://www.chiark.greenend.org.uk/~ian/adns/ftp/
@@ -18,7 +19,7 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-LIBVERSION= 12
+LIBVERSION= 1
PLIST_SUB+= LIBVERSION="${LIBVERSION}"
DOCS= COPYING GPL-vs-LGPL INSTALL LICENCE.WAIVERS README README.html TODO changelog
diff --git a/dns/adns/files/patch-configure b/dns/adns/files/patch-configure
index 2b4bfdac9c7f..cb1c4952408c 100644
--- a/dns/adns/files/patch-configure
+++ b/dns/adns/files/patch-configure
@@ -5,7 +5,7 @@
SHLIBFORLINK='libadns.so'
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
-+SHLIBFILE='$(SHLIBSONAME)$(MINOR)'
++SHLIBFILE='$(SHLIBSONAME)'
SHLIBCC='$(CC) $(CFLAGS) -fpic'
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'
diff --git a/dns/adns/files/patch-configure.in b/dns/adns/files/patch-configure.in
index 9e0b4ab7d960..74b94f6d1b02 100644
--- a/dns/adns/files/patch-configure.in
+++ b/dns/adns/files/patch-configure.in
@@ -5,7 +5,7 @@
SHLIBFORLINK='libadns.so'
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
-+SHLIBFILE='$(SHLIBSONAME)$(MINOR)'
++SHLIBFILE='$(SHLIBSONAME)'
SHLIBCC='$(CC) $(CFLAGS) -fpic'
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index 29459a50444c..18992e72bf99 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.djmnet.org/sw/dist/
MAINTAINER= martin@matuska.org
COMMENT= Programs that process web logs to get DNS and domain ownership info
-LIB_DEPENDS= adns.12:${PORTSDIR}/dns/adns
+LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
USE_BZIP2= yes
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index 3dfcfa6ab0d8..93b5eced4d13 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -16,7 +16,7 @@ DISTNAME= adns-python-${PORTVERSION}
MAINTAINER= perky@FreeBSD.org
COMMENT= A Python Interface to adns, the asynchronous DNS library
-LIB_DEPENDS= adns.12:${PORTSDIR}/dns/adns
+LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
USE_PYTHON= yes
USE_PYDISTUTILS= yes